Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Remove search history from URL bar?

  • 9 réponses
  • 1 a ce problème
  • 290 vues
  • Dernière réponse par cor-el

more options

I've been searching for the answer to this for a couple of hours and nothing has worked. When I start typing in the URL bar, I only want websites I've visited previously to show up, in the order of most frequently visited. It used to do that until a few hours ago. Now instead I get previous search results and bookmarked sites only. Can I change it back to its previous function or will I have to revert to an older version of Firefox?

eta: I figured out how to get the websites to show again, but I still don't want the search history showing up.

Captures d’écran jointes

Modifié le par girlyskin

Solution choisie

Actually, I just updated again and it must've been a glitch in the beta version because now it's back to how it was.

Lire cette réponse dans son contexte 👍 0

Toutes les réponses (9)

more options

Did you check the Search Suggestions settings in "Options/Preferences -> Search" ?

Cela vous a-t-il été utile ?

more options

That seems to only turn off suggestions in the Search bar, not my search history in the address bar.

Cela vous a-t-il été utile ?

more options

Hi, girlyskin

  1. Click on the menu button
  2. , click Library and then click History.
  3. Click Clear Recent History... to open the dialog window.
  4. In the Clear Recent History window, set Time range to clear: to Everything.
  5. Click on the arrow button next to Details to expand a list of items to clear. Make sure Browsing & Download History has a check mark next to it

See https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox

Cela vous a-t-il été utile ?

more options

Hi girlyskin, you might need to turn off Firefox's form and search history feature (those are combined) to suppress these. I'm not sure because previously they only showed up under regular search boxes (like in the new tab page) and not in the address bar drop-down.

If you want to try that out, see the steps in the following article for "Turn off Auto form fill and prevent Firefox from storing more form entries":

Control whether Firefox automatically fills in forms

Cela vous a-t-il été utile ?

more options

Himanshu prabhakar said

5. Click on the arrow button next to Details to expand a list of items to clear. Make sure Browsing & Download History has a check mark next to it

No... search history is combined with form history ("Form & Search History"), which is a completely different checkbox than browsing history.

Cela vous a-t-il été utile ?

more options

jscher2000 said

Hi girlyskin, you might need to turn off Firefox's form and search history feature (those are combined) to suppress these. I'm not sure because previously they only showed up under regular search boxes (like in the new tab page) and not in the address bar drop-down. If you want to try that out, see the steps in the following article for "Turn off Auto form fill and prevent Firefox from storing more form entries": Control whether Firefox automatically fills in forms

That does stop it from appearing in the address bar, but unfortunately also in the search bar, where I want it to show. Thank you anyways. I might just have to revert back to an older version of Firefox.

Cela vous a-t-il été utile ?

more options

Solution choisie

Actually, I just updated again and it must've been a glitch in the beta version because now it's back to how it was.

Cela vous a-t-il été utile ?

more options

For future reference, Firefox 79 (current Nightly) has this preference you can use to suppress search history suggestions in the address bar drop-down specifically. I haven't checked Firefox 78 (current Beta or Developer Edition):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.maxHistoricalSearchSuggestions preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change.

More info on about:config: Configuration Editor for Firefox.

Source: https://www.reddit.com/r/firefox/comments/h87hk6/since_a_recent_update_ff_has_been_showing_my/fup9uru/

Cela vous a-t-il été utile ?

more options

See also:

  • Bug 1643475 - Enable form history / historical searches on 78 release and put them behind the same prefs as remote suggestions

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Cela vous a-t-il été utile ?

Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.