X
Appuyez ici pour vous rendre sur la version mobile du site.

Forum d’assistance

Can't make websites think I speak English

Publié

Ever since the last update to 72.0, websites that change their content according to the browser's language act as if my language is Heberw although I've set all possible settings to English in about:preferences and about:config. Image attached.

I remember that right after the update, there was a message that never came back saying I can choose between Hebrew and English as the language that I'll present as my language to websites. I'm pretty sure I chose English but ever since, it seems the browser is doing the opposite. The most notable damage is that Google searches show up in English.

I've tested **Google searching in safe mode and it works fine**. I've also tested a clean and new profile and I couldn't get Google show up the content in English.

I know that for example Google, allows you to change the language you prefer to use their website. The problem is, that I don't store Google's cookies for the sake of privacy (I have an extension that automatically cleans cookies based on domain) and this setting is stored within a cookie.

In the meantime I've installed the Search extension https://addons.mozilla.org/en-GB/firefox/addon/search-google-us/

Ever since the last update to 72.0, websites that change their content according to the browser's language act as if my language is Heberw although I've set all possible settings to English in about:preferences and about:config. Image attached. I remember that right after the update, there was a message that never came back saying I can choose between Hebrew and English as the language that I'll present as my language to websites. I'm pretty sure I chose English but ever since, it seems the browser is doing the opposite. The most notable damage is that Google searches show up in English. I've tested **Google searching in safe mode and it works fine**. I've also tested a clean and new profile and I couldn't get Google show up the content in English. I know that for example Google, allows you to change the language you prefer to use their website. The problem is, that I don't store Google's cookies for the sake of privacy (I have an extension that automatically cleans cookies based on domain) and this setting is stored within a cookie. In the meantime I've installed the Search extension https://addons.mozilla.org/en-GB/firefox/addon/search-google-us/
Captures d’écran jointes
Citation

Détails additionnels sur le système

Application

  • Agent utilisateur : Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Plus d’informations

cor-el
  • Top 10 Contributor
  • Moderator
17759 solutions 160617 réponses

What is shown on the Help -> Troubleshooting Information page under "Internationalization & Localization" ?

Did you check the language setting in "Options/Preferences -> General -> Language" ?

What is shown on the Help -> Troubleshooting Information page under "Internationalization & Localization" ? Did you check the language setting in "Options/Preferences -> General -> Language" ?
Est-ce que ceci vous a été utile ?
Citation

Auteur de la question

Thanks for commenting @cor-el. The 1st Image is for normal mode and the 2nd image - where `he` doesn't show up once is for safe mode.

Thanks for commenting @cor-el. The 1st Image is for normal mode and the 2nd image - where `he` doesn't show up once is for safe mode.
Est-ce que ceci vous a été utile ?
Citation
cor-el
  • Top 10 Contributor
  • Moderator
17759 solutions 160617 réponses

Are there language packs showing in about:addons -> Languages (if this item is present) ?

Are there language packs showing in about:addons -> Languages (if this item is present) ?
Est-ce que ceci vous a été utile ?
Citation

Auteur de la question

I have both Hebrew and English. I tried to remove the Hebrew one and the `about:support` page stopped showing the `he` as an available locale but the issue still persists. I attached an Image showing the current status of the Internationalisation & Localisation section in about:support.

I have both Hebrew and English. I tried to remove the Hebrew one and the `about:support` page stopped showing the `he` as an available locale but the issue still persists. I attached an Image showing the current status of the Internationalisation & Localisation section in about:support.
Est-ce que ceci vous a été utile ?
Citation
Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.