X
Appuyez ici pour vous rendre sur la version mobile du site.

Forum d’assistance

Video does not play on some sites

Publié

On some sites, the video controls flash intermittently while playing. On one in particular - theguardian.com/uk - embedded video content will not play. The sound will, but the picture won't. I've done seemingly everything - disable hardware acceleration, messed about with tracking, blocking, permissions, extensions, plugins, reset that site, refreshed Firefox. Nothing works. I've been using Firefox happily for over a decade, but this is severely testing my faith and allegiance. I'm using a 2019 Mac, but Apple say it's not their problem. The protracted steps I had to take to even get to this page on this forum have seriously tested my patience. Please, Firefox - how can I fix this?

On some sites, the video controls flash intermittently while playing. On one in particular - theguardian.com/uk - embedded video content will not play. The sound will, but the picture won't. I've done seemingly everything - disable hardware acceleration, messed about with tracking, blocking, permissions, extensions, plugins, reset that site, refreshed Firefox. Nothing works. I've been using Firefox happily for over a decade, but this is severely testing my faith and allegiance. I'm using a 2019 Mac, but Apple say it's not their problem. The protracted steps I had to take to even get to this page on this forum have seriously tested my patience. Please, Firefox - how can I fix this?
Citation

Détails additionnels sur le système

Application

  • Agent utilisateur : Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:69.0) Gecko/20100101 Firefox/69.0

Plus d’informations

WestEnd
  • Top 25 Contributor
60 solutions 5379 réponses

Could be related to this popup message:

Your privacy

We use cookies to improve your experience on our site and to show you personalised advertising.

To find out more, read our privacy policy and cookie policy.

Blocking cookies or trackers can also have problem loadings. Or your Flash plugin is bad. And also depends on how firefox was installed or customized after it installed from default.

Could be related to this popup message: Your privacy We use cookies to improve your experience on our site and to show you personalised advertising. To find out more, read our privacy policy and cookie policy. Blocking cookies or trackers can also have problem loadings. Or your Flash plugin is bad. And also depends on how firefox was installed or customized after it installed from default.
Est-ce que ceci vous a été utile ? 1
Citation
Chris Ilias
  • Moderator
354 solutions 1944 réponses

Réponse utile

Hi, I have a 2019 Mac, and I have just tried a couple of videos at https://www.theguardian.com/video , and I was able to access the controls and hear the sound.

Your Firefox settings and info are kept in a folder separate from the Firefox program, called your profile folder. As a troubleshooting step, try creating a test profile, to see if the problem still occurs. See Profile Manager - Create, remove, or switch Firefox profiles.

Hi, I have a 2019 Mac, and I have just tried a couple of videos at https://www.theguardian.com/video , and I was able to access the controls and hear the sound. Your Firefox settings and info are kept in a folder separate from the Firefox program, called your profile folder. As a troubleshooting step, try creating a test profile, to see if the problem still occurs. See [[Managing profiles]].
Est-ce que ceci vous a été utile ? 1
Citation
cor-el
  • Top 10 Contributor
  • Moderator
17479 solutions 157962 réponses

You can also check the Web Console and possibly the Browser Console for media related messages.

You can also check the Web Console and possibly the Browser Console for media related messages. *https://developer.mozilla.org/en-US/Tools/Web_Console *https://developer.mozilla.org/en-US/Tools/Browser_Console
Est-ce que ceci vous a été utile ?
Citation

Auteur de la question

Chris Ilias said

Hi, I have a 2019 Mac, and I have just tried a couple of videos at https://www.theguardian.com/video , and I was able to access the controls and hear the sound. Your Firefox settings and info are kept in a folder separate from the Firefox program, called your profile folder. As a troubleshooting step, try creating a test profile, to see if the problem still occurs. See Profile Manager - Create, remove, or switch Firefox profiles.

Thank you. This sounds good. It never happened on my old 2010 MacBook Pro, and it wouldn't be the only issue that has caused problems since I set up the new Mac from an old, pre-Mojave backup. Is there a way to restore Firefox to factory settings and keep passwords? Refreshing Firefox doesn't seem to do it; and setting up a test profile sounds quite complex.

''Chris Ilias [[#answer-1252164|said]]'' <blockquote> Hi, I have a 2019 Mac, and I have just tried a couple of videos at https://www.theguardian.com/video , and I was able to access the controls and hear the sound. Your Firefox settings and info are kept in a folder separate from the Firefox program, called your profile folder. As a troubleshooting step, try creating a test profile, to see if the problem still occurs. See [[Managing profiles]]. </blockquote> Thank you. This sounds good. It never happened on my old 2010 MacBook Pro, and it wouldn't be the only issue that has caused problems since I set up the new Mac from an old, pre-Mojave backup. Is there a way to restore Firefox to factory settings and keep passwords? Refreshing Firefox doesn't seem to do it; and setting up a test profile sounds quite complex.
Est-ce que ceci vous a été utile ?
Citation

Auteur de la question

WestEnd said

And also depends on how firefox was installed or customized after it installed from default.

The above sentence seems pertinent, as it never happened on my previous, pre-Mojave Mac.

''WestEnd [[#answer-1252127|said]]'' <blockquote> And also depends on how firefox was installed or customized after it installed from default. </blockquote> The above sentence seems pertinent, as it never happened on my previous, pre-Mojave Mac.
Est-ce que ceci vous a été utile ?
Citation
Chris Ilias
  • Moderator
354 solutions 1944 réponses

Réponse utile

Here are the instructions:

  1. In the address bar, type the following address: about:profiles
  2. Press Return.
  3. Click on [Create a new profile].
  4. Click [Continue]
  5. Name your profile TEST, then click [Done]. Your new profile will appear in the about:profiles list.
  6. Scroll down to the TEST profile in the list, and click [Launch profile in new browser].

A separate instance of Firefox will load, which will also appear separately in the dock.

If the problem does not occur in the new profile, we can help you transfer your passwords.

Here are the instructions: # In the address bar, type the following address: '''about:profiles''' # Press '''Return'''. # Click on '''[Create a new profile]'''. # Click '''[Continue]''' # Name your profile ''TEST'', then click '''[Done]'''. Your new profile will appear in the about:profiles list. # Scroll down to the ''TEST'' profile in the list, and click '''[Launch profile in new browser]'''. A separate instance of Firefox will load, which will also appear separately in the dock. If the problem does not occur in the new profile, we can help you transfer your passwords.
Est-ce que ceci vous a été utile ? 1
Citation

Auteur de la question

Chris Ilias said

Here are the instructions:
  1. In the address bar, type the following address: about:profiles
  2. Press Return.
  3. Click on [Create a new profile].
  4. Click [Continue]
  5. Name your profile TEST, then click [Done]. Your new profile will appear in the about:profiles list.
  6. Scroll down to the TEST profile in the list, and click [Launch profile in new browser].
A separate instance of Firefox will load, which will also appear separately in the dock. If the problem does not occur in the new profile, we can help you transfer your passwords.

I think this works! It certainly seems better so far. Firstly, thank you! Secondly, what next? Is there a way to import my bookmarks?

''Chris Ilias [[#answer-1252547|said]]'' <blockquote> Here are the instructions: # In the address bar, type the following address: '''about:profiles''' # Press '''Return'''. # Click on '''[Create a new profile]'''. # Click '''[Continue]''' # Name your profile ''TEST'', then click '''[Done]'''. Your new profile will appear in the about:profiles list. # Scroll down to the ''TEST'' profile in the list, and click '''[Launch profile in new browser]'''. A separate instance of Firefox will load, which will also appear separately in the dock. If the problem does not occur in the new profile, we can help you transfer your passwords. </blockquote> I think this works! It certainly seems better so far. Firstly, thank you! Secondly, what next? Is there a way to import my bookmarks?
Est-ce que ceci vous a été utile ?
Citation

Auteur de la question

Bookmarks and passwords done. Thank you - I think it's fixed. You've been very very helpful.

Bookmarks and passwords done. Thank you - I think it's fixed. You've been very very helpful.
Est-ce que ceci vous a été utile ?
Citation

Auteur de la question

Oh dear. The next day and the problem is back. Videos that played yesterday don't today. Maybe Catlina will fix it. Ugh.

Oh dear. The next day and the problem is back. Videos that played yesterday don't today. Maybe Catlina will fix it. Ugh.
Est-ce que ceci vous a été utile ?
Citation
Chris Ilias
  • Moderator
354 solutions 1944 réponses

Actually, that might help identify the culprit. What changes have you made in the past day? ☺️

Actually, that might help identify the culprit. What changes have you made in the past day? ☺️
Est-ce que ceci vous a été utile ?
Citation

Auteur de la question

Chris Ilias said

Actually, that might help identify the culprit. What changes have you made in the past day? ☺️

I was too scared to change anything. All I did was run Disk Utility. *Some* videos work.

''Chris Ilias [[#answer-1252839|said]]'' <blockquote> Actually, that might help identify the culprit. What changes have you made in the past day? ☺️ </blockquote> I was too scared to change anything. All I did was run Disk Utility. *Some* videos work.
Est-ce que ceci vous a été utile ?
Citation

Auteur de la question

This one, for example, doesn't. Sound only. https://www.theguardian.com/law/2019/sep/17/government-declines-to-rule-out-fresh-prorogation-if-it-loses-case
Est-ce que ceci vous a été utile ?
Citation
Chris Ilias
  • Moderator
354 solutions 1944 réponses

I have just tested that URL, and it works for me. I recorded my test , which you can view at the following URL: https://www.youtube.com/watch?v=NiMguTpBRfQ

If I understand correctly, it doesn't work for you one day after creating a new profile. You said that you didn't change anything. What about importing data? Did you import any user data from your old profile, or sync to your Firefox account?

I have just tested that URL, and it works for me. I recorded my test , which you can view at the following URL: https://www.youtube.com/watch?v=NiMguTpBRfQ If I understand correctly, it doesn't work for you one day after creating a new profile. You said that you didn't change anything. What about importing data? Did you import any user data from your old profile, or sync to your Firefox account?
Est-ce que ceci vous a été utile ?
Citation

Auteur de la question

Chris Ilias said

I have just tested that URL, and it works for me. I recorded my test , which you can view at the following URL: https://www.youtube.com/watch?v=NiMguTpBRfQ If I understand correctly, it doesn't work for you one day after creating a new profile. You said that you didn't change anything. What about importing data? Did you import any user data from your old profile, or sync to your Firefox account?

I may have synced, now that you mention it.

''Chris Ilias [[#answer-1253052|said]]'' <blockquote> I have just tested that URL, and it works for me. I recorded my test , which you can view at the following URL: https://www.youtube.com/watch?v=NiMguTpBRfQ If I understand correctly, it doesn't work for you one day after creating a new profile. You said that you didn't change anything. What about importing data? Did you import any user data from your old profile, or sync to your Firefox account? </blockquote> I may have synced, now that you mention it.
Est-ce que ceci vous a été utile ?
Citation
cor-el
  • Top 10 Contributor
  • Moderator
17479 solutions 157962 réponses

Did you check the Web Console for media related messages like I suggested above ?

  • "3-bar" menu button or Tools -> Web Developer
Did you check the Web Console for media related messages like I suggested above ? *"3-bar" menu button or Tools -> Web Developer
Est-ce que ceci vous a été utile ?
Citation

Auteur de la question

Chris Ilias said

I have just tested that URL, and it works for me. I recorded my test , which you can view at the following URL: https://www.youtube.com/watch?v=NiMguTpBRfQ If I understand correctly, it doesn't work for you one day after creating a new profile. You said that you didn't change anything. What about importing data? Did you import any user data from your old profile, or sync to your Firefox account?

I just created a new test profile again, didn't sign in, didn't sync, imported all my bookmarks and manually reset my passwords, closed the browser and started it again.

Same old problem.

I'm close to giving up. I have a dim hope that Catalina may fix it; otherwise it may well have to be goodbye to a decade-plus of hitherto flawless browsing. Any last recommendations, anyone?

''Chris Ilias [[#answer-1253052|said]]'' <blockquote> I have just tested that URL, and it works for me. I recorded my test , which you can view at the following URL: https://www.youtube.com/watch?v=NiMguTpBRfQ If I understand correctly, it doesn't work for you one day after creating a new profile. You said that you didn't change anything. What about importing data? Did you import any user data from your old profile, or sync to your Firefox account? </blockquote> I just created a new test profile again, didn't sign in, didn't sync, imported all my bookmarks and manually reset my passwords, closed the browser and started it again. Same old problem. I'm close to giving up. I have a dim hope that Catalina may fix it; otherwise it may well have to be goodbye to a decade-plus of hitherto flawless browsing. Any last recommendations, anyone?
Est-ce que ceci vous a été utile ?
Citation

Auteur de la question

cor-el said

Did you check the Web Console for media related messages like I suggested above ?
  • "3-bar" menu button or Tools -> Web Developer

I don't really know what this means. But I'll try.

''cor-el [[#answer-1253294|said]]'' <blockquote> Did you check the Web Console for media related messages like I suggested above ? *"3-bar" menu button or Tools -> Web Developer </blockquote> I don't really know what this means. But I'll try.
Est-ce que ceci vous a été utile ?
Citation

Auteur de la question

Screenshot included after checking Web Console.

Screenshot included after checking Web Console.

Modifié le par lucashare

Est-ce que ceci vous a été utile ?
Citation
cor-el
  • Top 10 Contributor
  • Moderator
17479 solutions 157962 réponses

The screenshot shows the Web Console with the SUMO website. The console shows info for the currently select tab.

Can you post a screenshot of the Web Console on a website with the video problem ?

The screenshot shows the Web Console with the SUMO website. The console shows info for the currently select tab. Can you post a screenshot of the Web Console on a website with the video problem ?
Est-ce que ceci vous a été utile ? 1
Citation

Auteur de la question

Ah, gotcha. Here you go:

Ah, gotcha. Here you go:
Est-ce que ceci vous a été utile ?
Citation
Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.