X
Appuyez ici pour vous rendre sur la version mobile du site.

Forum d’assistance

[BUG] Drop-down url menu can not be edited since new v68

Publié
This way does not work anymore https://support.mozilla.org/en-US/questions/1220341

Solution choisie

Works for me, although you need to press Shift+Delete for it to work. However, it's important to note that you can only delete History items using this method. You cannot remove search engine suggestions, bookmarks or open tabs.

Hope this helps.

Lire cette réponse dans son contexte 1
Citation

Détails additionnels sur le système

Application

  • Agent utilisateur : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Plus d’informations

Wesley Branton
  • Top 10 Contributor
646 solutions 5253 réponses

Solution choisie

Works for me, although you need to press Shift+Delete for it to work. However, it's important to note that you can only delete History items using this method. You cannot remove search engine suggestions, bookmarks or open tabs.

Hope this helps.

Works for me, although you need to press Shift+Delete for it to work. However, it's important to note that you can only delete History items using this method. You cannot remove search engine suggestions, bookmarks or open tabs. Hope this helps.
Est-ce que ceci vous a été utile ? 1
Citation

Auteur de la question

Wesley Branton said

Works for me, although you need to press Shift+Delete for it to work.

Oh, gods, again Mozilla changed critical feature without any warnings. Why even simply move from Del to shift-del... What was so bad in it... How an I supposed to learn about it... Pff

''Wesley Branton [[#answer-1236182|said]]'' <blockquote> Works for me, although you need to press Shift+Delete for it to work. </blockquote> Oh, gods, again Mozilla changed critical feature without any warnings. Why even simply move from Del to shift-del... What was so bad in it... How an I supposed to learn about it... Pff
Est-ce que ceci vous a été utile ?
Citation
jscher2000
  • Top 10 Contributor
8794 solutions 71943 réponses

Using Shift+Delete in Firefox 68+ is documented in the support article (Remove websites from the address bar suggestions), but it isn't flagged as a change from Firefox 67 in any prominent location. For example, it didn't make the release notes:

https://www.mozilla.org/firefox/68.0/releasenotes/

Hopefully people will find this thread.

For what it's worth, Windows and Linux are now consistent with how it has always worked on Mac. I read that in the future, a Delete button/link could be added to the drop-down, which will inform more people that it is even possible to remove history suggestions from the list.

Using Shift+Delete in Firefox 68+ is documented in the support article ([[Remove websites from the address bar suggestions]]), but it isn't flagged as a change from Firefox 67 in any prominent location. For example, it didn't make the release notes: https://www.mozilla.org/firefox/68.0/releasenotes/ Hopefully people will find this thread. For what it's worth, Windows and Linux are now consistent with how it has always worked on Mac. I read that in the future, a Delete button/link could be added to the drop-down, which will inform more people that it is even possible to remove history suggestions from the list.
Est-ce que ceci vous a été utile ?
Citation
Wesley Branton
  • Top 10 Contributor
646 solutions 5253 réponses

Réponse utile

Muzukashii said

Why even simply move from Del to shift-del...

My guess is that maybe people were accidentally hitting the delete key. My other guess is that maybe they did it so that it's the same between operating systems, since the layout of a Mac keyboard has always required the Shift + Delete option to be used.

''Muzukashii [[#answer-1236198|said]]'' <blockquote>Why even simply move from Del to shift-del...</blockquote> My guess is that maybe people were accidentally hitting the delete key. My other guess is that maybe they did it so that it's the same between operating systems, since the layout of a Mac keyboard has always required the Shift + Delete option to be used.
Est-ce que ceci vous a été utile ? 1
Citation
jscher2000
  • Top 10 Contributor
8794 solutions 71943 réponses

For a limited time, you can roll back the address bar drop-down change using a preference. If you can't adjust to Shift+Delete, this might be a temporary workaround:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.quantumbar preference to switch the value from true to false

Although there would be no change in appearance, older code is used.

For a limited time, you can roll back the address bar drop-down change using a preference. If you can't adjust to Shift+Delete, this might be a temporary workaround: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''URLB''' and pause while the list is filtered (3) Double-click the '''browser.urlbar.quantumbar''' preference to switch the value from true to false Although there would be no change in appearance, older code is used.
Est-ce que ceci vous a été utile ? 1
Citation
Mike109 0 solutions 59 réponses

One of the drop down items shows the address I use, it’s for Google. But the title/description is wrong. It shows the “G” followed by the website name of what must have been what I was Googling. It’s been that way for over a year.

Pressing Delete or Shift+Delete does not get rid of it. And I can’t find a way to change the title.

Any suggestions?

One of the drop down items shows the address I use, it’s for Google. But the title/description is wrong. It shows the “G” followed by the website name of what must have been what I was Googling. It’s been that way for over a year. Pressing Delete or Shift+Delete does not get rid of it. And I can’t find a way to change the title. Any suggestions?
Est-ce que ceci vous a été utile ?
Citation
Wesley Branton
  • Top 10 Contributor
646 solutions 5253 réponses

@Mike109

If the above information does not resolve your issue, please consider creating a new thread containing the specific details of your issue.

It will probably also be helpful to post a screenshot of your problem on your new thread so that we can see exactly what you are referring to. See How do I create a screenshot of my problem?.

Doing so will allow the Mozilla volunteers to give you solutions that are more helpful to you. This may help them to solve your problem faster and more efficiently.

Please, feel free to post the link to your thread on this thread for volunteers interested in assisting you.

Thank you.

==@Mike109== If the above information does not resolve your issue, please consider creating a new thread containing the specific details of your issue. It will probably also be helpful to post a screenshot of your problem on your new thread so that we can see exactly what you are referring to. See [[How do I create a screenshot of my problem?]]. Doing so will allow the Mozilla volunteers to give you solutions that are more helpful to you. This may help them to solve your problem faster and more efficiently. Please, feel free to post the link to your thread on this thread for volunteers interested in assisting you. Thank you.
Est-ce que ceci vous a été utile ?
Citation
jscher2000
  • Top 10 Contributor
8794 solutions 71943 réponses

Hi Mike109, can you make sure it isn't a bookmark? Bookmarks are indicated with a star icon to the left of the site icon.

If it's a history entry:

Firefox should update the page title to the last one used for the page, but if the saved address redirects, then Firefox might never update the old entry. Could you try deleting the item through the Library window? Either:

  • Library toolbar button > History > "Show All History"
  • "3-bar" menu button > Library > History > "Show All History"
  • (menu bar) History > "Show All History"
  • Ctrl+Shift+h (on Windows, at least)

Enter the problem text in the search box at the upper right to isolate the entry. Then you should be able to delete it from the list.

Hi Mike109, can you make sure it isn't a bookmark? Bookmarks are indicated with a star icon to the left of the site icon. ''If it's a history entry:'' Firefox should update the page title to the last one used for the page, but if the saved address redirects, then Firefox might never update the old entry. Could you try deleting the item through the Library window? Either: * Library toolbar button > History > "Show All History" * "3-bar" menu button > Library > History > "Show All History" * (menu bar) History > "Show All History" * Ctrl+Shift+h (on Windows, at least) Enter the problem text in the search box at the upper right to isolate the entry. Then you should be able to delete it from the list.
Est-ce que ceci vous a été utile ? 1
Citation
Mike109 0 solutions 59 réponses

Deleting the page from History did not work. I did not see a star anywhere.

I searched bookmarks & there were 2 occurences. One had the proper title but the other included google in the name. I deleted the improper bookmark & that did the job.

I've just been ignoring this menu entry for a long time because it's at the bottom of the drop down list. And I never was able to delete it. But now it's finally gone!

Thanks !

Deleting the page from History did not work. I did not see a star anywhere. I searched bookmarks & there were 2 occurences. One had the proper title but the other included google in the name. I deleted the improper bookmark & that did the job. I've just been ignoring this menu entry for a long time because it's at the bottom of the drop down list. And I never was able to delete it. But now it's finally gone! Thanks !
Est-ce que ceci vous a été utile ?
Citation
Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.