Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

bookmark toolbar via userchrome.css broke with 66/66.0.1 update

  • 2 réponses
  • 1 a ce problème
  • 547 vues
  • Dernière réponse par Zoloft

more options

I've used userChrome.css since 57 I believe to have a two row bookmark toolbar. The .css files is currently:

/*AGENT_SHEET*/

/* Firefox 57+ userChrome.css tweaks ****************************************************/ /* code mostly taken from 'Classic Theme Restorer' & 'Classic Toolbar Buttons' add-ons **/ /* by Aris (aris-addons@gmx.net)*********************************************************/ /* Github: https://github.com/aris-t2/customcssforfx ************************************/ /****************************************************************************************/


  1. personal-bookmarks {
 display: block;

}

  1. personal-bookmarks #PlacesToolbar {
 display: block;
 min-height: 0px;
 overflow-x: hidden;
 overflow-y: auto;
 max-height: 999px;

}

  1. personal-bookmarks #PlacesToolbar > hbox {
 display: -moz-stack !important;
 left: 0px;
 right: 0px;
 width: 100%;

}

  1. personal-bookmarks #PlacesToolbar #PlacesToolbarItems {
 overflow-x: visible;
 overflow-y: visible;

}

  1. personal-bookmarks #PlacesToolbar #PlacesToolbarItems > box {
 display: block;

}

  1. personal-bookmarks #PlacesToolbar > .bookmark-item{
 visibility: visible !important;

}

  1. personal-bookmarks #PlacesToolbar .chevron{
 display: none;

}

  1. personal-bookmarks #PlacesToolbar > hbox > hbox{
 overflow-x: hidden;
 overflow-y: hidden;

}

  1. personal-bookmarks #PlacesToolbar #PlacesToolbarDropIndicator[collapsed="true"],
  2. personal-bookmarks #PlacesToolbar #PlacesToolbarDropIndicator{
 display: none;

}

  1. personal-bookmarks #PlacesToolbar toolbarbutton.bookmark-item{
 padding-top: 2px;
 padding-bottom: 2px;
 /*margin-left: -4px !important;
 padding-right: 9.5px !important;*/

}

  1. personal-bookmarks #PlacesToolbar toolbarbutton.bookmark-item:hover:active:not([disabled="true"]),
  2. personal-bookmarks #PlacesToolbar toolbarbutton.bookmark-item[open="true"] {
 padding-top: 2px !important;
 padding-bottom: 2px !important;
 /*-moz-padding-start: 4px;
 -moz-padding-end: 2px;*/

}

  1. personal-bookmarks #PlacesToolbar toolbarseparator{
 -moz-appearance: none !important;
 visibility: visible !important;
 display: inline;
 text-shadow: none !important;
 border-left: 3px solid ThreeDShadow !important;
 border-right: 3px solid ThreeDHighlight !important;
 vertical-align: middle;

}

  1. personal-bookmarks toolbarbutton.bookmark-item[dragover][open]{
 -moz-appearance: toolbarbutton;

}

  1. navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar):not(#TabsToolbar) {
 max-height: 50px !important;


This is no longer working in 66/66.0.1.

What needs to be adjusted to make this functional again in the latest updates?

Thanks!

R

Solution choisie

The "classic CSS" files from Aris are updated frequently, if you want to go back to the source and download the current version.

See also: https://www.userchrome.org/what-is-userchrome-css.html#multirowbookmarks

Lire cette réponse dans son contexte 👍 0

Toutes les réponses (2)

more options

Solution choisie

The "classic CSS" files from Aris are updated frequently, if you want to go back to the source and download the current version.

See also: https://www.userchrome.org/what-is-userchrome-css.html#multirowbookmarks

more options

Using this:

/* Multi-row Bookmarks Toolbar For Firefox 66 */ /* From https://www.reddit.com/r/FirefoxCSS/comments/b346fz/firefox_66_destroyed_my_more_toolbars_fix/eix109b/ */

  1. PersonalToolbar {
 min-height: unset !important;
 max-height: unset !important;

}

  1. PersonalToolbar #PlacesToolbarItems {
 overflow-x: visible !important;
 overflow-y: visible !important;
 display: inline-block !important;

}

worked for me, thanks for the link!