Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Images from custom fonts (such as google calendar icons) shown as squares with four letters after leaving Firefox open for a while

  • 3 réponses
  • 1 a ce problème
  • 5 vues
  • Dernière réponse par jchronakis

more options

All tabs operate normally when Firefox starts. After leaving Firefox on for a while, usually more than a day, icons that are coming from custom font characters such as the google calendar for example, stop showing. They are replaced with squares with a 4 letter/digit code inside. In addition, google documents open for a while, display some times a message "Font can't be loaded". The problem appears when I switch to a tab, not the currently shown tab.

The problem goes away with a reload of the web site. Fonts start working and icons start displaying properly.

It looks as if firefox clears from cache the fonts that were used by hidden tabs but does not reload them automatically when this tab gets focus again.

This is on Firefox 63.0.2 win 64 bit. It is very hard to reproduce as it takes a day of full operation to show.

All tabs operate normally when Firefox starts. After leaving Firefox on for a while, usually more than a day, icons that are coming from custom font characters such as the google calendar for example, stop showing. They are replaced with squares with a 4 letter/digit code inside. In addition, google documents open for a while, display some times a message "Font can't be loaded". The problem appears when I switch to a tab, not the currently shown tab. The problem goes away with a reload of the web site. Fonts start working and icons start displaying properly. It looks as if firefox clears from cache the fonts that were used by hidden tabs but does not reload them automatically when this tab gets focus again. This is on Firefox 63.0.2 win 64 bit. It is very hard to reproduce as it takes a day of full operation to show.

Toutes les réponses (3)

more options

Could you file a bug on https://bugzilla.mozilla.org/enter_bug.cgi ? After that please provide here a link to your bug, to let us follow it.

more options

Note that filing a bug report is only useful if there are specific steps to reproduce that allow devs to check what is wrong.

Did you try a new and clean profile and also made sure that security software isn't interfering?

Did you check the Browser Console for error messages when this happens?

more options

I filed a bug report as suggested: https://bugzilla.mozilla.org/show_bug.cgi?id=1512376

I did not see the suggestion not too.

This is a problem related with time and has randomness into it. It is very hard to reproduce. It could also not be a bug but something wrong with my machine. Depends, if others have it.

I did not spot anything in the browser console but every time I did this, it was after the problem appeared. And since a reload makes it go away, there were no specific errors in the console.

The profile has been refreshed recently.

Re extensions, indeed it could be related. Though most of those tend to block elements on load rather than unloading them days later and they work well in all other installations. But good advice.

To me it looks like some fonts are unloaded and not loaded back, though I don't know the internals. I recently found out that I lost 2/3 of my page file (with a disk gone) and windows were running often low on memory. It could be that Firefox aggressively freeing resources but the fonts are not loaded back or something similar. I will monitor the behaviour with the page file setting back to normal again.

Thanks.