X
Appuyez ici pour vous rendre sur la version mobile du site.

Forum d’assistance

Sync for caldav not working after update to Thunderbird 60

Publié

After I updated from Thunderbird 52.9 to 60 enlightenment stopped working with all caldav calendars on my nextcloud-instance. It doesn't synchronize anymore and doesn't even show that it doesn't. As soon as I downgrade to Thunderbird 52.9 and Enlightenment 5.4 all is good. I don't believe the problem being the nextclouds fault because the syncing is working with all android apps, Evolution and CLI tools too. I tested with a now profile on Thunderbird 60. But that doesn't help. I only get empty calenders because of the sync-problems

After I updated from Thunderbird 52.9 to 60 enlightenment stopped working with all caldav calendars on my nextcloud-instance. It doesn't synchronize anymore and doesn't even show that it doesn't. As soon as I downgrade to Thunderbird 52.9 and Enlightenment 5.4 all is good. I don't believe the problem being the nextclouds fault because the syncing is working with all android apps, Evolution and CLI tools too. I tested with a now profile on Thunderbird 60. But that doesn't help. I only get empty calenders because of the sync-problems

Solution choisie

I believe this is the CalDAV known-issue, it's a NextCloud problem. It's been reported in this issue, there is a workaround:

  1. Go to the config editor (Settings -> Advanced -> General -> Config Editor)
  2. Search for network.cookie.same-site.enabled
  3. Set it to false

For your own security you should set it back to true once this issue is resolved.

This was also mentioned in the release notes (very bottom of https://www.thunderbird.net/en-US/thunderbird/60.0/releasenotes/ )

Lire cette réponse dans son contexte 4

Détails additionnels sur le système

Application

  • Agent utilisateur : Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0

Plus d’informations

Fabián Rodríguez 70 solutions 557 réponses

Solution choisie

I believe this is the CalDAV known-issue, it's a NextCloud problem. It's been reported in this issue, there is a workaround:

  1. Go to the config editor (Settings -> Advanced -> General -> Config Editor)
  2. Search for network.cookie.same-site.enabled
  3. Set it to false

For your own security you should set it back to true once this issue is resolved.

This was also mentioned in the release notes (very bottom of https://www.thunderbird.net/en-US/thunderbird/60.0/releasenotes/ )

I believe this is the CalDAV known-issue, it's a NextCloud problem. [https://github.com/nextcloud/server/issues/10134 It's been reported in this issue], there is [https://github.com/nextcloud/server/issues/10134#issuecomment-411322692 a workaround]: # Go to the config editor (Settings -> Advanced -> General -> Config Editor) # Search for network.cookie.same-site.enabled # Set it to false For your own security you should set it back to true once this issue is resolved. This was also mentioned in the release notes (very bottom of https://www.thunderbird.net/en-US/thunderbird/60.0/releasenotes/ )

Auteur de la question

Thank you and sorry that I didn't read all through the release note.

Thank you and sorry that I didn't read all through the release note.
Xagec 0 solutions 1 réponses

Fabián Rodríguez said

I believe this is the CalDAV known-issue, it's a NextCloud problem. It's been reported in this issue, there is a workaround:
  1. Go to the config editor (Settings -> Advanced -> General -> Config Editor)
  2. Search for network.cookie.same-site.enabled
  3. Set it to false
For your own security you should set it back to true once this issue is resolved. This was also mentioned in the release notes (very bottom of https://www.thunderbird.net/en-US/thunderbird/60.0/releasenotes/ )

Same problem here, tried the workaround to no avail. Is there anything else that can be done aside of downgrading?

''Fabián Rodríguez [[#answer-1143907|said]]'' <blockquote> I believe this is the CalDAV known-issue, it's a NextCloud problem. [https://github.com/nextcloud/server/issues/10134 It's been reported in this issue], there is [https://github.com/nextcloud/server/issues/10134#issuecomment-411322692 a workaround]: # Go to the config editor (Settings -> Advanced -> General -> Config Editor) # Search for network.cookie.same-site.enabled # Set it to false For your own security you should set it back to true once this issue is resolved. This was also mentioned in the release notes (very bottom of https://www.thunderbird.net/en-US/thunderbird/60.0/releasenotes/ ) </blockquote> Same problem here, tried the workaround to no avail. Is there anything else that can be done aside of downgrading?