X
Appuyez ici pour vous rendre sur la version mobile du site.

Forum d’assistance

How can I stop videos from automatically starting (autoplay)?

Publié

Every web page with video / audio content begins to autoplay (at the vid's highest volume) approximately 5 seconds after opening the page. I could disable this in Safari and Chromium, but see no option to disable the 'Autoplay' feature in Firefox. Worse, there are no plug-ins or extensions available that will allow this to be done. If you have had success disabling this annoying 'feature' (it's not a 'bug,' right?), please advise how it was done so that I may rid myself of these annoying vids. Thanks in advance.

Every web page with video / audio content begins to autoplay (at the vid's highest volume) approximately 5 seconds after opening the page. I could disable this in Safari and Chromium, but see no option to disable the 'Autoplay' feature in Firefox. Worse, there are no plug-ins or extensions available that will allow this to be done. If you have had success disabling this annoying 'feature' (it's not a 'bug,' right?), please advise how it was done so that I may rid myself of these annoying vids. Thanks in advance.

Solution choisie

https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

or

You can set this pref; media.block-autoplay-until-in-foreground = true

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

Lire cette réponse dans son contexte 11

Détails additionnels sur le système

Plugins installés

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.11
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.1
  • 5.1.50901.0
  • iPhoto6

Application

  • Agent utilisateur : Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:48.0) Gecko/20100101 Firefox/48.0

Plus d’informations

FredMcD
  • Top 10 Contributor
4254 solutions 59579 réponses

Solution choisie

https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

or

You can set this pref; media.block-autoplay-until-in-foreground = true

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it or You can set this pref; '''media.block-autoplay-until-in-foreground = true''' Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar.
bygabyga 15 solutions 171 réponses

Réponse utile

Hello,

In order to change your Firefox Configuration please do the following:

  1. In the address bar, type about:config and press the Enter key.
  2. The about:config "This might void your warranty!" warning page may appear.
    Click I accept the risk! to continue to the about:config page.

Search for media.autoplay.enabled and set to false.

Hello, In order to change your Firefox Configuration please do the following: # In the [[Awesome Bar - Search your Firefox bookmarks, history and tabs from the address bar|address bar]], type '''about:config''' and press the '''Enter''' key. # The about:config "''This might void your warranty!''" warning page may appear.<br> Click '''I accept the risk!''' to continue to the about:config page. Search for '''media.autoplay.enabled''' and set to '''false'''.

Auteur de la question

Hello, Fred McD: Thanks for your reply. I can use 'about:config' to access the menu items. When I attempt to toggle 'True' to 'False,' ALL items become hilited. How does one change the value for only ONE item?

Hello, Fred McD: Thanks for your reply. I can use 'about:config' to access the menu items. When I attempt to toggle 'True' to 'False,' ALL items become hilited. How does one change the value for only ONE item?

Auteur de la question

Hello, bygabyga: I have installed the Extension. Where does it appear? I don't see it in the area which holds the other active Extensions. It sounds as if this is exactly what I've been looking for. I've used something similar (i.e., 'Click-To-Flash') on Safari and other browsers.

Hello, bygabyga: I have installed the Extension. Where does it appear? I don't see it in the area which holds the other active Extensions. It sounds as if this is exactly what I've been looking for. I've used something similar (i.e., 'Click-To-Flash') on Safari and other browsers.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 réponses

Réponse utile

Dr_Know said

I can use 'about:config' to access the menu items. When I attempt to toggle 'True' to 'False,' ALL items become hilited. How does one change the value for only ONE item?

If you double-click a boolean-type preference, it should alternate between true and false.

I'm going to copy/paste another recent post with more details. It has been a long time since Firefox 48, so apologies if this doesn't quite match up to yours.

To stop videos from autoplaying, you have to combine a number of approaches because sites use different methods for playing media:

  • Plugin-based players: many sites still use Flash for videos. You can set your media-related plugins to "click to play" ("Ask to Activate") to control when they start.
  • Built-in HTML5 video player: Firefox has a setting to stop auto-play. On some sites there are some strange side effects.

And now the details:

To set "Ask to Activate" for Flash, open the Add-ons page using either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate". You can do the same for QuickTime, Silverlight, VLC, and other media players.

(You don't need to change Widevine, as it isn't a player, it's a helper for the HTML5 player on sites that use DRM.)

With this setting, when you visit a site that wants to use Flash (etc.), you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern.

If you are ready to play the video and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

Some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

If you want finer control: This extension lets you allow specific videos of interest to you while not allowing the rest of them: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/ (I haven't tried it recently)

To control the built-in HTML5 player:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste media*play and pause while the list is filtered

(3) To delay media from auto-starting in background tabs, I suggest: double-click the media.block-play-until-visible preference to switch the value from false to true (Firefox 48 might not have had this feature)

(4) To prevent media from auto-starting in any tabs: double-click the media.autoplay.enabled preference to switch the value from true to false

The quirks:

  • When Firefox pauses an auto-played video, it may not change the pause button back into a play button. So on those sites, when you do want to start the video, you have to click twice.
  • On sites with GIFV media, there usually are not any visible player controls. You need to right-click the video player area and choose Show Controls. Then you can click the play button. (Firefox 48 might not have had the ability to pause auto-play for this type of media.)
''Dr_Know [[#answer-983963|said]]'' <blockquote>I can use 'about:config' to access the menu items. When I attempt to toggle 'True' to 'False,' ALL items become hilited. How does one change the value for only ONE item? </blockquote> If you double-click a boolean-type preference, it should alternate between true and false. I'm going to copy/paste another recent post with more details. It has been a long time since Firefox 48, so apologies if this doesn't quite match up to yours. To stop videos from autoplaying, you have to combine a number of approaches because sites use different methods for playing media: * Plugin-based players: many sites still use Flash for videos. You can set your media-related plugins to "click to play" ("Ask to Activate") to control when they start. * Built-in HTML5 video player: Firefox has a setting to stop auto-play. On some sites there are some strange side effects. And now the details: '''To set "Ask to Activate" for Flash''', open the Add-ons page using either: * Command+Shift+a (Windows: Ctrl+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate". You can do the same for QuickTime, Silverlight, VLC, and other media players. (You don't need to change Widevine, as it isn't a player, it's a helper for the HTML5 player on sites that use DRM.) With this setting, when you visit a site that wants to use Flash (etc.), you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern. If you are ready to play the video and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently. Some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later. ''If you want finer control:'' This extension lets you allow specific videos of interest to you while not allowing the rest of them: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/ (I haven't tried it recently) '''To control the built-in HTML5 player:''' (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media*play''' and pause while the list is filtered (3) To delay media from auto-starting in background tabs, I suggest: double-click the '''media.block-play-until-visible''' preference to switch the value from false to true ''(Firefox 48 might not have had this feature)'' (4) To prevent media from auto-starting in any tabs: double-click the '''media.autoplay.enabled''' preference to switch the value from true to false The quirks: * When Firefox pauses an auto-played video, it may not change the pause button back into a play button. So on those sites, when you do want to start the video, you have to click twice. * On sites with GIFV media, there usually are not any visible player controls. You need to right-click the video player area and choose Show Controls. Then you can click the play button. (Firefox 48 might not have had the ability to pause auto-play for this type of media.)

Auteur de la question

Jscher ... Dang. That's a boatload of information. Thanks. I've tried double-clicking the Boolean, but alas, it does nothing - no change, no highlight, nichts. The Flash 'Ask to Activate' link doesn't appear - nothing connected to Flash appears in the list. It's as if Flash doesn't exist. This may be 'cos I'm still using OS X 'Snow Leopard' - mainly 'cos upgrading to a version without Rosetta emulation breaks the legacy apps that I use. I've copied your information and pasted it into a text file I can open as needed. Thanks again for such an information-dense response.

Jscher ... Dang. That's a boatload of information. Thanks. I've tried double-clicking the Boolean, but alas, it does nothing - no change, no highlight, nichts. The Flash 'Ask to Activate' link doesn't appear - nothing connected to Flash appears in the list. It's as if Flash doesn't exist. This may be 'cos I'm still using OS X 'Snow Leopard' - mainly 'cos upgrading to a version without Rosetta emulation breaks the legacy apps that I use. I've copied your information and pasted it into a text file I can open as needed. Thanks again for such an information-dense response.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 réponses

Dr_Know said

I've tried double-clicking the Boolean, but alas, it does nothing - no change, no highlight, nichts.

Another method is to right-click (or on Mac it may be Ctrl+click) the preference name and choose Toggle to switch the value.

''Dr_Know [[#answer-984069|said]]'' <blockquote> I've tried double-clicking the Boolean, but alas, it does nothing - no change, no highlight, nichts. </blockquote> Another method is to right-click (or on Mac it may be Ctrl+click) the preference name and choose Toggle to switch the value.
MarjaE 2 solutions 216 réponses

The about:config fixes haven't worked in years.

I'm photosensititive, so blocking animation is ... kinda important. I have 3 about:config changes, I disabled all the plugins, I have 6 animation-blocking extensions, and 10 animation-blocking user styles, and more still gets through.

It's a health hazard.

The about:config fixes haven't worked in years. I'm photosensititive, so blocking animation is ... kinda important. I have 3 about:config changes, I disabled all the plugins, I have 6 animation-blocking extensions, and 10 animation-blocking user styles, and more still gets through. It's a health hazard.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 réponses

MarjaE said

The about:config fixes haven't worked in years.

If you have set the media.autoplay.enabled to false and blocked Flash from being activated without your permission, what site still automatically starts a video with that setting? It's helpful to work with specific examples.

(This thread is about videos starting automatically, not animations. You should start a new thread if the problem is not a video.)

''MarjaE [[#answer-996248|said]]'' <blockquote>The about:config fixes haven't worked in years.</blockquote> If you have set the '''media.autoplay.enabled''' to false and blocked Flash from being activated without your permission, what site still automatically starts a video with that setting? It's helpful to work with specific examples. (This thread is about videos starting automatically, not animations. You should start a new thread if the problem is not a video.)
MarjaE 2 solutions 216 réponses

Huffington Post automatically starts videos with all my blockers.

Huffington Post automatically starts videos with all my blockers.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 réponses

MarjaE said

Huffington Post automatically starts videos with all my blockers.

Can you give a link to a particular page where this happens? Does it start once page loading is completed, or do you need to do something to trigger it such as clicking something or scrolling?

''MarjaE [[#answer-996298|said]]'' <blockquote> Huffington Post automatically starts videos with all my blockers. </blockquote> Can you give a link to a particular page where this happens? Does it start once page loading is completed, or do you need to do something to trigger it such as clicking something or scrolling?
MarjaE 2 solutions 216 réponses
I installed FlashStopper earlier today. It keeps the @#$% videos from playing. http://www.huffingtonpost.com/entry/trump-white-house-response-charlottesville_us_59908c5ce4b090964297cdf5?ncid=inblnkushpmg00000009
jscher2000
  • Top 10 Contributor
8758 solutions 71655 réponses

I can't figure out what they are doing on that page, but the autoplay seems to be triggered by movement within the page, usually scrolling back up toward the video, but possibly also the page content moving down when a banner ad loads. If I scroll back to the top and reload and wait 15 seconds, nothing plays. With everyone's different filters and blockers, I'm sure it's difficult to compare.

I can't figure out what they are doing on that page, but the autoplay seems to be triggered by movement within the page, usually scrolling back up toward the video, but possibly also the page content moving down when a banner ad loads. If I scroll back to the top and reload and wait 15 seconds, nothing plays. With everyone's different filters and blockers, I'm sure it's difficult to compare.

Auteur de la question

Thanks to jscher2000 and MarjaE. The 'about:config' seems to have done the trick. I get the same 'movement at the top of the page' trigger jscher2000 mentions, but scrolling down appears to end it if I then scroll back up and wait. Something (apparently a screen movement script or sensor) is detecting movement and / or cursor position - that apparently is all it takes to trigger autostart (or cancel it). There's still a bit of bother with some sites that aren't completely responsive, but things now are a lot better than they were before. Thanks to all for the helpful suggestions.

Thanks to jscher2000 and MarjaE. The 'about:config' seems to have done the trick. I get the same 'movement at the top of the page' trigger jscher2000 mentions, but scrolling down appears to end it if I then scroll back up and wait. Something (apparently a screen movement script or sensor) is detecting movement and / or cursor position - that apparently is all it takes to trigger autostart (or cancel it). There's still a bit of bother with some sites that aren't completely responsive, but things now are a lot better than they were before. Thanks to all for the helpful suggestions.
MrToo 0 solutions 7 réponses

Dr_Know said

Every web page with video / audio content begins to autoplay (at the vid's highest volume) approximately 5 seconds after opening the page. I could disable this in Safari and Chromium, but see no option to disable the 'Autoplay' feature in Firefox. Worse, there are no plug-ins or extensions available that will allow this to be done. If you have had success disabling this annoying 'feature' (it's not a 'bug,' right?), please advise how it was done so that I may rid myself of these annoying vids. Thanks in advance.

This is a solution for an old version. Not compatible with Firefox Quantum.

''Dr_Know [[#question-1166689|said]]'' <blockquote> Every web page with video / audio content begins to autoplay (at the vid's highest volume) approximately 5 seconds after opening the page. I could disable this in Safari and Chromium, but see no option to disable the 'Autoplay' feature in Firefox. Worse, there are no plug-ins or extensions available that will allow this to be done. If you have had success disabling this annoying 'feature' (it's not a 'bug,' right?), please advise how it was done so that I may rid myself of these annoying vids. Thanks in advance. </blockquote> This is a solution for an old version. Not compatible with Firefox Quantum.
cor-el
  • Top 10 Contributor
  • Moderator
17519 solutions 158412 réponses

See also:

See also: *Policy Control - JavaScript and Flash blocker: https://addons.mozilla.org/firefox/addon/policy-control/