X
Appuyez ici pour vous rendre sur la version mobile du site.

Forum d’assistance

What LSO blocking programs are available for Firefox since Better Privacy became incompatible?

Publié

After I selected Firefox -Clear History, Better Privacy appeared to be functioning but I noticed in Add-Ons Manager “Better Privacy” will be disabled after you restart Firefox”. Firefox searches immediately began appearing in Google-My Activity even though they had been effectively blocked for the past year. When I restarted, Add-Ons Manager verified that Better Privacy had been disabled upon restart and that it was incompatible with Firefox 44.0.2. 1. Why would clearing history apparently trigger an add-on to become incompatible when the Firefox version has not changed? 2. What other effective LSO blocking programs are available for Firefox 44.0.2 and higher since Better Privacy completely stopped working?

3. Has Firefox permanently stopped making Better Privacy available for newer versions? If so, why?
After I selected Firefox -Clear History, Better Privacy appeared to be functioning but I noticed in Add-Ons Manager “Better Privacy” will be disabled after you restart Firefox”. Firefox searches immediately began appearing in Google-My Activity even though they had been effectively blocked for the past year. When I restarted, Add-Ons Manager verified that Better Privacy had been disabled upon restart and that it was incompatible with Firefox 44.0.2. 1. Why would clearing history apparently trigger an add-on to become incompatible when the Firefox version has not changed? 2. What other effective LSO blocking programs are available for Firefox 44.0.2 and higher since Better Privacy completely stopped working? 3. Has Firefox permanently stopped making Better Privacy available for newer versions? If so, why?

Solution choisie

Firefox 44.0.2 is a old version from February 11, 2016.

The current Firefox Release is 50.1.0 (released on December 13, 2016) as you can see at www.mozilla.org/firefox/all/

The BetterPrivacy like the vast majority of Extensions hosted at addons.mozilla.org are made by a third-party author or company. A Mozilla made extension would have Mozilla or Mozilla Labs as author for example.

https://addons.mozilla.org/en-US/firefox/addon/betterprivacy/versions/

The issue as you can see in above link is due to using a old Firefox version as the only version that will work with Fx 44.0.2 is the old 1.69 from November 2015. You likely got a Extension update say to the current 1.77 which supports Firefox 49.0 and later.

Firefox is the name of this browser (third one actually as it was Phoenix then Firebird in the early days of the browser) and Mozilla is the company that makes Firefox. Neither Mozilla or the Firefox browser makes or maintains this BetterPrivacy extension.

Lire cette réponse dans son contexte 1

Détails additionnels sur le système

Plugins installés

  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 20.0 r0
  • EMusic Plugin
  • iPhoto6

Application

  • Agent utilisateur : Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:44.0) Gecko/20100101 Firefox/44.0

Plus d’informations

James
  • Top 25 Contributor
  • Moderator
1598 solutions 11290 réponses

Solution choisie

Firefox 44.0.2 is a old version from February 11, 2016.

The current Firefox Release is 50.1.0 (released on December 13, 2016) as you can see at www.mozilla.org/firefox/all/

The BetterPrivacy like the vast majority of Extensions hosted at addons.mozilla.org are made by a third-party author or company. A Mozilla made extension would have Mozilla or Mozilla Labs as author for example.

https://addons.mozilla.org/en-US/firefox/addon/betterprivacy/versions/

The issue as you can see in above link is due to using a old Firefox version as the only version that will work with Fx 44.0.2 is the old 1.69 from November 2015. You likely got a Extension update say to the current 1.77 which supports Firefox 49.0 and later.

Firefox is the name of this browser (third one actually as it was Phoenix then Firebird in the early days of the browser) and Mozilla is the company that makes Firefox. Neither Mozilla or the Firefox browser makes or maintains this BetterPrivacy extension.

Firefox 44.0.2 is a old version from February 11, 2016. The current Firefox Release is 50.1.0 (released on December 13, 2016) as you can see at www.mozilla.org/firefox/all/ The BetterPrivacy like the vast majority of '''Extensions''' hosted at addons.mozilla.org are made by a third-party author or company. A Mozilla made extension would have Mozilla or Mozilla Labs as author for example. https://addons.mozilla.org/en-US/firefox/addon/betterprivacy/versions/ The issue as you can see in above link is due to using a old Firefox version as the only version that will work with Fx 44.0.2 is the old 1.69 from November 2015. You likely got a Extension update say to the current 1.77 which supports Firefox 49.0 and later. Firefox is the name of this browser (third one actually as it was Phoenix then Firebird in the early days of the browser) and Mozilla is the company that makes Firefox. Neither Mozilla or the Firefox browser makes or maintains this BetterPrivacy extension.
James
  • Top 25 Contributor
  • Moderator
1598 solutions 11290 réponses

Réponse utile

I just noticed you are using the old Mac OSX 10.6.x

Firefox as of 49.0 and later does not run on OSX 10.6, 10.7, 10.8 as you need OSX 10.9 and later now.

See https://support.mozilla.org/en-US/kb/firefox-osx on your options.

There are a couple options, you can use the Firefox 45.0 ESR which is basically the Firefox 45.0 Release but with allowed security and stability fixes since until 45.9.0esr being the last (when Firefox 53.0 is released) unless extended. Or you can use Firefox 48.0.2 however it is already behind on security fixes.

Normally there are eight major ESR releases of a version. I say 45.9.0esr and not 45.8.0esr because 45.6.0esr was released when 50.1.0 was as 45.6.0esr would have instead been released in future when 51.0 is released.

I just noticed you are using the old Mac OSX 10.6.x Firefox as of 49.0 and later does not run on OSX 10.6, 10.7, 10.8 as you need OSX '''10.9''' and later now. See https://support.mozilla.org/en-US/kb/firefox-osx on your options. There are a couple options, you can use the Firefox 45.0 ESR which is basically the Firefox 45.0 Release but with allowed security and stability fixes since until 45.9.0esr being the last (when Firefox 53.0 is released) unless extended. Or you can use Firefox 48.0.2 however it is already behind on security fixes. Normally there are eight major ESR releases of a version. I say 45.9.0esr and not 45.8.0esr because 45.6.0esr was released when 50.1.0 was as 45.6.0esr would have instead been released in future when 51.0 is released.

Modifié le par James