Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Whenever I change the archive folder location, emails still go to the old location.

  • 7 réponses
  • 1 a ce problème
  • 130 vues
  • Dernière réponse par Toad-Hall

more options

In the settings I changed "Keep message archives in:" from "Archives folder on [email]" to "Other: Archives on Local Folders"

The icon swapped to the local folder and I deleted the archive folder on my email account. The problem being when I click "Archive" Thunderbird creates the archive folder on my email account again and stores them there. Also an icon appears on the new archive folder under my email account but it doesn't get removed from the local folder location I set. To remove the icon I have to swap the archive location to my email and back to the local folder. Then when I click to archive my mail it still moves it to the folder on my email even though the the archive location icon is on the local folders..

I have a few other emails and they don't seem to have this problem. I'm using Thunderbird portable with the latest version (38.7.0)

Probably an unrelated bug, but sometimes I get a pop-up to say that compacting a folder will save 18GB, although the whole installation is about 500MB. I've tried compacting folders and rebuilding the Global Database which removed the archive folder from my email but it got recreated again as soon as I tried to archive another email.

I hope you can help, this error has been driving me mad :)

In the settings I changed "Keep message archives in:" from "Archives folder on [email]" to "Other: Archives on Local Folders" The icon swapped to the local folder and I deleted the archive folder on my email account. The problem being when I click "Archive" Thunderbird creates the archive folder on my email account again and stores them there. Also an icon appears on the new archive folder under my email account but it doesn't get removed from the local folder location I set. To remove the icon I have to swap the archive location to my email and back to the local folder. Then when I click to archive my mail it still moves it to the folder on my email even though the the archive location icon is on the local folders.. I have a few other emails and they don't seem to have this problem. I'm using Thunderbird portable with the latest version (38.7.0) Probably an unrelated bug, but sometimes I get a pop-up to say that compacting a folder will save 18GB, although the whole installation is about 500MB. I've tried compacting folders and rebuilding the Global Database which removed the archive folder from my email but it got recreated again as soon as I tried to archive another email. I hope you can help, this error has been driving me mad :)

Solution choisie

Good to hear all is now ok.

Additional Info for anyone reading this question: If any one has an additional identity / email address on a mail account.

'Tools' > 'Account Settings' for the main identity of mail account or right click on mail account and select 'Settings'

  • click on 'Manage Identites' button
  • select the additional identity and click on 'Edit'
  • select 'Copies & Folders tab

Under 'Message Archives'

  • select 'Keep message archives in:'
  • Select 'Other' and choose Archives folder on Local Folders.
  • click on OK
  • Click on OK
Lire cette réponse dans son contexte 👍 0

Toutes les réponses (7)

more options

Confirm: Is Thunderbird Portable is running from external hardrive or usb?

What is the storage location of Thunderbird Profile folder ? Account Settings > Server Settings for the mail account at bottom - 'Local directory:' Put cursor in the text area Then right click and click on 'Select All' right click and select 'Copy.' Paste info in this question.

then select 'Local Folders' in the left Pane and look at 'local directory'. Perform same action again and paste the info.

more options

Toad-Hall said

Confirm: Is Thunderbird Portable is running from external hardrive or usb? What is the storage location of Thunderbird Profile folder ? Account Settings > Server Settings for the mail account at bottom - 'Local directory:' Put cursor in the text area Then right click and click on 'Select All' right click and select 'Copy.' Paste info in this question. then select 'Local Folders' in the left Pane and look at 'local directory'. Perform same action again and paste the info.

I'm running Thunderbird portable from a USB stick.

H:\Programs\ThunderbirdPortable\Data\profile\ImapMail\[imap server]

H:\Programs\ThunderbirdPortable\Data\profile\Mail\Local Folders

more options

If one does not exist: create an 'Archives' folder in Local Folders. In Account Settings > Copies & Folders for imap maila ccount select: 'Other' and then select the 'Local Folders' > 'Archives' folder. click on OK

Synchronise imap folders for offline use. In Offline mode: Select an email and click on 'Archive' button.

What occurs when in Offline mode after synchonising offline folders?

What server is this? gmail ?

Modifié le par Toad-Hall

more options

Toad-Hall said

If one does not exist: create an 'Archives' folder in Local Folders. In Account Settings > Copies & Folders for imap maila ccount select: 'Other' and then select the 'Local Folders' > 'Archives' folder. click on OK Synchronise imap folders for offline use. In Offline mode: Select an email and click on 'Archive' button. What occurs when in Offline mode after synchonising offline folders? What server is this? gmail ?

After synchronising and going offline the archive button doesn't seem to do anything when I trying to archive that email account, the others still work ok though.

The server is 1and1

Modifié le par MatG

more options

Please check config editor settings:

'Tools' > 'Options' > 'Advanced' > 'General' tab click on 'config Editor' button - it will tell you to be careful :)

In top search type the email address which is effected.

You should see this line: mail.identity.id3.useremail; Value = email address. Make a note of the 'id' number. In the example above, it is 'id3', but yours might be different..

In top search, type eg: archive what does it say for the following lines where the id = eg: id3 Example:

  • mail.identity.id3.archive_folder; Value=mailbox://nobody@Local%20Folders/Archives
  • mail.identity.id3.archives_folder_picker_mode; Value =1

What does it say for the following lines: example:

  • mail.identity.default.archive_enabled; Value =true
  • mail.identity.default.archive_granularity; Value =1
  • mail.identity.default.archive_keep_folder_structure; Value =false

you can use right click to copy paste the lines of info into this forum question. Or even better...post an image of the config editor window which shows the results of the 'archive' search.

more options

Well I found the problem, thank you!

I own the .com and .co.uk email addresses for the domain, and emails sent to either end up in my .com inbox. When I typed the email into the config search the .com is id3 and the .co.uk is id8. So when I typed "archive" into the search I just copied the settings from id3 to id8 and it works.

I completely forgot that I'd added the .co.uk version as a different identity, It was quite some time ago.

I've marked your reply as solved as although it doesn't solve the problem, it led me to the solution :)

Thanks again for your help and time. I do feel a bit thick for forgetting about the different identity though, I didn't realise all the settings were different, I thought they carried over from the main account.

more options

Solution choisie

Good to hear all is now ok.

Additional Info for anyone reading this question: If any one has an additional identity / email address on a mail account.

'Tools' > 'Account Settings' for the main identity of mail account or right click on mail account and select 'Settings'

  • click on 'Manage Identites' button
  • select the additional identity and click on 'Edit'
  • select 'Copies & Folders tab

Under 'Message Archives'

  • select 'Keep message archives in:'
  • Select 'Other' and choose Archives folder on Local Folders.
  • click on OK
  • Click on OK