Rechercher dans l’assistance

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I fix the need to constantly clear history?

  • 11 réponses
  • 5 ont ce problème
  • 501 vues
  • Dernière réponse par pfreeman666

more options

Within the past two days, my browser has started failing to search. I did a search on this through another browser and found a suggestion to clear history. I did that and it seemed to fix the problem. However, the next time I tried a search and every time since,I have to again clear history, close the browser, and then initiate the search again.

If instead of a search, I select one of my "favorites", there is no problem.

Toutes les réponses (11)

more options

Are you using the search box, the address box, or what?

more options

You can check for problems with the places.sqlite database file (bookmarks, history) in the Firefox profile folder.

If the Places Maintenance extension can't repair the places.sqlite database file then remove all places.sqlite file(s) in the Firefox profile folder to make Firefox rebuild the places.sqlite database file from the most recent JSON backup in the bookmarkbackups folder.

more options

This is strange, but it hasn't done it the last couple of times I tried it. But, I was talking about the search box.

Cor-el: I will look at the links you sent, but that's pretty much "Greek" to me. Thank you though.

more options

Is that the search bar on the Navigation Toolbar?

Do search bars on other built-in pages like about:home and about:newtab work?

Is there a search engine selected in "Options/Preferences > Search"?

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

You can use this button to go to the current Firefox profile folder:

Firefox will rebuild the search.json file from the default built-in search engines that come with Firefox and the searchplugins folder in the Firefox profile folder.

more options

I spoke too soon - the problem started up again today. So, I followed your last instructions to delete the .json files and that may have fixed it. I thought I already had a default search engine but did not, so I made Google the default as well. For now, it is working and search results are coming up much faster.

more options

Again, I spoke too quickly - I opened Firefox again, and again Google search just sits there. There is no indication it is doing anything. It is like deleting those files fixed it, but then when I started to browser again and it rebuilt those files,it included whatever is causing the problem. Should I leave Google the default search engine when I delete the files?

more options

By the way, I went back to your instructions and realized I had not deleted the .sqlite file you mentioned, but it is not there. In addition to the other 2 you mentioned, there's a sessionCheckpoints.json and one called signons.sqlite.

more options

Did you check your security software and other software that has file protection or cleanup features?

signons.sqlite was used in older Firefox version to store the passwords that you see in the Password Manager. Current Firefox versions use logins.json instead and no longer use signons.sqlite. So leave other SQLite and JSON files alone and do not delete them.

sessionCheckpoints.json is crated automatically to log the startup progression.

more options

I haven't made any changes to my security software but I will look at it. In the meantime, I think I might have fixed it simply by changing my Firefox privacy settings to delete History each time I close the browser. That does of course cause some other difficulties but I can work around them.

more options

What data do you want to clear when you close Firefox?

more options

As I mentioned in my original post, when I cleared history it temporarily fixed the problem. But, I had to repeat that about every time I tried a Google search after closing the browser. So now it does it automatically. I know I shouldn't have to do that, but for now it works.