Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

"Untrusted connection" for many sites

  • 3 réponses
  • 50 ont ce problème
  • 48 vues
  • Dernière réponse par Stretch4030

more options

I got a new windows10 laptop recently, installed firefox, and now firefox is saying "This Connection is Untrusted" with many sites, even the searchbar. I've noticed that if i google something straight from the searchbar it'll tell me "untrusted connection"; however if i were to remove the s from "https" then i'll be able to get to the site. Example: i googled 'hello', the address that turned up untrusted connection was "https://www.google.com/search?q=hello&ie=utf-8&oe=utf-8", upon removing the s, i could get to the site, the site address became "https://www.google.com.sg/search?q=hello&ie=utf-8&oe=utf-8&safe=active&gws_rd=cr,ssl&ei=5u3TVevvNsnk0gSEiZ7QDg&safe=active". Yes, my date and time is set correctly. I am using AVG antivirus on Asus Zenbook. I've tried many solutions in the many forums including this support forum. Please help, it's really annoying me.

Here's the full details of "untrusted connection":

You have asked Firefox to connect securely to www.youtube.com, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate."

Solution choisie

One thing you didn't mention that seems to be affecting a lot of Windows 10 users is that parental controls are being applied to their accounts, which causes seemingly random silent blockages. Could you check Microsoft Family Safety and either disable it or take your account out of the family: http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

Lire cette réponse dans son contexte 👍 2

Toutes les réponses (3)

more options

Solution choisie

One thing you didn't mention that seems to be affecting a lot of Windows 10 users is that parental controls are being applied to their accounts, which causes seemingly random silent blockages. Could you check Microsoft Family Safety and either disable it or take your account out of the family: http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

more options

Thank you so much! I did that, and it seems to be working fine now.

more options

If you do this is will make the untrusted Connection not appear with out disabling Microsoft Family Safety.

To consent to such snooping, and suppress all "Untrusted Certificate" warnings arising from this scheme, you need to instruct Firefox to trust Microsoft's SSL certificate that is used for re-encrypting. (Microsoft Internet Explorer doesn't have this "problem" because it trusts Microsoft's certificate out of the box. Google Chrome is the same, since it relies on cryptography mechanisms built into Windows. Firefox, however, uses its own cryptographic routines that consult a separate list of trusted root certificates.)

The certificate that you need to import is Microsoft's. Go to Control Panel → Network and Internet → Internet Options → Content → Certificates → Trusted Root Certification Authorities. Select the Microsoft Family Safety certificate, then click Export…. Answer No, do not export the private key. Either of the two .CER formats is fine. Save it to any convenient temporary location, such as familysafety.cer on your Desktop.

Then, you need to tell Firefox to trust the certificate that you just exported. In the Firefox menu, choose Options → Advanced → Certificates → View Certificates → Authorities → Import…. Select the familysafety.cer that you had just saved. Select Trust this CA to identify websites, then click OK, and close the Options dialog.

Just restart Firefox and you should be fine