Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

What can I do, when filling out forms on the web, when Firefox does not provide the right character, e.g. provides " instead of the At sign.

  • 6 réponses
  • 2 ont ce problème
  • 120 vues
  • Dernière réponse par cor-el

more options

Sometimes when using Mozilla, either in email (Microsoft Outlook) or when filling out online forms on the web, the character I am trying to enter is not what is displayed. This happens particularly with the At sign which comes out as " and the question mark which comes out as É. In fact, the be able to sign on to Mozilla Support, I had to type an At sign in Microsoft word and then copy onto the Mozilla web page. I don`t think its a problems with my keyboard because it only happen in Mozilla.

Solution choisie

Actually Mozilla Firefox has not its own keyboard parameters (but there are display page and check spelling language parameters). Sometimes Windows keyboard language changes unintentionally, example giving with keyboard shortcut Shift+Alt. For the moment, check if you have more than one keyboard language installed: open the Control Panel > Language, and you should have the list of languages Windows can use.

Lire cette réponse dans son contexte 👍 2

Toutes les réponses (6)

more options

Did you check if your Windows keyboard language is correctly setted? You should have a system icon with the current language on the right of your taskbar. You can also try the Virtual Keyboard of Windows to check what happens.

more options

Thank you. I don't know a lot about computers so I am not sure how to check the things you suggest. However, this only happens in Mozilla so I assume that it is a problem with the Mozilla settings. Unfortunately, I don't know how to find the appropriate setting. When I look at Mozilla Firefox properties. there is no mention of keyboard language.

more options

Solution choisie

Actually Mozilla Firefox has not its own keyboard parameters (but there are display page and check spelling language parameters). Sometimes Windows keyboard language changes unintentionally, example giving with keyboard shortcut Shift+Alt. For the moment, check if you have more than one keyboard language installed: open the Control Panel > Language, and you should have the list of languages Windows can use.

more options

Thank you so much. I think I think the problem may be solved.

more options

Happy to help!

more options

Do you have multiple keyboard layouts installed? It is possible that the keyboard layout has been switched by accident by using the key sequence to rotate the keyboard layout.

Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut.

  • Make sure that you have the Language bar visible on the Windows Taskbar
  • You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar
  • Check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar
  • You need to do that while Firefox has focus because Windows remembers the keyboard layout setting per application
  • The default key combination to rotate the layout is the Ctrl+Shift or Alt+Shift combination that is used in Firefox for menu items, so it is possible to change the layout accidentally.
  • To avoid an unintentional switch, assign a specific key sequence (Alt/Ctrl+Shift+number) to select keyboard layouts and remove the key combination to rotate layouts (Alt+Shift or Ctrl+Shift)