Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

How to stop the debugger?

  • 5 réponses
  • 2 ont ce problème
  • 5651 vues
  • Dernière réponse par cor-el

more options

Yesterday I used the debugger. Now each time I try to inspect code, I get the message "Debugger is paused". There is no breakpoint, I do not pause the debugger. How can it be stopped? (yes I googled, and pressed every button I found ... no way) Thank you!

Yesterday I used the debugger. Now each time I try to inspect code, I get the message "Debugger is paused". There is no breakpoint, I do not pause the debugger. How can it be stopped? (yes I googled, and pressed every button I found ... no way) Thank you!

Solution choisie

guigs2 said

In order to stop the debugger, try two things:
  1. Click on Tools > Web Developer > and make sure Debugger is not checked
  2. Toggle the tools instead > Click on "Debugger" and click on the gear in the right corner and uncheck "Show on Startup"

Thanks for your reply. The problem was not whether the debugger is shown or not. I want to use the debugger, it's great. I was just not able to switch it off once it was running, so once started, I always got the message "Debugger is paused" and could not inspect. It did not help to hide the debugger. It did help to close the tab and reopen the page in a new tab.

Now, after a Firefox restart, where it updated itself, I tried to replicate the error, but it doesn't happen again. So I assume the latest update fixed it.

Lire cette réponse dans son contexte 👍 0

Toutes les réponses (5)

more options

In order to stop the debugger, try two things:

  1. Click on Tools > Web Developer > and make sure Debugger is not checked
  2. Toggle the tools instead > Click on "Debugger" and click on the gear in the right corner and uncheck "Show on Startup"

Did this help?

more options

You can check devtools.debugger.* prefs on the about:config page to see if any have changed from the default.

more options

cor-el said

You can check devtools.debugger.* prefs on the about:config page to see if any have changed from the default.

Thanks, I checked: The only thing not default is devtools.debugger.ui.panes-sources-width ...

more options

Solution choisie

guigs2 said

In order to stop the debugger, try two things:
  1. Click on Tools > Web Developer > and make sure Debugger is not checked
  2. Toggle the tools instead > Click on "Debugger" and click on the gear in the right corner and uncheck "Show on Startup"

Thanks for your reply. The problem was not whether the debugger is shown or not. I want to use the debugger, it's great. I was just not able to switch it off once it was running, so once started, I always got the message "Debugger is paused" and could not inspect. It did not help to hide the debugger. It did help to close the tab and reopen the page in a new tab.

Now, after a Firefox restart, where it updated itself, I tried to replicate the error, but it doesn't happen again. So I assume the latest update fixed it.

more options

Did you check your extensions?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window