Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

When I click on a link for a PDF document on a web page, nothing happens.

  • 3 réponses
  • 1 a ce problème
  • 17 vues
  • Dernière réponse par jscher2000

more options

When I click on a link for a PDF document on any web page, nothing happens. There is no error or message, and the document doesn't download. I've tried going to my Firefox options, then to the Applications tab, and then to Portable Document Format (PDF), and changing the dropdown to Preview in Firefox. I've also tried changing the dropdown to use Adobe Reader. It still doesn't work.

Toutes les réponses (3)

more options

Hi shbarnha,

Thank you for contacting our support community.

You can try the steps in the following link:

Make sure you really have a PDF reader on your computer, such as Adobe Acrobat.

More information:

more options

Does this problem occur on all sites, or only on particular sites, such as with email attachments?

(As a test, you can find PDFs using this search and try opening them directly from the results page:

The reason for the question is that some links are scripted and/or use pop-up windows, so the problem could be in those areas.

more options

Usually if Firefox is confused about how to handle a PDF, it still will download it. If the link acts as though it is "dead" then I wonder whether an add-on might be interfering...

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?