Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Search toolbar box no longer displays search engines with 34.0.5 update

  • 9 réponses
  • 33 ont ce problème
  • 9 vues
  • Dernière réponse par bobrooney

more options

The 34.0.5 update just made my life more difficult! Now i have to click on the drop down, select Change Search Settings, then from another drop down select which search engine I want to use. This is so infuriating and frustrating! Why would the programmers make it more difficult for everyone? I mean, its just doesnt make sense! Sometimes i just wish i could turn OFF these lousy updates that do nothing but break things that ran smoothly. Is there any way to get the search box to just work efficiently again? I just need a simple dropdown from the magnifier like it used to be before!

Solution choisie

You can revert to the previous Search Bar scheme like this.

Open up about:config (typed in the Location Bar) Right-click and toggle this preference to false

browser.search.showOneOffButtons

Then restart Firefox.

Lire cette réponse dans son contexte 👍 35

Toutes les réponses (9)

more options

hello bobrooney, the new search bar should make it easier to choose between different search providers than before. if you type a search term you can just hit enter in order to use the default search engine or chose any different engine just for this particular search by clicking on the corresponding icons. the workings of the search bar are described in more detail at Search with the Firefox address bar

more options

Unfortunately, i dont have any icons when i click on the drop down. All i have is Add "Firefox Help" and Change Search Settings. When i click on Change Search Settings, I can see all my search engines listed and checked off to be displayed.

more options

when you don't have any search icons when you start typing a search term (see highlighted section of the screenshot attached) then this might be a bug. can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Modifié le par philipp

more options

no luck in safe mode. still no icons appearing.

more options

these icons should appear when you start typing (as opposed to "when i click on the drop down" how you mentioned it before)

more options

ah, ok, they do show up. thanks!

more options

Solution choisie

You can revert to the previous Search Bar scheme like this.

Open up about:config (typed in the Location Bar) Right-click and toggle this preference to false

browser.search.showOneOffButtons

Then restart Firefox.

more options

You can check if you have the XML files of default search engines like Google and Yahoo! in the browser\searchplugins folder in the Firefox program folder.

If not then you need to reinstall Firefox.

You can find the full version of the current Firefox 34.0 release in all languages and for all Operating Systems here:

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.

You can use this button to go to the currently used Firefox profile folder:

more options

thanks! this is even better!