Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Firefox download of files not working or not finishing for one user on one computer account but does for another on a separate account.

  • 8 réponses
  • 11 ont ce problème
  • 118 vues
  • Dernière réponse par FredMcD

more options

Firefox on mac osx with automatic updates for OS and Firefox up to date for over a year recently started producing failed downloads (probably between 9-13 and 9-14, around the time of the last Firefox update). What has been tried to fix this: everthing from the Mozilla help pages “What to do if you can't download or save files” asserted to be based on information from “Unable to save or download files (mozillaZine KB)” with the exception of dealing with the "plist" file since that could not be found in this OS installation. If anything has changed through these efforts, it has been to cause the failure to be more severe. Before attempting any fixes, the downloads usually produced a zero-byte file of the expected name and an apparently full-length download file with the expected name and a ".part" extension (or an abbreviated download file with a jumbled alphanumeric name and ".part" extension). After all the fixes were attempted, with the additional trial of patching the profile from TimeMachine back-ups well before the initiation of the problems, and then a final effort of a complete Firefox re-install (freshly downloaded via the separate account on the computer then Firefox removed prior to a fresh install), downloads now fail for that one problem account producing only the zero-byte file of the expected name and no ".part" files yet seen again. Created new profiles in Firefox under the same computer account inherit the same download problems (tried twice).

FYI: in addition to the troubleshooting information below, the computer account with the Firefox problems reports another four plug-ins (Blue Jeans, RBlue Jeans and "install" for both). As these do not show up on this computer account where the Firefox browser has no download issues, this may matter. But since the download issues were independent of Safe Mode operation for Firefox, presumably the plug-in differences would not matter.

Toutes les réponses (8)

more options

In order to fix the problem, try disabling the scanning as follows:

#    In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  1. Click I'll be careful, I promise!, to continue to the about:config page. A list of settings should appear
  2. Filter the list by typing in the search bar at the top. Type in scanWhenDone. You should now find the preference.
  3. Double-click on that preference to set the value to false.
  4. Next, try to download something and see if it still hangs.

Please reply and tell us whether this helped you!

more options

Guigs2: thank you for the help. But the preference was not there (when you type in, neither of the two preferences that show up are "scan..." (there is no "scan" anything). This was true for both computer accounts, the one with downloads working and the one where they do not. If I type in scanWhenDone (or even the shorter "scan") for the search, there was nothing, either {I will have to go back and try that on the other account as well. I am on the 'good' one presently} But I just got a notification that there was an update to Firefox available. I will make sure that got installed and try again.

AND back again: Checked the other computer account for the results of trying "scan" (or "scanWhenDone") in about:config --- the same in both the good and bad accounts: nothing found.

Checked and verified the Firefox update installed, then retried downloading (failed) and searched the preferences again in about:config (the same status still from either computer account).

One additional note: there have been downloads attempted in the 'bad' account {by the owner} over the past few days and at least two resulted in the two file end state where the expected file name has a zero byte file and the temporary download [alphanumeric-jumble].part file looks possibly to be complete based on its size.

Modifié le par aparmstrong

more options

Possible areas to investigate on this I have thought of are two: first, file and/or folder permissions; and two, the type and management of the account.

I have only checked the permissions arena by looking at the downloads folders: those seem to be completely parallel in the two computer accounts.

But I found more time to look at the account issues just now. On this computer, there are three account types in use: standard, managed (parental controls) and administrative. The 'good' account referenced so far in the discussion is administrative while the 'bad' account is managed (but with very few restrictions in place). When the download issue was checked on two existing standard accounts, there were no problems. An additional managed account was created with matching parental controls to those of the 'bad' account (since there was not another existing one like it): the same download issues were found there.

summary --- account type --- download status --- how many accounts administrative working 1 standard working 2 managed "failed" 2

So this may be an OS / interaction issue rather than simply a Mozilla issue. Of course, if the OS were from Microsoft, that would not be.  ;)

Any help still would be appreciated.

more options

FredMcD: thank you for your reply. However, the link you posted is to one I noted I had used prior to asking for help (or to one eerily and essentially identical to that).

One correction: apparently this computer had not been set to automatically do upgrades for the Mac OS X (but does do them automatically for Firefox). So the original question posting with the assertion that both Firefox and OS X were up to date was wrong. Actually, the OS X had not been updated since 10.9.2 {updated on this computer in March, 2014} and the current release is 10.9.5 {release date ?}. That may have been out before the apparent issue onset date of 9-13-2014 based on the downloaded files history (last download before issues arose as evidenced by partial/failed download files from 9-14).

My current hypothesis is that this may come from some changes in the Firefox 32.0.1 update released 9-12-2014 (and likely installed on this computer on 9-13-2014).

more options

The managed account, change it to standard and test it. You can always change it back.

What is the difference between the two? Does managed have blocks on it?

more options

Yes, this is a solution of sorts. Changing the account from Managed to Standard results in downloads working properly. But it does not explain why they were working and then stopped working (on or about 9-13-2014 and presumably connected with the Firefox update 32.0.1).

But to answer your questions about the Managed account settings: very few restrictions were/are in place. OS X has five tabs for the controls: Apps, Web, People, Time Limits and Other. Web, People and TIme Limits have no restrictions set on them and Other, which seems unlikely to matter, has four checked { Disable Dictation, Hide profanity in Dictionary, Limit printer administration and Limit CD and DVD burning } and two unchecked [ Disable built-in camera and Disable changing the password]. This leaves Apps. I also think this has no restrictions set as there are no non-greyed-out boxes checked [ Use Simple Finder, Limit Applications and Prevent the Dock from being modified ]. So with these few limits, none of which seem relevant, it seems that simply having the account in Managed status produces the downloading issues.

This should not be relevant, but the the greyed-out boxes under Allowed Apps can be activated by checking Limit Applications. The defaults there were to have checked { App Store and Widgets } and [ Other Apps and Utilities ] unchecked. Firefox is, of course, under Other Apps. So again, this should have no effect, but I tried cycling Limit Applications to checked allowed conversion so that all of the check boxes could be converted to checked { App Store, Other Apps, Widgets and Utilities } and then switching LImit Applications back to unchecked. I will be back shortly to update whether this had any effect=> and, no, it had no effect: downloads still fail.

I also tried clearing all of the limitations by unchecking all of the boxes under the "Other" tab. So with _NO_ evident limits it seems that simply having the account in Managed status produces the downloading issues.

Modifié le par aparmstrong

more options

I have called for more help. I am sorry I can not help more.