Réactiver les modules complémentaires qui ont été désactivés après une mise à jour de Firefox

Depuis la version 57 de Firefox, seuls fonctionnent les modules complémentaires développés en utilisant les API WebExtensions. Si vous voulez vous assurer que vos modules sont concernés, consultez l’article Modernisation de la technologie des modules pour Firefox et ces questions fréquemment posées pour davantage d’informations.

Quand vous mettez Firefox à jour, il vérifie automatiquement les modules et les met à jour vers des versions compatibles lorsque c’est possible. Il désactive les modules complémentaires qui ne sont plus compatibles. Cet article explique comment rendre vos modules complémentaires de nouveau fonctionnels.

invite-sélection-modules.png
Note : si un module complémentaire est désactivé et affiche un message du type (Nom du module) n’a pas pu être vérifié pour son utilisation dans Firefox, consultez l’article La signature des modules complémentaires dans Firefox.

Rechercher des nouvelles versions de vos modules complémentaires

Firefox recherche une fois par jour des nouvelles versions de vos modules complémentaires et les met à jour automatiquement, mais vous pouvez rechercher manuellement des nouvelles versions à tout moment.

  1. Cliquez sur le bouton de menu Fx57Menu pour développer le panneau de menu.
  2. Cliquez sur Modules complémentairesModules complémentaires et thèmesExtensions et thèmes. La page du Gestionnaire de modules complémentaires s’ouvre.
  3. Cliquez sur Add-on Tools Icon dans le Gestionnaire de modules complémentaires et sélectionnez Rechercher des mises à jour. Si Firefox trouve des mises à jour, elles seront automatiquement téléchargées.
    rechercher-mise-à-jour-modules.png
  4. Cliquez sur le lien Redémarrer maintenant pour terminer l’installation si Firefox vous y invite.
    redémarrer-pour-installer-modules.png

Rechercher des mises à jour sur le site web du module complémentaire

Certains éditeurs de modules complémentaires ont différentes versions de leurs modules pour différentes versions de Firefox, si bien que la mise à jour automatique ne fonctionne pas. Dans ce cas, une mise à jour pourrait être disponible sur le site web du module complémentaire.

  1. Dans l’onglet du gestionnaire de modules complémentaires, trouvez les modules incompatibles dans la liste. Cliquez sur le lien Plus pour obtenir davantage d’informations sur ce module, puis cliquez sur le lien à côté de Page d’accueil afin de vous rendre sur la page web de ce module.
  2. Téléchargez la dernière version du module complémentaire depuis la page web de ce module.
Note : s’il n’y a pas de version fonctionnelle disponible du module complémentaire, cela pourrait aider de contacter les personnes développant le module pendant que vous êtes sur leurs sites web.

Rechercher des alternatives

Il peut y avoir d’autres modules complémentaires avec des fonctionnalités analogues qui soient compatibles avec votre version de Firefox. Le site des modules complémentaires est un bon endroit pour rechercher des alternatives.

Cet article vous a-t-il été utile ?

Veuillez patienter…

Ces personnes ont aidé à écrire cet article :

Illustration of hands

Participer

Développez et partagez votre expertise avec les autres. Répondez aux questions et améliorez notre base de connaissances.

En savoir plus