Que faire devant l'erreur « Échec de la connexion sécurisée »

Cet article explique pourquoi vous pouvez voir une page d’erreur qui indique Échec de la connexion sécurisée ou Connexion bloquée : problème de sécurité potentiel et ce que vous pouvez faire dans ce cas.

Une connexion sécurisée ne peut être établie

Quand un site web qui demande une connexion sécurisée (https) essaie de sécuriser la communication avec votre ordinateur, Firefox effectue une vérification croisée de cette tentative pour s’assurer que le certificat du site web et la méthode de connexion sont effectivement sûrs. Si Firefox ne peut pas établir de connexion sécurisée, il affiche une des deux pages d’erreur que le présent article détaille, Échec de la connexion sécurisée ou Connexion bloquée : problème de sécurité potentiel.

Échec de la connexion sécurisée

Une page d’erreur Échec de la connexion sécurisée comprend une description de l’erreur, la possibilité de signaler l’erreur à Mozilla et un bouton Réessayer. Il n’existe pas d’option pour ajouter une exception de sécurité qui permettrait de contourner ce type d’erreur.

fx60SecureConnectionFailed-ErrorCode

La page d’erreur comprend également les informations suivantes :

  • La page que vous essayez de consulter ne peut pas être affichée car l’authenticité des données reçues ne peut être vérifiée.
  • Veuillez contacter les propriétaires du site web pour les informer de ce problème.

Connexion bloquée : problème de sécurité potentiel

Certains échecs de connexion sécurisée vont produire une page d’erreur Connexion bloquée : problème de sécurité potentiel.

Fx67SecError-DidNotConnect

La page d’erreur comprend une description du problème potentiel de sécurité, la possibilité de signaler l’erreur à Mozilla et un bouton Avancé… pour voir le code d’erreur et d’autres détails techniques. Il n’existe pas de possibilité d’ajouter une exception de sécurité pour visiter le site web.

Problèmes avec les sites web

Version non prise en charge de TLS

Certains sites web essaient d’utiliser un mécanisme obsolète (et donc qui n’est plus sécurisé) Transport Layer Security (TLS) pour renforcer la sécurité de votre connexion. Firefox vous protège en empêchant la navigation sur de tels sites s’il existe un problème dans l’établissement d’une connexion sécurisée. Contactez les propriétaires du site web et demandez-leur de mettre à jour leur TLS vers une version plus récente et encore sécurisée.

Depuis Firefox version 78, la version minimum acceptée par défaut pour le TLS est la version 1.2. Les sites web qui ne prennent pas en charge les versions 1.2 ou supérieures de TLS affichent une page d’erreur Échec de la connexion sécurisée affichant le code d’erreur SSL_ERROR_UNSUPPORTED_VERSION et le message Ce site web pourrait ne pas prendre en charge le protocole TLS 1.2, qui est la version minimale prise en charge par Firefox.

Fx78SecureConnectionFailed-TLS

La page d’erreur peut également comporter un bouton Activer TLS 1.0 et 1.1 vous permettant de passer outre la restriction sur la version minimale de TLS.
Note : Mozilla prévoit de retirer cette option et de désactiver définitivement les versions TLS 1.0 et 1.1 dans une prochaine version de Firefox. Pour plus d’informations, consultez cette page de Mozilla (en anglais).

=HSTS obligatoire

D’autres sites web exigent le protocole HSTS (HTTP Strict Transport Security (en anglais)) et ne permettent pas un accès avec une connexion non sécurisée.

Conflits avec des logiciels de sécurité

De nombreux logiciels de sécurité utilisent une fonctionnalité qui intercepte par défaut les connexions sécurisées. Cela peut provoquer des erreurs de connexion ou des alertes de sécurité sur les sites web sécurisés. Si vous rencontrez des erreurs de connexion sur de multiples sites web sécurisés, mettre à jour votre logiciel de sécurité ou modifier ses paramètres peut résoudre le problème. Consultez cette section d’article sur les logiciels antivirus pour obtenir de l’aide sur les logiciels de sécurité spécifiques qui peuvent causer ces erreurs, comme les produits Avast, AVG et ESET.

Sinon, vous pouvez désinstaller le logiciel de sécurité tiers et utiliser Windows Defender, l’antivirus intégré à Windows 8 et Windows 10.

Heure incorrecte de l’horloge système

Firefox utilise des certificats sur les sites web sécurisés pour s’assurer que vos informations sont envoyées au destinataire voulu et ne peuvent pas être interceptées par des yeux indiscrets. Une valeur incorrecte de l’horloge de votre système peut expliquer que Firefox repère comme invalide ou expiré le certificat du site web. Assurez-vous que votre ordinateur est réglé à la bonne date et à la bonne heure pour le bon fuseau horaire. Pour d’autres informations, consultez l’article Erreurs liées à la date et l'heure sur des sites web sécurisés : que faire ?

Autres problèmes de connexion

Pour régler d’autres problèmes de connexion sécurisée qui ne sont pas évoqués ici, consultez :

Cet article vous a-t-il été utile ?

Veuillez patienter…

Ces personnes ont aidé à écrire cet article :

Illustration of hands

Participer

Développez et partagez votre expertise avec les autres. Répondez aux questions et améliorez notre base de connaissances.

En savoir plus