Plugin Flash – le garder à jour et résoudre les problèmes

Le plugin pour navigateur Adobe Flash Player vous permet de voir des vidéos et des contenus animés dans Firefox. Cet article contient des informations sur le test, la mise à jour et la résolution des problèmes du plugin Adobe Flash.

Note : La fonctionnalité de mise à jour du logiciel Firefox ne met pas à jour les plugins installés. Consultez la page de bulletins et d'avis de sécurité d'Adobe pour toute information sur les problèmes de sécurité et de stabilité affectant Adobe Flash Player et les autres produits d'Adobe.

Tester Flash

Visitez la page de test d'Adobe pour voir si le plugin Flash est installé et fonctionne correctement. Si elle dit que Flash n'est pas installé, vous pouvez consulter l'article Installer le plugin Flash pour voir des vidéos, animations et jeux ou suivre les instructions dans la section mettre à jour Flash ci-dessous pour installer le plugin Flash.

Mettre à jour Flash

Le plugin Flash se met à jour automatiquement par défaut. Si la page Vérification des plugins de Mozilla ou la page de test d'Adobe dit que Flash n'est pas à jour et que vous ne voulez pas attendre la mise à jour automatique, vous pouvez mettre à jour Flash manuellement en téléchargeant et en installant la dernière version d'Adobe.

Pour vérifier que votre installation de Flash est à jour, visitez la page Vérification des plugins de Mozilla. Si elle dit que Flash n'est pas à jour, vous pouvez mettre à jour Flash en téléchargeant et en installant la dernière version d'Adobe.

  1. Rendez-vous sur la page Adobe de téléchargement du lecteur Flash et téléchargez le fichier d'installation de Flash.
    Avertissement : la page de téléchargement d'Adobe peut inclure une case cochée par défaut pour un logiciel facultatif tel que « Google Chrome » ou « McAfee Security Scan ». Si vous ne décochez pas cette case avant le téléchargement, ce logiciel sera installé sur votre ordinateur lors de l'exécution du fichier d'installation de Flash.
  2. Quand le téléchargement est terminé, fermez Firefox.

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  3. Ouvrez le fichier d'installation de Flash, puis suivez les instructions.
Note : si vous avez des problèmes avec le fichier d'installation de Flash récupéré depuis la page de téléchargement d'Adobe, vous pouvez utiliser ce lien vers le fichier d'installation de Flash pour télécharger directement l'installateur complet.
  1. Rendez-vous sur la page d'Adobe page de téléchargement du lecteur Flash et téléchargez le fichier d'installation de Flash.
  2. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  3. Ouvrez le fichier que vous avez téléchargé (c.à-d. install_flash_player_osx_intel.dmg).
  4. Dans le Finder, ouvrez Install Adobe Flash Player.app pour démarrer l'installation, ensuite suivez les instructions d'installation.
  1. Rendez-vous sur la page de téléchargement du lecteur Flash d'Adobe.
  2. Lorsque vous y êtes invité, enregistrez le fichier install_flash_player_"version"_linux."processor".tar.gz.
  3. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  4. Ouvrez une fenêtre Terminal (dans Gnome, cliquez sur le menu Applications, sélectionnez Accessoires, puis sélectionnez Terminal).
  5. Dans une fenêtre Terminal, rendez-vous dans le répertoire où vous avez enregistré le fichier téléchargé (p.ex. « cd /home/user/Downloads »).
  6. Extrayez libflashplayer.so du fichier que vous avez téléchargé avec la commande tar -zxvf install_flash_player_"version"_linux."processor".tar.gz.
  7. En tant que super utilisateur (sudo), copiez le fichier extrait, libflashplayer.so, vers votre sous-répertoire plugins de votre répertoire d'installation de Firefox. Par exemple, si Firefox est installé dans /usr/lib/mozilla, utilisez la commande « sudo cp libflashplayer.so /usr/lib/mozilla/plugins », puis entrez votre mot de passe de super utilisateur lorsque vous y êtes invité.

    0a85171f1802a3b0d9f46ffb997ddc02-1260326970-447-1.png

Désinstaller Flash

Pour des instructions sur la désinstallation de Flash rendez-vous sur le site d'assistance d'Adobe, consultez Désinstallation de Flash Player sous WindowsDésinstallation de Flash Player sous Mac OS.

Note : L'exécution du fichier de désinstallation d'Adobe supprimera Flash de tous les navigateurs où il n'est pas intégré, y compris Internet Explorer. Vous serez invité à réinstaller Flash quand vous visiterez une page qui le nécessite, telle que la page de test d'Adobe.

Résoudre les problèmes

Le Plugin Flash ne fonctionne pas

Si la page de test d'Adobe ne signale pas que Flash fonctionne même si vous avez installé la dernière version, il se peut que le Plugin Flash soit désactivé. Pour s'assurer qu'il soit bien activé,

  1. En haut de la fenêtre Firefox, cliquez sur le bouton FirefoxSur la barre de menus, cliquez sur le menu OutilsEn haut de la fenêtre Firefox, cliquez sur le menu Outils, puis cliquez sur Modules complémentaires. L'onglet du « Gestionnaire de modules complémentaires » s'ouvre. Cliquez sur le bouton menu New Fx Menu et choisissez Modules. L'onglet du « Gestionnaire de modules complémentaires » s'ouvre.

  2. Dans l'onglet du « Gestionnaire de modules complémentaires », sélectionnez le panneau Plugins

Si le Plugin Flash est désactivé, cliquez sur le bouton Activer

Si le Plugin Flash est désactivé, cliquez sur le bouton Toujours activer dans son menu déroulant.

Flash fonctionne avec Internet Explorer ou Chrome mais pas avec Firefox

Il existe trois types différents de lecteurs Flash : une version ActiveX version pour Internet Explorer, une version pour Chrome intégrée au navigateur et une version plugin pour Firefox et quelques autres navigateurs. Si vous voulez que Flash fonctinne avec Firefox vous devez installer la version plugin, suivant la procédure qui est expliquée ci-dessus.

Fenêtre : « Activer Adobe Flash »

Si vous voyez une fenêtre qui vous invite à « Activer Adobe Flash » au lieu de contenu Flash, soit vous avez configuré le plugin Flash pour « Demander pour activer » dans le gestionnaire de modules complémentaires soit Firefox a empêché une version dangereuse de Flash de s'exécuter automatiquement. Cliquez sur le message « Activer Adobe Flash » pour permettre le chargement du contenu Flash (si cela ne fonctionne pas, rechargez la page et essayez à nouveau). Pour plus d'informations, consultez les articles Paramétrer Adobe Flash afin qu'il ne se lance qu'à la demande sous Firefox et Pourquoi dois-je cliquer pour activer les plugins ?.

Le plugin Adobe Flash a planté

Si vous avez ce message au lieu du contenu Flash, consultez Le plugin Adobe Flash a planté – empêcher que cela se reproduise.

Le plugin ne répond plus

Firefox vous affichera un avertissement si le plugin Flash est occupé ou ne répond pas :
warning-unresponsive-plugin
Consultez l'article Attention : le plugin ne répond pas – ce que cela signifie et le corriger pour y remédier ou éviter que cela se reproduise.

Les vidéos en flash n'apparaissent pas en plein écran

Consultez l'article Les vidéos Flash ne fonctionnent pas en plein écran sur YouTube, Facebook et d'autres sites.

La lecture de vidéos Flash provoque le blocage de Firefox

Si Firefox ne répond plus, ou si le plugin Flash plante ou ne fonctionne plus à la lecture d'un contenu Flash, vous pouvez essayer ces solutions :

  • Suspendez ou arrêtez la lecture de contenu Flash dans les autres onglets. Il est possible que vous soyez obligé de fermer ces onglets.
  • Mettez à jour Flash. Référez-vous à la section Mettre Flash à jour ci-dessus.
  • Désactivez l'accélération matérielle dans Flash en suivant ces étapes :
    1. Allez à cette page d'aide d'Adobe Flash Player (anglais).
    2. Clic droit sur le logo Flash Player de cette page, puis cliquez sur Paramètres dans le menu contextuel. L'écran « Paramètres d'Adobe Flash Player » s'ouvre.

      fpSettings_FR.png
    3. Cliquez sur l'icône en bas à gauche de la fenêtre « Paramètres d'Adobe Flash Player » pour ouvrir le panneau d'affichage.
    4. Décochez Activer l'accélération matérielle.

      fpSettings1_FR.png
    5. Cliquez sur Fermer pour fermer la fenêtre « Paramètres d'Adobe Flash Player ».
    6. Redémarrez Firefox.
  • Mettez à jour vos pilotes graphiques. Jetez un coup d'œil à l'article Mettre à jour vos pilotes graphiques pour utiliser l'accélération graphique matérielle et WebGL pour lire davantage de détails.
Cet article est en anglais mais vous pouvez avoir une version traduite en français en cliquant dands le menu déroulant des langues tout en bas à droite de la page
  • Désactivez le mode protégé de Flash (anglais) en suivant ces étapes. 
    Avertissement : Le mode protégé, qui est activé par défaut, est une caractéristique de sécurité d'Adobe Flash. La désactivation du mode protégé va réduire la protection de sécurité.
  1. Dans la barre d'adresse, saisissez about:config, puis appuyez sur EntréeRetour.

    • La page d'avertissement « Attention, danger ! » doit apparaître. Cliquez sur Je ferai attention, promis ! pour accéder à la page « about:config ».
  2. Recherchez dom.ipc.plugins.flash.disable-protected-mode dans la liste des préférences.
  3. Double-cliquez sur la préférence pour basculer sa valeur de false à true. (si la préférence est déjà sur true cela signifie que le mode protégé du Flash est désactivé).
  4. Fermez Firefox.

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  5. Redémarrez Firefox.
  • Désactivez le mode protégé de Flash (anglais) en suivant ces étapes.
    Avertissement : Le mode protégé qui est activé par défaut est une caractéristique de sécurité d'Adobe Flash. La désactivation du mode protégé va réduire la protection de sécurité.
  1. Dans la barre d'adresse, saisissez about:config, puis appuyez sur EntréeRetour.

    • La page d'avertissement « Attention, danger ! » doit apparaître. Cliquez sur Je ferai attention, promis ! pour accéder à la page « about:config ».
  2. Recherchez dom.ipc.plugins.flash.disable-protected-mode dans la liste des préférences.
  3. Double-cliquez sur la préférence pour basculer sa valeur de false à true. (si la préférence est déjà sur true cela signifie que le mode protégé de Flash est désactivé).
  4. Fermez Firefox.

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  5. Redémarrez Firefox.
  • Désactivez le mode protégé d'Adobe Flash en suivant ces étapes.
    Avertissement : Le mode protégé qui est activé par défaut est une caractéristique de sécurité d'Adobe Flash. La désactivation du mode protégé va réduire la protection de sécurité.
  1. En haut de la fenêtre Firefox, cliquez sur le bouton FirefoxSur la barre de menus, cliquez sur le menu OutilsEn haut de la fenêtre Firefox, cliquez sur le menu Outils, puis cliquez sur Modules complémentaires. L'onglet du « Gestionnaire de modules complémentaires » s'ouvre. Cliquez sur le bouton menu New Fx Menu et choisissez Modules. L'onglet du « Gestionnaire de modules complémentaires » s'ouvre.

  2. Dans l'onglet du « Gestionnaire de modules complémentaires », sélectionnez le panneau Plugins
  3. Trouvez Shockwave Flash dans la liste des plugins et cliquez sur Options.
  4. Décochez Activer le mode protégé d'Adobe Flash.
    Fx38-UI-AdobeFlash-protected-mode
  5. Fermez Firefox.

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  6. Redémarrez Firefox.


Autres problèmes avec Flash ? — Des pistes pour les résoudre

  • Si le contenu Flash ne fonctionne pas, agit bizarrement ou cause des erreurs ou si vous voyez un avertissement comme quoi vous avez besoin de mettre à jour Flash (par exemple Vérification des plugins) même après avoir installé la dernière version de Flash, désinstallez, puis réinstallez Flash.




Basé sur des informations de Flash (mozillaZine KB)


Partagez cet article : http://mzl.la/1BAQTH9

Cet article vous a-t-il été utile ? Veuillez patienter…

Ces formidables personnes ont aidé à écrire cet article : Goofy_BZ, scoobidiver, barzogh, irahal, fleurquin, J2m06. Vous pouvez également aider - découvrez comment.