Les anciennes versions de Java ont été bloquées – mettre à jour et débloquer Java | Résolution de problèmes

Les anciennes versions de Java ont été bloquées – mettre à jour et débloquer Java

(Redirigé depuis Débloquer le plugin Java)

Cet article n'est plus maintenu. Par conséquent, son contenu pourrait ne plus être à jour.

Des anciennes versions du plugin Java ont récemment été ajoutées à la liste de blocage des modules complémentaires de Firefox afin que le plugin soit désactivé. En effet, ces anciennes versions sont vulnérables à une attaque qui pourrait permettre à quelqu'un de prendre le contrôle de votre ordinateur sans votre consentement, d'accéder à des fichiers ou de voler des informations critiques comme des identifiants et mots de passe de banque. Cet article décrit les instructions à suivre pour mettre à jour Java afin qu'il fonctionne de nouveau.

Des anciennes versions du plugin Java sont vulnérables à une attaque qui pourrait permettre à quelqu'un de prendre le contrôle de votre ordinateur sans votre consentement, d'accéder à des fichiers ou de voler des informations critiques comme des identifiants et mots de passe de banque. Cet article décrit les instructions à suivre pour mettre à jour Java afin qu'il fonctionne de nouveau.

Mettre à jour Java

Firefox ne bloque que les versions vulnérables du plugin Java, donc la chose à faire est de mettre à jour Java à sa dernière version. Malheureusement, installer une nouvelle version de Java ne supprime pas nécessairement les anciennes versions de Java de votre ordinateur, ce qui vous laisse vulnérable. Vous devez donc désinstaller toutes anciennes versions de Java afin de pouvoir effectuer la mise à jour.

  1. Rendez-vous sur la page de téléchargement de Java et téléchargez le fichier d'installation de Java, mais ne l'exécutez pas encore.
  2. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

    .
  3. Depuis le menu « Démarrer » dans la barre des tâches Windows, sélectionnez Panneau de configuration. Le panneau de configuration s'ouvre.

    sélectionner-panneau-conf.png
  4. Ouvrez la liste des programmes Windows.
    • (Windows Vista/7) : Cliquez sur Programmes, puis sur Programmes et fonctionnalités.
    • (Windows 2000/XP) : Double-cliquez sur Ajouter ou supprimer des programmes.
  5. Depuis la liste des programmes actuellement installés, sélectionnez tout programme Java ou Java Runtime.
  6. Pour commencer la désinstallation :
    • (Windows Vista/7) : Cliquez sur Désinstaller en haut de la fenêtre.
    • (Windows 2000/XP) : Cliquez sur Supprimer sur la droite de la liste Java.
      Note : Finissez le processus de désinstallation avant de continuer.
  7. Exécutez le fichier d'installation que vous avez téléchargé à l'étape 1.
  8. Démarrez Firefox

Java devrait désormais fonctionner comme attendu.

Firefox ne bloque que les versions vulnérables du plugin Java, donc la chose à faire est de mettre à jour Java à sa dernière version.

  1. Rendez-vous sur la page de téléchargement de Java et téléchargez le fichier d'installation de Java.
  2. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

    .
  3. Exécutez le fichier d'installation que vous avez téléchargé à l'étape 1.
  4. Démarrez Firefox.

Java devrait désormais fonctionner comme attendu.

La chose à faire est de mettre à jour Java vers sa dernière version.

  1. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  2. Depuis le menu Pomme, sélectionnez Mises à jour logiciel….
  3. Sélectionnez la mise à jour Java, puis cliquez sur Installer. Attendez que la mise à jour se termine.
  4. Démarrez Firefox

Java devrait désormais fonctionner comme attendu.

Si vous avez précédemment sélectionner « Désactiver » dans la boîte de dialogue de blocage, vous pouvez avoir besoin d'activer de nouveau le plugin Java :

  1. En haut de la fenêtre Firefox, cliquez sur le bouton FirefoxSur la barre de menus, cliquez sur le menu OutilsEn haut de la fenêtre Firefox, cliquez sur le menu Outils, puis cliquez sur Modules complémentaires. L'onglet du « Gestionnaire de modules complémentaires » s'ouvrira. Cliquez sur le bouton menu New Fx Menu et choisissez Modules pour ouvrir l'onglet « Gestionnaire de modules complémentaires ».

  2. Trouvez l'élément Java Platform ou Java Runtime, puis cliquez sur Activer.

Contourner la liste de blocage

Si vous n'êtes pas en mesure de mettre à jour Java et qu'il est important pour vous de continuer à l'utiliser, vous pouvez réactiver la version bloquée.

Avertissement : Ceci vous laissera vulnérable aux attaques. Le simple fait de visiter un site web compromis pourrait permettre la prise de contrôle à distance de votre ordinateur.

Activer Java

  1. En haut de la fenêtre Firefox, cliquez sur le bouton FirefoxSur la barre de menus, cliquez sur le menu OutilsEn haut de la fenêtre Firefox, cliquez sur le menu Outils, puis cliquez sur Modules complémentaires. L'onglet du « Gestionnaire de modules complémentaires » s'ouvrira. Cliquez sur le bouton menu New Fx Menu et choisissez Modules pour ouvrir l'onglet « Gestionnaire de modules complémentaires ».

  2. Trouvez l'élément Java Platform ou Java Runtime, puis cliquez sur Activer.



Partager cet article : http://mzl.la/MN0qiT

Ces formidables personnes ont aidé à écrire cet article : scoobidiver, Mozinet. Vous pouvez également aider - découvrez comment.
Obtenir de l'aide pour une autre plateforme :
Personnaliser cet article

Firefox