Changer le programme utilisé pour ouvrir les liens de courriel | Comment faire

Changer le programme utilisé pour ouvrir les liens de courriel

Firefox utilise normalement le programme de messagerie par défaut de votre système d'exploitation pour envoyer un courrier électronique. Cet article décrit comment changer le programme qui s'ouvre quand vous cliquez sur :

  • Envoyer un lien vers la page... à partir du menu Firefox (menu Fichier dans Windows XP)menu Fichier.
  • Envoyer le lien... à partir du menu contextuel clic-droitCtrl+clic de Firefox.
  • Un lien « mailto » ou vers une adresse électronique sur une page web (p. ex. examples@examples.net).
  • Envoyer par courriel un lien vers la page... à partir du menu Firefox (menu Fichier dans Windows XP)menu Fichier.
  • Un lien « mailto » ou vers une adresse électronique sur une page web (p. ex. examples@examples.net).

Définir le client de messagerie de Firefox

  1. En haut de la fenêtre de Firefox, cliquez sur le bouton Firefox, puis sélectionnez OptionsEn haut de la fenêtre de Firefox, cliquez sur le menu Outils, puis sélectionnez OptionsSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Préférences…En haut de la fenêtre de Firefox, cliquez sur le menu Édition, puis sélectionnez Préférences

    Cliquez sur le bouton menu New Fx Menu et sélectionnez OptionsPréférences

  2. Sélectionnez le panneau Applications.
  3. Cherchez le « Type de contenu » : mailto et sélectionnez-le.
  4. Cliquez sur la colonne « Action » dans la ligne mailto, pour changer l'action. changer-client-messagerie.png


    Fx4MacAppPanel-mailto
    • Toujours demander vous avertira à chaque fois que vous utiliserez une fonction de messagerie pour savoir quel programme ou service utiliser.
    • Utiliser <Programme> (par défaut) lancera automatiquement le client de messagerie de votre système d'exploitation (par exemple, Thunderbird, Windows Live Mail, Outlook, Evolution, KMail) vers sa fenêtre de composition de message. Pour savoir comment changer le client de messagerie par défaut de votre système d'exploitation, voir la section suivante de cet article.
    • Utiliser <Webmail> ouvrira la page de composition de message de votre service de messagerie (par exemple, Yahoo! Mail, Gmail) dans Firefox. Pour plus d'information concernant l'utilisation des services de messagerie, voir la section Utiliser les services de messagerie web de cet article.
    • Autre... vous permettra de spécifier un programme externe à lancer par Firefox.
    • Détails de l'application... vous permettra de consulter des informations sur les services de messagerie que Firefox utilise ou de les supprimer.
  5. Cliquez sur OK pour fermer la fenêtre « Options »Cliquez sur Fermer pour fermer la fenêtre « Préférences »Fermez la fenêtre « Préférences »

Définir le client de messagerie par défaut de votre système d'exploitation

Par défaut, Firefox utilise le client de messagerie par défaut de votre système pour envoyer des courriers électroniques pour les actions listées ci-dessus. Pour changer le client de messagerie par défaut que votre système d'exploitation utilise, suivez les instructions ci-dessous :

Windows 7 et Vista

  1. Cliquez sur le bouton « Démarrer », puis sur Programmes par défaut.
  2. Cliquez sur Configurer les programmes par défaut.
  3. Sous Programmes, cliquez sur le client de messagerie que vous souhaitez utiliser (par exemple, Thunderbird, Windows Live Mail, Outlook).
  4. Cliquez sur Définir ce programme comme programme par défaut.
  5. Cliquez sur OK en bas de la fenêtre.

Windows XP

  1. Cliquez sur le bouton « Démarrer », puis sur l'icône « Panneau de configuration » pour ouvrir le panneau de configuration Windows.
  2. Cliquez sur l'icône Ajouter ou supprimer des programmes pour ouvrir l'applet « Ajouter ou supprimer des programmes ».
  3. Sur le côté gauche de la fenêtre, cliquez sur l'icône Configurer les programmes par défaut.
  4. Dans la fenêtre qui s'ouvre, cliquez sur le bouton radio Personnalisée pour développer la catégorie Personnalisation.
  5. Sous Choisir un programme de messagerie par défaut, cliquez sur le bouton radio à côté du programme que vous souhaitez utiliser (par exemple, Thunderbird, Windows Live Mail, Outlook).
  6. Cliquez sur OK en bas de la fenêtre.
  1. Ouvrez l'application Courrier dans le dossier d'applications.
  2. Cliquez sur le menu Courrier et sélectionnez Préférences.
  3. Cliquez sur le bouton Général.
  4. Sélectionnez un nouveau programme de courrier par défaut (par exemple, Thunderbird, Outlook).
Note : Ces instructions sont pour des distributions courantes de Linux. Votre distribution utilise peut-être une interface différente.

Gnome

Les distributions qui utilisent l'environnement de bureau Gnome par défaut sont Ubuntu, openSUSE, Red Hat Enterprise Linux et d'autres encore.

  1. Ouvrez la fenêtre des « Applications préférées ». Elle s'ouvre en :
    • (Ubuntu) Cliquant sur le menu Système, en sélectionnant Préférences, puis Applications préférées.
    • Cliquant sur le menu Applications, en sélectionnant Préférences du bureau, puis Avancé, puis en sélectionnant Applications préférées.
  2. Sous Lecteur de courrier, utilisez le menu déroulant pour sélectionner une application de courrier (par exemple, Thunderbird, Evolution).
  3. Cliquez sur Fermer pour fermer la fenêtre des « Applications préférées ».

KDE

Les distributions qui utilisent l'environnement de bureau K par défaut sont Kubuntu, Mandriva Linux, PCLinuxOS et d'autres encore.

  1. Ouvrez le centre de contrôle KDE en cliquant sur K puis en sélectionnant Centre de contrôle.
  2. Dans la fenêtre Centre de contrôle, cliquez pour développer Composants KDE.
  3. Cliquez pour sélectionner Sélecteur de composants.
  4. Cliquez pour sélectionner Courrier de client.
  5. Cliquez pour sélectionner le bouton radio Utiliser un courrier de client différent.
  6. Saisissez le chemin entier de votre courrier de client (par exemple, /usr/bin/thunderbird).
  7. Cliquez sur Appliquer pour fermer la fenêtre du centre de contrôle et pour sauvegarder les modifications.

Utiliser les services de messagerie web

Firefox autorise les services de messagerie web (tels que Gmail, Yahoo! Mail, etc.) pour vous permettre de les utiliser pour les fonctions de messagerie de Firefox. Utilisez les instructions dans la section Définir le client de messagerie de Firefox ci-dessus pour utiliser un service de messagerie web avec cette méthode.

Si le service de messagerie web que vous souhaitez utiliser n'est pas disponible dans le panneau « Applications » de la fenêtre « OptionsPréférences », vous pouvez utiliser une extension pour ajouter une prise en charge de vos services de messagerie web :




Basé sur des informations de Default mail client (mozillaZine KB), Default mail client (mozillaZine KB), Change the default e-mail program (Microsoft.com Support), How to change the default web browser or email application (Apple.com Support), The KDE Control Center (KDE.org) et Select Preferred Applications in Ubuntu (DebianAdmin.com).



Partager cet article : http://mzl.la/LhUKxb

Cet article vous a-t-il été utile ?

Veuillez patienter…

Ces formidables personnes ont aidé à écrire cet article : scoobidiver, nicodel. Vous pouvez également aider - découvrez comment.
Obtenir de l'aide pour une autre plateforme :
Personnaliser cet article

Firefox