Les changements des barres d’outils et tailles de fenêtres ne sont pas enregistrés

Dans certains cas, les modifications apportées aux paramètres de vos barres d'outils ou à votre configuration peuvent ne pas être retenues par Firefox.

Cet article explique comment résoudre le problème sous-jacent qui peut résulter d' un ou plusieurs des comportements suivants :

  • Vous avez ajouté, réarrangé ou supprimé des boutons de votre barre d'outils, mais les changements ne sont pas enregistrés quand vous redémarrez Firefox.
  • Vous avez redimensionné ou déplacé la fenêtre de votre navigateur, mais la nouvelle taille et la position ne sont pas mémorisées quand vous redémarrez Firefox.
  • Vous ne pouvez pas enregistrer les nouveaux marque-pages.

Voici deux façons pour résoudre le problème :

Solution 1 : supprimer le fichier xulstore.json

Vous pouvez avoir un fichier xulstore.json corrompu dans votre profil Firefox. Vous pouvez supprimer ce fichier afin que Firefox en crée un nouveau.

  1. En haut de la fenêtre Firefox, cliquez sur le bouton Firefox, allez sur le menu AideSur la barre de menus, cliquez sur le menu AideEn haut de la fenêtre Firefox, cliquez sur le menu Aide, puis sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.Cliquez sur le bouton menu New Fx Menu , puis cliquez sur le bouton Aide Help-29 et sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.

  2. Sous la section Paramètres de base de l'application, cliquez sur le bouton Ouvrir le dossier correspondantAfficher dans le FinderOuvrir le dossier correspondant. Une fenêtre avec vos fichiersvotre dossier de profil s'ouvre.
  3. Note : si vous n'arrivez pas à ouvrir ou utiliser Firefox, suivez les instructions dans Trouver votre profil sans ouvrir Firefox.
  4. Fermez Firefox :

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  5. Recherchez et supprimez le fichier xulstore.json (ou renommez-le, par exemple, en xulstore.jsonOLD, pour garder l'ancien fichier comme sauvegarde).
  6. Vous pouvez fermer le dossier du profil et ouvrir Firefox maintenant.

Solution 2 : réinitialiser Firefox

La fonctionnalité de réinitialisation de Firefox va remettre à zéro les préférences de la barre d'outils et supprimer les modules complémentaires qui pourraient interférer.

Note : lors de la procédure de réparation, vos marque-pages, historique de navigation, onglets ouverts, fenêtres, mots de passe, cookies et informations auto-complétées de formulaires web sont sauvegardés. Cependant, les extensions et thèmes que vous avez installés seront supprimés et vos préférences seront réinitialisées.lors de la procédure de réinitialisation, vos marque-pages, historique de navigation, onglets ouverts, fenêtres, mots de passe, cookies et informations auto-complétées de formulaires web sont sauvegardés. Cependant, les extensions et thèmes que vous avez installés seront supprimés et vos préférences seront réinitialisées. lors de la procédure de réinitialisation, vos marque-pages, historique de navigation, mots de passe, cookies et informations auto-complétées de formulaires web sont sauvegardés. Cependant, les extensions et thèmes seront supprimés ; les fenêtres, onglets et groupes d'onglets ouverts ne seront pas sauvegardés et vos préférences seront réintialisées. En savoir plus….
  1. Cliquez directement sur ce bouton Rafraîchir Firefox, si vous voyez cette page dans Firefox.
    Ceci ne fonctionnera pas si vous utilisez un autre navigateur ou un appareil mobile.
    • Vous pouvez également trouver un bouton Réparer Firefox en haut à droite de la fenêtre about:support intitulée Informations de dépannage
  2. Pour continuer, cliquez sur Réparer Firefox dans la fenêtre de confirmation qui s'ouvre.
  3. Firefox se ferme alors et se réinitialise. Une fois l'opération terminée, une fenêtre s'affiche, listant les données importées. Cliquez sur Terminer pour que Firefox se rouvre.

Note : il existe aussi un bouton Réparer Firefox dans la fenêtre du mode sans échec, si vous ne parvenez pas à démarrer Firefox normalement. S'il vous est impossible de trouver le bouton Réparer Firefox dans votre version du navigateur, vous pouvez aussi pratiquer une réinitialisation manuelle en créant un nouveau profil. L'article Utiliser le gestionnaire de profils pour créer et supprimer les profils de Firefox vous indique comment faire.

Cet article vous a-t-il été utile ? Veuillez patienter…

Ces formidables personnes ont aidé à écrire cet article : Goofy_BZ, scoobidiver, Mozinet, irahal, J2m06, Konanoob. Vous pouvez également aider - découvrez comment.