Les changements des barres d’outils et tailles de fenêtres ne sont pas enregistrés | Résolution de problèmes

Les changements des barres d’outils et tailles de fenêtres ne sont pas enregistrés

Dans certains cas, les modifications apportées aux paramètres de vos barres d'outils ou à votre configuration peuvent ne pas être retenues par Firefox.

Cet article explique comment résoudre le problème sous-jacent qui peut résulter d' un ou plusieurs des comportements suivants :

  • Vous avez ajouté, réarrangé ou supprimé des boutons de votre barre d'outils, mais les changements ne sont pas enregistrés quand vous redémarrez Firefox.
  • Vous avez redimensionné ou déplacé la fenêtre de votre navigateur, mais la nouvelle taille et la position ne sont pas mémorisées quand vous redémarrez Firefox.
  • Vous ne pouvez pas enregistrer les nouveaux marque-pages.

Voici deux façons pour résoudre le problème :

Solution 1 : supprimer le fichier xulstore.json

Vous pouvez avoir un fichier xulstore.json corrompu dans votre profil Firefox. Vous pouvez supprimer ce fichier afin que Firefox en crée un nouveau.

  1. En haut de la fenêtre Firefox, cliquez sur le bouton Firefox, allez sur le menu AideSur la barre de menus, cliquez sur le menu AideEn haut de la fenêtre Firefox, cliquez sur le menu Aide, puis sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.Cliquez sur le bouton menu New Fx Menu , puis cliquez sur le bouton Aide Help-29 et sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.

  2. Sous la section Paramètres de base de l'application, cliquez sur le bouton Ouvrir le dossier correspondantAfficher dans le FinderOuvrir le dossier correspondant. Une fenêtre avec vos fichiersvotre dossier de profil s'ouvre.
  3. Note : si vous n'arrivez pas à ouvrir ou utiliser Firefox, suivez les instructions dans Trouver votre profil sans ouvrir Firefox.
  4. Fermez Firefox :

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  5. Recherchez et supprimez le fichier xulstore.json (ou renommez-le, par exemple, en xulstore.jsonOLD, pour garder l'ancien fichier comme sauvegarde).
  6. Vous pouvez fermer le dossier du profil et ouvrir Firefox maintenant.

Solution 2 : réinitialiser Firefox

La fonctionnalité de réinitialisation de Firefox va remettre à zéro les préférences de la barre d'outils et supprimer les modules complémentaires qui pourraient interférer.

Note : lors de la procédure de réparation, vos marque-pages, historique de navigation, onglets ouverts, fenêtres, mots de passe, cookies et informations auto-complétées de formulaires web sont sauvegardés. Cependant, les extensions et thèmes que vous avez installés seront supprimés et vos préférences seront réinitialisées.lors de la procédure de réinitialisation, vos marque-pages, historique de navigation, onglets ouverts, fenêtres, mots de passe, cookies et informations auto-complétées de formulaires web sont sauvegardés. Cependant, les extensions et thèmes que vous avez installés seront supprimés et vos préférences seront réinitialisées. lors de la procédure de réinitialisation, vos marque-pages, historique de navigation, mots de passe, cookies et informations auto-complétées de formulaires web sont sauvegardés. Cependant, les extensions et thèmes seront supprimés ; les fenêtres, onglets et groupes d'onglets ouverts ne seront pas sauvegardés et vos préférences seront réintialisées. En savoir plus….
  1. En haut de la fenêtre de Firefox, cliquez sur le menu ?Aide, puis sélectionnez Informations de dépannage.En haut de la fenêtre de Firefox, cliquez sur le bouton Firefox, allez sur le sous-menu Aide et sélectionnez Informations de dépannage.Sur la barre de menus, cliquez sur le menu Aide et sélectionnez Informations de dépannage.
    fx26-infos-dépannage-winxp fx26-Win7-Infos-Dépannage Troubleshooting info - mac Troubleshooting info - lin
    S'il vous est impossible d'accéder au menu Aide, saisissez about:support dans votre barre d'adresse pour faire apparaître la page des Informations de dépannage.
  2. Cliquez sur le bouton Réinitialiser Firefox en haut à droite de la page « Informations de dépannage ».
    winxp-fx26-reinitialiser-fx reinitialiser_firefox_win7 Reset Firefox - Mac - 1 Reset Firefox - Lin - 1
  3. Pour poursuivre, cliquez sur Réinitialiser Firefox dans la fenêtre de confirmation qui s'ouvre.Pour poursuivre, cliquez sur Réinitialiser Firefox dans la feuille de confirmation qui glisse vers le bas.
  4. Firefox se ferme puis se réinitialise. Une fois l'opération terminée, un fenêtre s'affiche, listant les données importées. Cliquez Terminer ; Firefox se rouvre.
  1. Cliquez sur le bouton de menu New Fx Menu puis cliquez sur le bouton Aide Help-29 en bas du menu.
  2. Dans le menu Aide, sélectionnez Informations de dépannage
    S'il vous est impossible d'accéder au menu Aide, saisissez about:support dans votre barre d'adresse pour faire apparaître la page des Informations de dépannage.
  3. Dans la page Informations de dépannage, cliquez sur le bouton Réinitialiser Firefox en haut à droite
    Reset 29 Win Reset 29 Mac Reset 29 Lin
  4. Pour continuer, cliquez sur Réinitialiser Firefox dans la fenêtre de confirmation qui s'ouvre.
  5. Firefox se ferme alors et se réinitialise. Une fois l'opération terminée, une fenêtre s'affiche, listant les données importées. Cliquez sur Terminer pour que Firefox se rouvre.
  1. Cliquez directement sur ce bouton -> Rafraîchir Firefox, si vous parcourez cette page avec Firefox (cela ne marchera pas si vous utilisez un autre navigateur). Vous trouverez aussi un bouton de réparation dans l'angle supérieur droit de la page about:support qui s'intitule Informations de dépannage.
  2. Pour continuer, cliquez sur le bouton Réparer Firefox dans la fenêtre de confirmation qui s'ouvre.
  3. Firefox va se fermer pour être restauré. À ce stade, une fenêtre établira la liste de vos informations importées. Cliquez sur Terminer et Firefox va démarrer.

Note : il existe aussi un bouton Réparer FirefoxRéinitialiser Firefox dans la fenêtre du mode sans échec, si vous ne parvenez pas à démarrer Firefox normalement.

Cet article vous a-t-il été utile ?

Veuillez patienter…

Ces formidables personnes ont aidé à écrire cet article : Goofy_BZ, scoobidiver, Mozinet, irahal, J2m06, Konanoob. Vous pouvez également aider - découvrez comment.

Dernière mise à jour : 2016-04-17

Obtenir de l'aide pour une autre plateforme :
Personnaliser cet article

Firefox