Etsi tuesta

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox ignores font color selections. I want to use a black background with white text. The white text is displayed in some places but not in text boxes. On th

  • 5 vastausta
  • 7 henkilöllä on sama ongelma
  • 15 näyttöä
  • Viimeisin kirjoittaja bfrs

more options

I am visually handicapped. I have set the Firefox preferences so that the background color is black and the text color is white. I un-checked the allow web pages to use their own colors box. When I go to the Google search page the background is black but when I type in the search field the text is also black and I can't read it.

Kaikki vastaukset (5)

more options

Hi cbrew,

There are a few options that may be considered here, so I will give brief details of the ones I am thinking could help.

The OS itself may have options that help, and you may as you have tried select to use chosen settings but these simple solutions are often unsatisfactory.

I note Accessibility features in Firefox - Make Firefox and web content work for all users#w_using-a-high-contrast-theme says:

Using a High Contrast Theme
Firefox automatically detects if you are using a High Contrast theme and displays everything in your high contrast color scheme. This overrides all other other browser or web page settings, and it affects the Firefox interface itself (all menus, windows, and dialog boxes) and the content of any web page you visit. 

That may well be worthwhile trying as an alternative to simply changing font size and colour.

THIS MAYBE THE BEST IDEA
There is a popular add on called No Squint, it takes quite a bit of setting up to work properly but it is very powerful.


Additionally it is possible to change settings that includes the Firefox User Interface, it is fiddly, and will probably only be worthwhile if using No Squint. It involves setting the preference layout.css.devPixelsPerPx


You may also be interested in

Muokattu , muokkaaja John99

more options
more options

I have tried every suggestion but nothing fixes the problem. I downloaded NoSquint and it had no effect. This is a simple problem. All I want to do is make the font color for text white everywhere on a web page. Firefox ignores my selection for text font color in text boxes such as the search box on the Google home page. How can this be fixed? Thanks much.

more options

Try code like this in the userContent.css file below the default @namespace line.

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder.


button, input, select, select > input[type="button"], textarea {
 -moz-appearance: none !important;
 background-color: black !important;
 color: white !important;
}

Muokattu , muokkaaja cor-el

more options

Extrapolating cor-el's answer worked for me. Here's what I did:

Install the firefox Add-on Stylish:

https://addons.mozilla.org/en-US/firefox/addon/stylish/?src=external-userstyleshome

Goto Stylish's companion website:

http://userstyles.org/

Search for Google on userstyles.org and install the following theme:

Black Google 2012 by Panos

http://userstyles.org/styles/61377/black-google-2012-by-panos

Once you install Stylish its easy to install Stylish themes from userstyles.org

My main problem was with the Google Search box, with nothing visible (black text color on black background)

To add more sites where you want this "Black Google" theme to work, go to firefox's Add-on manager (Ctrl + Shift + A), and click Edit next to this theme. You'll find a list of google sites at the top, just add whatever you want to these.

Muokattu , muokkaaja bfrs