Etsi tuesta

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Trying to download a kmz file from a remote server IE will download the file but Firefox returns computer code. This is a new problem as I have been able to download kmx files before

  • 6 vastausta
  • 9 henkilöllä on sama ongelma
  • 92 näyttöä
  • Viimeisin kirjoittaja howardmathieson

more options

I have uploaded a google earth file to a server. I can download the file with IE and in the past have been able to download Google Earth files with Firefox. This week I doing a test of a web link I tried to download a file and it returns computer code. Is there a security setting I may have changed? Is there an issue with a Firefox update. IT has me stumped.

Here is a link to try: http://geogenealogy.ca/maps/United%20states/Northern%20Pacific%20Railway%201900.kmz

Any help would be greatly appreciated

Howard

I have uploaded a google earth file to a server. I can download the file with IE and in the past have been able to download Google Earth files with Firefox. This week I doing a test of a web link I tried to download a file and it returns computer code. Is there a security setting I may have changed? Is there an issue with a Firefox update. IT has me stumped. Here is a link to try: http://geogenealogy.ca/maps/United%20states/Northern%20Pacific%20Railway%201900.kmz Any help would be greatly appreciated Howard

Muokattu , muokkaaja NoahSUMO

Kaikki vastaukset (6)

more options

http://en.wikipedia.org/wiki/Keyhole_Markup_Language

The only way that file opens thru IE8 for me (but not actually in IE8) is by using the Zip Utility (then IE closes) that is in WinXP and then opening the two image files in the Windows Fax and Picture Viewer.

I think Firefox is trying to display that file because the MIME-type is for text/plain instead of the appropriate MIME-type of application/vnd.google-earth.kml+xml or application/vnd.google-earth.kmz

That is something that needs to be configured in the server that is hosting that file type. Sorry, I don't know how that can be fixed. The one support person here that might know lives in Europe (I believe), so you might need to wait for an answer.

more options

I have looked at the problem again...

I have IE7 and it will prompt me to save or open the file. If I select open, it will download the KMZ file, launch Google Earth, and display the file. Therefore I would conclude there is no problem with the server that hosts the file.

This would lead me to suspect that the problem is with Firefox. I suspect that the latest version is not recognizing it as a kmz file but rather as a text file.

more options

Firefox doesn't go by the file extension, it uses the MIME-type to determine file handling.

https://support.mozilla.com/en-US/kb/Managing%20file%20types#w_download-actions

more options

Hi Edmister...

Thanks for your interest and help.

However why will Internet Explorer download the file normally? Firefox used to be able to download the same file but now it wont. I have tried it on a two different computers and it still returns computer code rather than the KMZ file. This would likely rule out a problem with my computer

more options

If you want to download a file send as text/plain like this one then you need to right-click and use "Save Link as" or press and hold Alt and left-click the link.

It is a ZIP archive, but Firefox doesn't check the content.
It is a problem with configuring the server to send the correct MIME type for each file.

https://developer.mozilla.org/en/docs/Properly_Configuring_Server_MIME_Types

more options

thanks cor-el

The Alt left click works!