Etsi tuesta

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PDFs do not display

more options

PDFs open in the browser, but all pages are black. The content can be selected and copied, but not viewed. The PDF can be downloaded and viewed externally. Any thoughts?

PDFs open in the browser, but all pages are black. The content can be selected and copied, but not viewed. The PDF can be downloaded and viewed externally. Any thoughts?

Valittu ratkaisu

Could you disable Firefox's use of hardware acceleration? This is a diagnostic for an incompatibility between Firefox and your display driver software. You can find the steps in this article: Firefox's performance settings. You might need to Quit/Restart Firefox for that to take effect.

Lue tämä vastaus kontekstissaan 👍 1

Kaikki vastaukset (6)

more options

Link and screens hot? Are we talking about FF cause you gave no specs?

Muokattu , muokkaaja WestEnd

more options

Hi doubledaffy, do you have this issue with all PDFs or are there particular sites where you see this issue? Firefox's built-in PDF viewer is less sophisticated than stand-alone PDF viewers, especially in handling PDFs with heavy graphical content.

However, simple PDFs should be fine. If those don't work, either, could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Thanks for the suggestions. Here's what I figured out:

  • PDFs display properly in safe mode
  • If I manually disable the the Add-ons, PDFs still do not display
  • Local PDFs on my machine display properly in all cases.

Also:

WestEnd said

Link and screens hot? Are we talking about FF cause you gave no specs?

An example link is here, and I attached a screenshot. You can see the thumbnails display as well. The specs are in the Question Details, but it is Firefox 57 on MacOS 10.13.1. What other information would be helpful?

more options

Valittu ratkaisu

Could you disable Firefox's use of hardware acceleration? This is a diagnostic for an incompatibility between Firefox and your display driver software. You can find the steps in this article: Firefox's performance settings. You might need to Quit/Restart Firefox for that to take effect.

more options

That did it. Thanks!

more options

Thanks for reporting back. We usually suggest trying to update, referencing the following article: Upgrade your graphics drivers to use hardware acceleration and WebGL. However, I don't know if that makes sense on Apple systems.