Flash-liitännäinen - Pidä se ajan tasalla ja korjaa sen ongelmia | Ohje

Flash-liitännäinen - Pidä se ajan tasalla ja korjaa sen ongelmia

Adobe Flash Player -selainliitännäisellä voit katsella videoita ja animoitua sisältöä Firefoxissa. Tässä artikkelissa on tietoa Flash Playerin testaamisesta, päivittämisestä, poistamisesta ja ongelmien korjaamisesta.

Huomaa: Firefoxin päivitystoiminto ei päivitä asennettuja liitännäisiä. Katso englanninkieliseltä Adoben tietoturvasivulta lisätietoja Flash Playerin ja muiden Adoben tuotteiden turvallisuus- ja vakausongelmista.

Flashin testaaminen

Vieraile Adoben testisivulla tarkistaaksesi, onko Flash-liitännäinen asennettu ja toimiiko se kunnolla. Jos sivu kertoo, ettei liitännäistä ole asennettu, katso ohjeet artikkelista Avaa videot, animaatiot ja pelit asentamalla Flash-liitännäinen, tai asenna Flash-liitännäinen osan Flashin päivittäminen ohjeilla.

Flashin päivittäminen

Flash-liitännäinen päivittää itsensä oletusarvoisesti automaattisesti. Jos Mozillan Liitännäisten tarkistus ja päivitys -sivu kertoo, että Flash on vanhentunut, etkä halua odottaa automaattista päivitystä, voit päivittää Flashin käsin lataamalla ja asentamalla viimeisimmän version Adobelta.

Tarkista, onko Flash-asennuksesi ajan tasalla käymällä Mozillan Liitännäisten tarkistus ja päivitys -sivulla. Jos sivu kertoo, että Flash on vanhentunut, voit päivittää Flashin käsin lataamalla ja asentamalla viimeisimmän version Adobelta.

  1. Mene Flash Playerin lataussivulle Adobe.comissa ja lataa Flashin asennusohjelma.
    Varoitus: Adoben lataussivu saattaa sisältää valintalaatikon, jolla valitaan asennuksen yhteydessä asennettavat lisäohjelmat (kuten Google Chrome tai McAfee Security Scan). Ellet poista valintaa ennen latausta, nämä ohjelmat asennetaan tietokoneellesi Flashin asennuksen päätyttyä.
  2. Kun lataus on valmis, sulje Firefox:

    Paina Firefox-ikkunan ylälaidasta Firefox-painiketta ja napsauta LopetaValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse LopetaValitse valikkopalkista Firefox-valikko ja napsauta Lopeta FirefoxValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse Lopeta

    Napsauta valikkopainiketta New Fx Menu ja napsauta sitten LopetaLopeta Close 29

  3. Avaa lataamasi Flash-asennusohjelma ja seuraa ohjeita.
Huomaa: Jos Flash-asennusohjelman kanssa on ongelmia, voit ladata täyden Flash-asennusohjelman suoraan Adobe.comista.
  1. Siirry Flash Player -lataussivulle Adobe.comissa ja lataa Flash-asennusohjelma.
  2. Paina Firefox-ikkunan ylälaidasta Firefox-painiketta ja napsauta LopetaValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse LopetaValitse valikkopalkista Firefox-valikko ja napsauta Lopeta FirefoxValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse Lopeta

    Napsauta valikkopainiketta New Fx Menu ja napsauta sitten LopetaLopeta Close 29

  3. Avaa lataamasi tiedosto (install_flash_player_osx_intel.dmg).
  4. Suorita asennusohjelma avaamalla Finderissa Install Adobe Flash Player.app ja seuraa sen ohjeita.
  1. Siirry Flash Player -lataussivulle Adobe.comissa.
  2. Kun ilmoitus aukeaa, tallenna tiedosto (i.e. install_flash_player_"versio"_linux."prosessori".tar.gz).
  3. Paina Firefox-ikkunan ylälaidasta Firefox-painiketta ja napsauta LopetaValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse LopetaValitse valikkopalkista Firefox-valikko ja napsauta Lopeta FirefoxValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse Lopeta

    Napsauta valikkopainiketta New Fx Menu ja napsauta sitten LopetaLopeta Close 29

  4. Avaa Pääte-ikkuna (Terminal) (napsauta Gnomessa Sovellukset (Applications) -valikkoa, valitse Apuohjelmat (Accessories) ja valitse sitten Pääte (Terminal).)
  5. Siirry Pääte-ikkunassa hakemistoon, johon latasit tiedoston (esim. cd /home/user/Downloads).
  6. Pura libflashplayer.so lataamastasi tiedostosta komennolla tar -zxvf install_flash_player_"versio"_linux."prosessori".tar.gz.
  7. Vaihda pääkäyttäjäksi (super user), kopioi purettu tiedosto, libflashplayer.so, Firefoxin asennushakemistossa alikansioon plugins. Jos Firefox on esimerkiksi asennettu hakemistoon /usr/lib/mozilla, käytä komentoa sudo cp libflashplayer.so /usr/lib/mozilla/plugins ja anna pääkäyttäjän salasana kysyttäessä.

    0a85171f1802a3b0d9f46ffb997ddc02-1260326970-447-1.png

Flashin asennuksen poistaminen

Lue englanninkielisestä artikkelista Uninstall Flash Player - WindowsUninstall Flash Player - Mac OS Adobe.comissa ohjeita Flashin poistamiseksi.

Huomaa: Adoben poisto-ohjelman suorittaminen poistaa Flashin kaikista selaimista, joissa se ei ole sisäänrakennettuna, kuten Internet Explorerista. Sinulle ehdotetaan Flashin asentamista uudelleen, kun vierailet sivulla joka vaatii sen, kuten Adoben testisivulla.

Ongelmien korjaaminen

Flash-liitännäinen ei toimi

Jos Adoben testisivu ei ilmoita Flashin olevan asennettu, vaikka uusin versio on asennettu, Flash-liitännäinen saattaa olla pois käytöstä. Varmista seuraavilla ohjeilla, että Flash on käytössä:

  1. Valitse Firefox-ikkunan ylälaidasta Firefox-painikeValitse valikkopalkista TyökalutValitse Firefoxin valikkopalkista Työkalut, ja napsauta sitten valikkoa Lisäosat. Lisäosien hallinta -välilehti aukeaa.

    Napsauta valikkopainiketta New Fx Menu ja valitse Lisäosat. Lisäosien hallinta -välilehti avautuu.

  2. Valitse Lisäosien hallinta -välilehdellä Liitännäiset -paneeli.

Jos Flash-liitännäinen on poistettu käytöstä, napsauta Ota käyttöön.

Jos Flash-liitännäinen on poistettu käytöstä, valitse Käynnistä aina sen kohdalla olevasta alasvetovalikosta.

Flash toimii Internet Explorerissa tai Chromessa, mutta ei Firefoxissa

Flash Playereitä on kolme erilaista: ActiveX-versio Internet Explorerille, Chrome-selaimen sisäänrakennettu versio ja liitännäisversio Firefoxille ja joillekin muille selaimille. Jos Flashin halutaan toimivan Firefoxissa, on asennettava liitännäisversio yllä olevilla ohjeilla.

Adoben Flash -liitännäinen kaatui

Jos näet tämän ilmoituksen Flash-sisällön sijasta, katso lisätietoja artikkelista Liitännäinen Adobe Flash kaatui - Estä sen tapahtuminen uudelleen.

Liitännäinen ei vastaa

Firefox näyttää varoitusikkunan, jos Flash-liitännäisen käynnistyminen kestää odotettua kauemmin:

warning-unresponsive-plugin

Katso toimintaohjeita ja ratkaisuja artikkelista Warning Unresponsive plugin - What it means and how to fix it.

Flash-videoiden kokoruutukatselu ei onnistu

Katso ohjeet artikkelista Flash videos won't play full screen.

Flash-videoiden toistaminen jumittaa Firefoxin

Jos Firefox lopetaa vastaamasta kutsuihin, tai jos Flash-liitännäinen jumittaa tai lakkaa toimimasta, kun toistat Flash-videoita tai pelejä, yritä näitä toimenpiteitä:

  • Keskeytä tai lopeta muissa välilehdissä käynnissä olevat Flash-videot tai pelit. Joudut mahdollisesti sulkemaan nämä välilehdet.
  • Päivitä Flash. Katso ohjeet tämän artikkelin osasta Flashin päivittäminen.
  • Estä Flashin laitteistokiihdytys:
    1. Mene sivulle Adobe Flash Player Help page.
    2. Napsauta hiiren kakkospainikkeellaPidä Ctrl pohjassa ja napsauta sivulla olevaa Flash Player -logoa, ja valitse sitten ponnahdusvalikosta Settings.... Adobe Flash Player Settings -ruutu aukeaa.
    3. Napsauta Adobe Flash Player Settings -ikkunan vasemmassa alalaidassa olevaa kuvaketta, jolloin Display-paneeli aukeaa.
    4. Poista valinta Enable hardware acceleration -valintaruudusta.

      fpSettings1.PNG
    5. Sulje Adobe Flash Player Settings -ikkuna napsauttamalla Close-painiketta.
    6. Käynnistä Firefox uudelleen.
  • Päivitä grafiikka-ohjaimesi. Katso ohjeet artikkelista Upgrade your graphics drivers to use hardware acceleration and WebGL.
  1. Kirjoita osoitepalkkiin about:config ja paina Enteriä.

    • About:config-sivun varoitus "Tämä sivu on ladattu ja vaarallinen!" voi avautua. Napsauta Lupaan olla varovainen ja varsinainen about:config-sivu aukeaa.
  2. Etsi ominaisuus dom.ipc.plugins.flash.disable-protected-mode luettelosta.
  3. Kaksoisnapsauta ominaisuutta, jolloin sen arvoksi vaihtuu true.
  4. Sulje Firefox:

    Paina Firefox-ikkunan ylälaidasta Firefox-painiketta ja napsauta LopetaValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse LopetaValitse valikkopalkista Firefox-valikko ja napsauta Lopeta FirefoxValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse Lopeta

    Napsauta valikkopainiketta New Fx Menu ja napsauta sitten LopetaLopeta Close 29

  5. Käynnistä Firefox uudelleen.
Huomaa: Voit ottaa Flashin suojatun tilan (Protected Mode) uudelleen käyttöön toista edelliset vaiheet niin, että ominaisuuden dom.ipc.plugins.flash.disable-protected-mode arvoksi vaihtuu false.

Flash ei toimi kunnolla tai Flash ei päivity

Jos Flash-sisältö ei toimi, käyttäytyy oudosti tai aiheuttaa ongelmia, tai jos näet päivityspyyntöjä (esimerkiksi Mozillan liitännäisten tarkistussivulla) vielä uusimman version asentamisen jälkeenkin, poista Flash ja asenna se uudelleen.




Perustuu mozillaZinen informaatioon Flash (mozillaZine KB)


Share this article: <a href="http://mzl.la/1BAQTH9">http://mzl.la/1BAQTH9</a>

Oliko tästä artikkelista apua?

Odota hetki...

Nämä mahtavat henkilöt auttoivat kirjoittamaan tämän artikkelin: funky, AnonymousUser, jjuslin. Sinäkin voit auttaa - lue lisää.
Hae tukea toisella alustalla:
Muokkaa tätä artikkelia

Firefox