Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't get Firefox to not remember my browsing history.

  • 2 پاسخ
  • 4 have this problem
  • 1 view
  • آخرین پاسخ توسّط cor-el

more options

My Firefox browser settings (under tools and options) are that it should never remember my browsing history.

Nevertheless, every time I open Firefox (even after the browser has been closed and the computer shut down) and open a new tab, there is a grid of tiles showing sites that I have previously visited. Also, if I click on history I can see my browsing history.

If I go to options and clear history, these things disappear. But after a period of browsing, they are back, even with the setting "never remember history."

How can I get Firefox to respect this setting and not remember my browsing history?

(I have tried creating a new profile, but this hasn't changed anything.)

Thanks for any advice, Matthew

Chosen solution

You can set another page as the new tab page by modifying the browser.newtab.url pref om the about:config page.

See this article about the New Tab page (about:newtab):

Do you have any software installed on your computer like Advanced SystemCare that might be causing this?

Read this answer in context 👍 1

All Replies (2)

more options

Hello there!

Please show a screenshot of that settings. :)

more options

Chosen Solution

You can set another page as the new tab page by modifying the browser.newtab.url pref om the about:config page.

See this article about the New Tab page (about:newtab):

Do you have any software installed on your computer like Advanced SystemCare that might be causing this?