X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I change the displayed language, eg at the top of my page, my File option is now spelt Bestand, Edit is Bewerken etc I would like to change it back to English

Posted

I have tried changing the language using the Extra (Tools) option but that has not worked. Also I cannot read what the options are.

This happened

Every time Firefox opened

== A week ago

Chosen solution

Hello Tony.

You need to download the version you want (see this this page for all systems and languages), uninstall the one you have (no data will be lost) and install the version you just downloaded. You can choose to not uninstall your current version and just install the new version in a different location, but that may create a mess for unexperienced users.

Read this answer in context 15

Additional System Details

Installed Plug-ins

  • -getplusplusadobe16248
  • np-mswmp
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • Java(TM) Platform SE binary
  • My Web Search Plugin Stub for 32-bit Windows
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.0 r42
  • iTunes Detector Plug-in
  • 4.0.50524.0
  • Office Live Update v1.3
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Java Plug-in 1.6.0_10 for Netscape Navigator (DLL Helper)
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 (.NET CLR 3.5.30729)

More Information

Trouble shooting has not helped

Morbus 134 solutions 2338 answers

Chosen Solution

Hello Tony.

You need to download the version you want (see this this page for all systems and languages), uninstall the one you have (no data will be lost) and install the version you just downloaded. You can choose to not uninstall your current version and just install the new version in a different location, but that may create a mess for unexperienced users.

Question owner

please change the display in english

Morbus 134 solutions 2338 answers

Helpful Reply

You need to download the version you want (see this this page for all systems and languages), uninstall the one you have (no data will be lost) and install the version you just downloaded. You can choose to not uninstall your current version and just install the new version in a different location, but that may create a mess for unexperienced users.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96632 answers

Make sure that when you uninstall that Dutch (nl) version that you do not remove your personal data (profile folder). Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.2.6)


You may need to (re)set the pref "general.useragent.locale" to the preferred language (e.g. "en-US" or "en-GB") on the about:config page. You can open the about:config page via the location bar, like you open a web site. Use the Filter bar at the top of that page to quickly locate the pref.

chemchor 0 solutions 1 answers

Yesterday, 5 August 2010, my Firefox display suddenly was in what appears to be Dutch. It was not Deutsch. When I opened Google News it also changed to Dutch. I shut off the computer and restarted it. Microsoft was in English, but Firefox was in Dutch. I had Norton do a quick scan and it reported nothing. I looked in the Firefox help section and found this thread. Then I went back and looked through the possible items on the top bar. Under 'View' I found that 'Bork Text' had been checked. I am still uncertain what that means, but I don't believe it had been checked previously. I removed the check mark and the display text went back to English. Does anyone have an explanation?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96632 answers

Looks that you have installed an extension that made the language switch.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

eMixt 0 solutions 3 answers

After spending few hours and testing how to change the language of my Firefox 3.6.8 from Chinese to en-US (English), I come across this only option so far (the about:config trick didn't work for me).

1. Unistall your previous Firefox browser instalation. 2. Go to: Control Panel -> Region and Language -> Change Location -> (set) United States. 3. Find a good proxy or VPN with USA IP. 4. Go to: http://www.mozilla.com/en-US/firefox/all.html and download your desired Firefox with your desired language (I chose: http://www.mozilla.com/products/download.html?product=firefox-3.6.8&os=win&lang=en-US). 5. Download it and install it.

Done!

Note: As far as I understand the Firefox will look about your OS language (mine is the English version), your OS keyboard languages (mine set for US and chinese), OS Control Panel Location (mine was set to USA), and your location at the moment when you execute the download for the Firefox browser app (mine was China but at that time I used a VPN which confirmed my location as USA).

Regards,

eMixt www.emixt.com

andymoz 0 solutions 1 answers

This was easy to fix. Using a bit of lateral thinking, I disabled Tor by clicking on "Tor Enabled", then closed and reopened Mozilla... Fixed!

This will only work if you use the Tor network. If you don't, then this might suggest a fix to the boffins at Mozilla

I suspected that my Mozilla was connecting via a Tor network user in another country and was detecting their language.

Andy

cmullinsjr 0 solutions 4 answers

I need to review web pages in many different languages. From the solution you proposed, I would need to install a different version of Firefox for each language. Is that correct? Is there no feature as in IE where you can change the user interface language and/or locale?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96632 answers

You can install additional language pack for other languages than en-US.

See http://kb.mozillazine.org/Language_packs

nigeld 0 solutions 1 answers

I have what I think may be a related problem. I have made my home page using google.uk and Firefox. Everything is displayed in English. If I use the main page Google search, everything appears in English but if I use the small Google search in the browser bar, everything comes back in Dutch and if I go to bookmarks/search engines/google the Dutch home page comes up. I should add that I am connected through a Belgian VPN server. How do I re-set to English please?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96632 answers

Some sites automatically redirect you to a site in the local language, based on where your IP locates you.

If the Google (Firefox) or Yahoo! home page is in the wrong language then see: