Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

link to open in new tab instead of new window

more options

I went to settings and set firefox to open links in a NEW TAB instead of a new window, but it still opens links in a new window. I did a search on google and when I click on the link for the website to see the information it is still opening in a new window. How can I fix this so I don't have a lot of new windows. It's irritating to have to close all those stinking windows just to get back to my original window. I just want the links I click on to open in a new tab.

I went to settings and set firefox to open links in a NEW TAB instead of a new window, but it still opens links in a new window. I did a search on google and when I click on the link for the website to see the information it is still opening in a new window. How can I fix this so I don't have a lot of new windows. It's irritating to have to close all those stinking windows just to get back to my original window. I just want the links I click on to open in a new tab.

All Replies (6)

more options

Try downloading Firefox from Mozilla, run it from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

What OS? What desktop? X11 or Wayland?

Helpful?

more options

This built-in setting should work by diverting those new windows to new tabs in the same window instead:

However, one exception would be a restricted popup window -- the kind with the stripped down toolbars. Those can't have additional tabs.

If you can rule out that scenario, I wonder whether an add-on might be coming into play, whether it is specifically related to opening links or is related to isolating sites from one other (using Containers, for example).

To rule out add-ons, you could test in Firefox's Troubleshoot Mode. You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Any improvement?

Helpful?

more options

I have already done that. In my original write up I mention that i went into settings and marked or clicked on "open links in new tabs instead of new windows". See screen shot. It still opens links in new window. That's why I'm asking for help.

Helpful?

more options

I've toggled that setting and google results open in the same tab. To get the results in another tab I just middle click. The only way for me to get a new window is to right click and select new window. Did you try downloading from Mozilla just to test.

Helpful?

more options

These prefs on the about:config page are related to this new window feature.

Normal Links:

  • browser.link.open_newwindow
    1:current tab; 2:new window; 3:new tab;

JavaScript Links:

  • browser.link.open_newwindow.restriction
    0:divert always; 1:divert never; 2:divert no features

Helpful?

more options

beachcomber.paradise said

I have already done that. In my original write up I mention that i went into settings and marked or clicked on "open links in new tabs instead of new windows". See screen shot. It still opens links in new window. That's why I'm asking for help.

Sorry if the way I embedded the image blocked my suggestions that followed:

jscher2000 - Support Volunteer said

This built-in setting should work by diverting those new windows to new tabs in the same window instead: ... However, one exception would be a restricted popup window -- the kind with the stripped down toolbars. Those can't have additional tabs. If you can rule out that scenario, I wonder whether an add-on might be coming into play, whether it is specifically related to opening links or is related to isolating sites from one other (using Containers, for example). To rule out add-ons, you could test in Firefox's Troubleshoot Mode. You can restart Firefox in Safe/Troubleshoot Mode using either:
  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button). Any improvement?

Helpful?

یک سؤال بپرسید

شما باید برای پاسخ به پست‌ها وارد حسابتان شوید. اگر هنوز حسابی ندارید، لطفاً یک سؤال جدید آغاز کنید.