Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF suddenly auto downloads to download folder. How to stop it?

  • 4 پاسخ
  • 4 have this problem
  • 45 views
  • آخرین پاسخ توسّط cor-el

more options

For over a decade I've used FF, and when I download things (99% of the time from Yahoo) I set FF to "always ask" what to do with downloads. Suddenly that changed and it started downloading everything automatically to the Download Folder.

I went to options and changed everything back to "always ask."

FF does always ask... but... it ALSO still auto downloads to the Downloads Folder now.

And I can't figure out how to stop that.

Any help is appreciated.

For over a decade I've used FF, and when I download things (99% of the time from Yahoo) I set FF to "always ask" what to do with downloads. Suddenly that changed and it started downloading everything automatically to the Download Folder. I went to options and changed everything back to "always ask." FF does always ask... but... it ALSO still auto downloads to the Downloads Folder now. And I can't figure out how to stop that. Any help is appreciated.
Attached screenshots

All Replies (4)

more options

I'm also encountering this for the past 2-3 weeks and since Firefox was updated to 98.0.2 (64-bit). I'd like to know how I can revert to a previous version otherwise I'm going to have to stop using Firefox until a solution is found. As instructed, I went to Settings->Applications->and have set the pdf application I want to open. In addition, I've set it to ask me first. So, that works.

The issue is that although I'm asked, and I'm able to open the file in the appropriate application—the document 'also' downloads. So, everyday I have to check my Download Folder to delete unnecessary documents that might already be saved in another folder. I need a solution that works.

more options

You cannot stop downloading (unless, evidently, you set pdf to open in Firefox) except temporarily.

https://www.mozilla.org/firefox/98.0/releasenotes/ https://support.mozilla.org/en-US/questions/1370494

more options

I just started having this problem out of nowhere. It's extremely annoying. Has there been a fix to this? I click to view pdf's on web pages and all the sudden they are just downloading to the download folder. IF I want to save it, I'll pick the destination and I'll rename it what I want. This "feature" doesn't save me any time. It just makes me angry... just like many Firefox updates the last few years.

In Settings I have "Always ask you where to save files" checked AND A"sk whether to open or save files" checked, but so far today everything I've clicked on has downloaded to the download folder. Of the 12 files that YOU forced my machine to download, I would only have kept 1.

How is this helpful to anyone? It literally just takes up space on my machine for NO GOOD REASON!!!!

more options

You can set browser.downloads.start_downloads_in_tmp_dir = true to revert to the previous behavior to use the OS temp folder.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.