Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mute/unmute button in each window tab disappears when there is no sound

  • 5 پاسخ
  • 1 has this problem
  • 606 views
  • آخرین پاسخ توسّط jam.gray

more options

Hi all. For years I have used Firefox browser and utilised the little audio mute/unmute buttons that sit in each tab so I can mute/unmute sound coming from a web page without needing to open that particular window first. Since the last FF update I have found the button only appears when there is sound coming from that webpage. Is there anyway to force the mute/unmute button to be always avaialble?

Hi all. For years I have used Firefox browser and utilised the little audio mute/unmute buttons that sit in each tab so I can mute/unmute sound coming from a web page without needing to open that particular window first. Since the last FF update I have found the button only appears when there is sound coming from that webpage. Is there anyway to force the mute/unmute button to be always avaialble?

Chosen solution

Why is the sound intermittent? If the sound pauses or stops, then I think Firefox will remove the icon after 3 seconds. You could extend that time to 30 seconds and see whether that helps. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste hiding and pause while the list is filtered

(3) Double-click the browser.tabs.delayHidingAudioPlayingIconMS preference to display an editing field, and add a zero so the value changes from 3000 to 30000 then press Enter or click the blue check mark button to save the change.

This value is in milliseconds, so 60000 for 60 seconds, 300000 for 5 minutes, and so on.


I also note that it's possible to use custom style rules in a userChrome.css file to force a mute button on all tabs, but that may be too much clutter. I will note this option here but don't recommend it.

/*** Default sound icon for all tabs not currently playing ***/
.tab-icon-sound:not([soundplaying]):not([muted]) {
  /* Override display: none */
  display: -moz-inline-box !important;
  /* Specify image */
  list-style-image: url(chrome://browser/skin/tabbrowser/tab-audio-playing.svg);
  /* Show 40% gray */
  opacity: 0.4 !important;
}
Read this answer in context 👍 1

All Replies (5)

more options

Hi

As far as I am aware, that icon only appears when needed if there is sound possible from that tab.

more options

Thanks for the reply. The mute/unmute toggle used to remain visible when there is no sound emanating from that webpage but now after updating FF the toggle disappears after a few seconds of no sound. I have multiple tab pages open all with intermittent sound and now I can't control them without going into each page individually which it is not possible for me to do without wrecking my workstream.

Modified by jam.gray

more options

Hi,

Right click on the tab  and you can must or unmute when there is no audio playback from the  tab
more options

Chosen Solution

Why is the sound intermittent? If the sound pauses or stops, then I think Firefox will remove the icon after 3 seconds. You could extend that time to 30 seconds and see whether that helps. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste hiding and pause while the list is filtered

(3) Double-click the browser.tabs.delayHidingAudioPlayingIconMS preference to display an editing field, and add a zero so the value changes from 3000 to 30000 then press Enter or click the blue check mark button to save the change.

This value is in milliseconds, so 60000 for 60 seconds, 300000 for 5 minutes, and so on.


I also note that it's possible to use custom style rules in a userChrome.css file to force a mute button on all tabs, but that may be too much clutter. I will note this option here but don't recommend it.

/*** Default sound icon for all tabs not currently playing ***/
.tab-icon-sound:not([soundplaying]):not([muted]) {
  /* Override display: none */
  display: -moz-inline-box !important;
  /* Specify image */
  list-style-image: url(chrome://browser/skin/tabbrowser/tab-audio-playing.svg);
  /* Show 40% gray */
  opacity: 0.4 !important;
}
more options

Thanks so much Jscher2000, this is exactly what I was looking for. Set it to 3000000 so now I get 50 mins before the icon disappears which is more than enough.

Modified by jam.gray