Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot disable snippets

  • 2 پاسخ
  • 0 have this problem
  • 806 views
  • آخرین پاسخ توسّط mozilla-jcbeck

more options

I've tried Firefox with add-ons disabled.

I've tried disabling Snippets through the UI as well as through about:config.

Regardless of my settings, Snippets appear on new tabs.

Chosen solution

Hi mozilla-jcbeck, just to recap, you mean you have done the following:

Options / Preferences Page

The options for selecting and deselecting content on the built-in home page (which is also the new tab page) can be found on the Options page in the Home panel.

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Home

Then on the right side, you can select/deselect different categories and see what you like best.

Complete the Tour

I will mention something I saw in a different user's thread: If you have a colorful fox icon in the upper left corner of the new tab page, with a blue dot, that indicates you never clicked through the introductory "tour" for this page. The snippets will keep appearing until you click through the tour -- don't worry, it's very brief.

<center></center>

Toggle the Setting(s) Under the Covers

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste snip and pause while the list is filtered

(3) The checkbox flips the browser.newtabpage.activity-stream.feeds.snippets preference to false, you could verify that is still set

(4) Double-click the browser.newtabpage.activity-stream.disableSnippets preference to switch the value from false to true and test whether this makes a difference

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Hi mozilla-jcbeck, just to recap, you mean you have done the following:

Options / Preferences Page

The options for selecting and deselecting content on the built-in home page (which is also the new tab page) can be found on the Options page in the Home panel.

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Home

Then on the right side, you can select/deselect different categories and see what you like best.

Complete the Tour

I will mention something I saw in a different user's thread: If you have a colorful fox icon in the upper left corner of the new tab page, with a blue dot, that indicates you never clicked through the introductory "tour" for this page. The snippets will keep appearing until you click through the tour -- don't worry, it's very brief.

<center></center>

Toggle the Setting(s) Under the Covers

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste snip and pause while the list is filtered

(3) The checkbox flips the browser.newtabpage.activity-stream.feeds.snippets preference to false, you could verify that is still set

(4) Double-click the browser.newtabpage.activity-stream.disableSnippets preference to switch the value from false to true and test whether this makes a difference

Modified by jscher2000

more options

Sorry for the duplicate posts and posting with a comment. The UI on this site is a little clunky ;) I was very unsure how to create an account, and it kept saying Error Generating Preview, or just quietly swallowing my comments. Similar thing happened when I created a new post.

Anyway, you are correct - I had no idea there was that "tour" icon in the top left. Widescreen monitor, my eyes go to the Top Sites icons and never noticed that icon. That solved my issue. Thank you!