Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox hangs after installing RAM

  • 2 پاسخ
  • 1 has this problem
  • 8 views
  • آخرین پاسخ توسّط Lcona

more options

When I open Firefox it loads my "Restore Session" tab, then about 5 sec later it starts hanging / "not responding", whether or not I've attempted to restore my windows. If I'm lucky, this'll go away in a couple of minutes, but if I at all try to open a webpage, it will hang on that page for longer than my patience allows (i.e., I just end up Force Quitting Firefox). The hanging occurs every single time I open Firefox.

I am running Mac OS X 6.8, Model 7,1 Mid-2010, and this problem only started happening immediately after I installed new RAM (2GB -> 8GB).

What I've tried:

  • Restarting my computer
  • Reinstalling Firefox to the latest version (40.0.3)
  • Entering Safe Mode (still crashes)
  • Checked that graphic drivers are up to date (they are)
  • Checked RAM for errors; after running memtest I receive no errors

All other applications have been working fine since the RAM installation.

I know this is probably a difficult problem to solve, especially since I have no Crash Report to offer (since I've been having to Force Quit every time and thus do not receive the dialog). Regardless, if anyone has any information that might solve this, it would be much appreciated — I don't want to switch browsers yet!

When I open Firefox it loads my "Restore Session" tab, then about 5 sec later it starts hanging / "not responding", whether or not I've attempted to restore my windows. If I'm lucky, this'll go away in a couple of minutes, but if I at all try to open a webpage, it will hang on that page for longer than my patience allows (i.e., I just end up Force Quitting Firefox). The hanging occurs every single time I open Firefox. I am running Mac OS X 6.8, Model 7,1 Mid-2010, and this problem only started happening immediately after I installed new RAM (2GB -> 8GB). What I've tried: * Restarting my computer * Reinstalling Firefox to the latest version (40.0.3) * Entering Safe Mode (still crashes) * Checked that graphic drivers are up to date (they are) * Checked RAM for errors; after running memtest I receive no errors All other applications have been working fine since the RAM installation. I know this is probably a difficult problem to solve, especially since I have no Crash Report to offer (since I've been having to Force Quit every time and thus do not receive the dialog). Regardless, if anyone has any information that might solve this, it would be much appreciated — I don't want to switch browsers yet!

All Replies (2)

more options
more options

the-edmeister said

Run Memtest - http://www.memtestosx.org/

Thanks but I already tried that and there were no errors produced.