Old versions of the Flash Player plugin have known vulnerabilities

Our volunteers are working on translating this article. Until it's ready, maybe the English version can be of some help. If you want to help us translate articles like this one, please click here.

Add-ons (extensions, themes, and plugins) that violate Mozilla's add-on guidelines are put on a "blocklist".

What does the blocklist do?

Disables unsafe add-ons

Firefox will block the unsafe add-on from loading and present you with the following message:

Firefox has determined that the following add-ons are known to cause stability or security problems


Add-ons Blocklist Mac1

To prevent these add-ons from running, click Restart Firefox.

Blocks unsafe add-ons from being installed

When you try to install an unsafe add-on that is on the blocklist, Firefox will block the installation and display the message:

The add-on name could not be installed because it has a high risk of causing stability or security problems.

Prevents plugins from running automatically

Firefox can prevent a plugin from running automatically (which prevents many issues). When Firefox blocks a plugin you'll see a message similar to this:

Click to play 1 new

You can then choose to run the plugin or update it (if an update is available). To learn more, see Why do I have to click to activate plugins?

Support ended for all NPAPI plugins except for Flash in Firefox version 52, released March 7, 2017. See this compatibility document and this article for details.

Beginning with Firefox version 52, support has ended for all NPAPI plugins except for Adobe Flash. See this compatibility document and this article for details.

Steps to take

If the installed add-on is disabled

Extension or theme

  1. Click the menu button New Fx Menu and choose Add-ons. The Add-ons Manager tab will open.

  2. In the Add-ons Manager tab, select the Extensions panel.
  3. On the "Tools for all add-ons" Add-on Tools Icon menu, make sure that the Update Add-ons Automatically menu item is checked.

Plugin

Check to see if there's an updated version of your plugin. If there are no plugin updates available, you may need to contact the developer of the plugin that was blocked.

Installation blocked

If you were blocked from installing an add-on, check to see if there is an updated version of the add-on you were trying to install.

Note: If there is not an updated version to install, you may need to contact the developer of the add-on that was blocked.

What unsafe add-ons are on the blocklist?

See the list of blocked add-ons.

These fine people helped write this article: . You can help too - find out how.