X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Master password is not working, is it due to my add-ons- no script, ghostery, flagfox, google yandex, adblock plus, better privacy, WOT?

Posted

Hello Mozilla,

I have included the basic issue in the question above. I use the above add-ons on an up to date firefox browser via an Intell macbook. I also just reset my master password. I have restarted firefox,, logged into an online account to test, logged out... then logged back in again. Upon restarting firefox there was no prompt to enter my master password, nor was there a prompt asking me if I should include the user name and p word in firefox's utilization of the master password. What, in your opinion is going on and how might it be resolved? Of course, I would like to continue using said add-ons.

Chosen solution

If you delete the signons.sqlite and key3.db files and set a new Master Password then this should be working properly, especially in a new profile or with all extensions disabled.

Note that Firefox won't offer to store new passwords when you are in Private Browsing mode.
Sometimes a problem with hardware acceleration can make the save password button via the key icon on the location bar not working.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 11.7 r700
  • 5.1.20125.0
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

finitarry 157 solutions 2178 answers

Helpful Reply

If you try to look up passwords, are you prompted for the master password? That is when that should happen. To see whether the extensions have any effect on the situation, you could start Firefox in safe mode and see if there is any difference.

Question owner

Thank you finitarry for the effort.Turning off all extentions and restarting didn't do it. Starting in safe mode didn't do it either. I have not used firefox master p word in years but I remember that upon starting a browsing session I would be prompted for a master password. If that didn't happen, I would usually be prompted for it when I tried to sign into some online account. If that didn't happen, I would then be prompted for the master p word during a second login attempt. Nothing is happening.

I can go ahead and look for another password manager solution when I am ready. I trust mozilla so I wanted to stick with them. Other than master password not working, should I be concerned? Security is becoming more and more of an issue on the web.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

It is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox.
Rename the key3.db and signons.sqlite files in the Firefox profile folder.
You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action.
You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost.
If that has worked then you can remove the renamed files that are no longer needed.

See:

Question owner

Cor-el, thank you for the suggestion. I went ahead and tried it ("Rename the key3.db and signons.sqlite files in the Firefox profile folder.You can add .old to the file names (key3.db.old and signons.sqlite.old)"). This didn't work either. I then went ahead and reset firefox. Still nothing.

I was hoping for a quick "google search fix" for this issue; that isn't happening. At this point I have just about hit the the limit of how much energy I am willing to invest to fix this. Thanks to you all for trying.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Chosen Solution

If you delete the signons.sqlite and key3.db files and set a new Master Password then this should be working properly, especially in a new profile or with all extensions disabled.

Note that Firefox won't offer to store new passwords when you are in Private Browsing mode.
Sometimes a problem with hardware acceleration can make the save password button via the key icon on the location bar not working.

Question owner

Ok Cor-el, We're cooking now. Instead of renaming by adding .old I deleted signons.sqlite and key3.db and changed the firefox preferences to remember history instead of "never remember history." I have had the understanding that using "never remember history," is a good security practice but I have no idea if this is indeed true. For the sake of privacy and individual liberty, I used "never remember history" to limit the ability to track me. Perhaps you can enlighten me regarding this practice and what it does.

Thanks for you help

finitarry 157 solutions 2178 answers

Helpful Reply

History is not the only way you can be tracked. You can minimize that by clearing history at the end of each browsing session anyway. Third party cookies are used for tracking, DOM storage is used to store information about your system that can be recalled by the site that saved it, just as cookies can. Third party referers can also be used for tracking, as well as ETags in the browser's request headers. Of course, there are also Flash and Silverlight cookies.