Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

filling out FAFSA for college, incompatibe browser detected, downloaded firefox upgrade and it still doesn't work

more options

An Incompatible Browser Has Been Detected Your Web browser is not supported by our Web site. You must use a Compliant Web Browser - Standard* to view our site properly. We recommend you upgrade to the latest version of your browser according to your Operating System.

Browser Requirements to Access this Site (Listed by Operating System).

All Replies (1)

more options

The reason is the site doesn't support FF 8.0 yet. Either use Internet Explorer for the time being, or use this add-on to (temporarily) change the User Agent of the browser.

https://addons.mozilla.org/en-US/firefox/addon/user-agent-switcher/

(The user agent is what the browser tells websites, so they can work out what version you are running)

Ripped from the site;

Supported Microsoft Internet Explorer browsers: Windows XP - Internet Explorer 6.0, 7.0, and 8.0 Windows Vista - Internet Explorer 7.0 and 8.0 Windows 7 - Internet Explorer 8.0

Supported Mozilla Firefox browsers: Windows XP - Mozilla Firefox 3.5.x and 3.6.x Windows Vista - Mozilla Firefox 3.5.x and 3.6.x Windows 7 - Mozilla Firefox 3.5.x and 3.6.x Macintosh Operating System 10.5 - Mozilla Firefox 3.5.x and 3.6.x Macintosh Operating System 10.4 - Mozilla Firefox 3.6