Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

google product-i/google, gmail, etc. will not load on firefox but they do work fine on Chrome--happened overnight--is this a google takeover or hacker??

  • 4 replies
  • 25 have this problem
  • 31 views
  • Last reply by mapyron

more options

i/google was my home page--one morning I opened FF and up comes TEXT--like a default text with html gone. Don't remember if I had downloaded Chrome before or after this. I have also tried youtube and cannot get my account to come up. I created a new gmail account on Chrome and tried to access it on FF, and the loading screen came up but FF couldn't load it--timed out--but load bar had no activity. Anyway, I guess I am just not smart enough to figure it out. Has anyone else reported this "google takeover". I am a loyal FF fan.

Chosen solution

Perform the suggestions mentioned in the last three articles provided in my previous reply.

Read this answer in context 👍 1

All Replies (4)

more options
more options

I tried the first two. Have CCleaner which clears cookies,cache, etc. Also cleared the network suggestion. Read over the other suggestion and will try to do that today. Made Chrome default browser temporarily so no blocks. Then, I had inadvertently downloaded a ASK toolbar--and you know how everyone wants to be DEFAULT so uninstalled that. Am anxious to get back to work on it this pm.

more options

Chosen Solution

Perform the suggestions mentioned in the last three articles provided in my previous reply.

Modified by Hasan

more options

Well, after much stress and anger toward google, I sat down and followed all your suggestions at once. Also, In self defense I downloaded Chrome to see "iGoogle" and set up a google email account. It shows my last iGoogle. Well this is the result. When I put it in safe mode both sites worked and looked right to me. When I took it out of safe mode, the gmail worked but IGoogle would only show a "classic" page (basically blank). I rechecked all google account settings and didn't see anything wrong. So,oooo I will have to rethink what to do, but I REALLY don't like Google anyway. Caught a C-Net article on how they get stuff off Facebook, so I fixed what I could. Course I have the Ghostery addon and can see them tracking everywhere I go anyway....along with tons of other companies. Good luck to you other people who are having trouble with Google!!!!! Have thought of using private browsing all the time, but I use my history so much... mha007 Thank you