Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Impossible to install Firefox, error: VCRUNTIME140_1.dll

  • 3 replies
  • 1 has this problem
  • Last reply by mrmister23

more options

Hi, I can't install Firefox and I don't know what's going on here.

Yesterday I installed the latest version of Firefox and it worked fine. Then, I turned off the laptop and the next day when I was going to use Firefox, it didn't load any pages. Edge was working fine, Chrome was working fine, but Firefox was not working. Trying to fix the problem, I decided to uninstall Firefox and installing it again. In order to clean even more the previous installation, I even manually deleted the C:\Program Files\Mozilla Firefox folder to remove all possible traces. I restarted the laptop and downloaded again the Firefox installer. I don't know how, but the installer detected that I had already installed Firefox before. I unchecked restart Firefox and hit the button to continue with the installation. After this, was impossible to install Firefox again. I got a message saying that the installation cannot continue because the VCRUNTIME140_1.dll was not found. The message said that this problem can be fixed by reinstalling the program, but that is not true, everytime I try to reinstall it, I get again the VCRUNTIME140_1.dll error.

After this, the installation stops and the Firefox icon appears on the desktop, but it doesn't install properly the software and when I open it, I cannot browse the Internet.

Do you know what's going on here and how to solve this?


All Replies (3)

more options

Chosen Solution


more options

Hello, I have exactly the same problem. Exactly the same and also with a laptop, in my case a brand new Dell Inspiron 16.

It seems to be that it is necessary to install again the Visual C++ Redistributable package of the 64 bits, exactly this file: vc_redist.x64.exe

I would rather prefer to download this package from the Microsoft website, however, how may I know the version of the Visual C++ Redistributable package beloning to this file vc_redist.x64.exe?

Do this file (vc_redist.x64.exe) belong to the Visual Studio 2015, 2017, 2019, and 2022?

In the link suggested as a solution, I think it is posted to download the version 16:

However, the latest version available from the Microsoft website is:

Should I download the version 16 or 17? (I guess I should download the latest version)

Also, should I download and install the x86 (32 bits version) and the 64 bits version? My Windows 11 runs in 64 bits.



more options
      • PROBLEM SOLVED ***

I have installed the Visual Studio 2015, 2017, 2019, and 2022 redistributable package, exactly the file: vc_redist.x64.exe (in the 64 bits version, because my Windows 11 runs in 64 bits) and it solved the problem. Firefox installed perfectly, I get rid off the problem VCRUNTIME140_1.dll and everything is fine.

jonzn4SUSE, you pointed me towards the right thread and I have solved the problem thanks to your help.

Thank you!


Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.