Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I change the footer date format to my Windows format

  • 2 replies
  • 1 has this problem
  • 6 views
  • Last reply by colladon

more options

I live in Switzerland. My preferred languages as set in Firefox preferences are (1) French/Switzerland [fr-ch] and (2) English [en] . OS is Windows 10, Firefox Quantum (64-bit) 60.01 installed. OS date format dd.mm.yyyy, as shown at bottom of screen. But footer in printed pages do not pick up the OS date format (nor browser locale) but use U.S. format mm/dd/yyyy. Which is confusing to me and can be misread when dd < 12. How can I get Firefox to use the Windows date format? [N.B. please don't tell me to install the British version of Firefox as that is not my English and the spell checker will be wrong] Thank you.

I live in Switzerland. My preferred languages as set in Firefox preferences are (1) French/Switzerland [fr-ch] and (2) English [en] . OS is Windows 10, Firefox Quantum (64-bit) 60.01 installed. OS date format dd.mm.yyyy, as shown at bottom of screen. But footer in printed pages do not pick up the OS date format (nor browser locale) but use U.S. format mm/dd/yyyy. Which is confusing to me and can be misread when dd < 12. How can I get Firefox to use the Windows date format? [N.B. please don't tell me to install the British version of Firefox as that is not my English and the spell checker will be wrong] Thank you.

All Replies (2)

more options

Hi, fyi : Microsoft has replaced your Video Card Drivers with it's own (possibly all hardware) adapterDescription: Intel(R) Q965/Q963 Express Chipset Family (Microsoft Corporation - WDDM 1.1) driverDate: 10-1-2012

There are also errors : failures: [u'CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs igd10umd64 v= and igd10iumd64 v=', u'CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs igd10umd64 v= and igd10iumd64 v=', u'CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs igd10umd64 v= and igd10iumd64 v=', u'CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs igd10umd64 v= and igd10iumd64 v=', u'CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs igd10umd64 v= and igd10iumd64 v=', u'CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs igd10umd64 v= and igd10iumd64 v=', u'CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs igd10umd64 v= and igd10iumd64 v=', u'CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs igd10umd64 v= and igd10iumd64 v=']

https://www.howtogeek.com/302595/how-to-stop-windows-10-from-automatically-updating-hardware-drivers/

Suggest work on these as it maybe the problem as video card driver errors can cause a multitude of issues. Though you can see if it is extensions as the issue : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

more options

Many thanks for your fast reply. I tried safe mode and that makes no difference. Although I am pretty PC-friendly (assemble them) I am not interested in playing with the video drivers or editing the registry. I have re-installed the Opera browser which I used for years before being seduced by reports of how good Firefox is (and apart from this problem it is) and will remove Firefox from my system. Opera uses the OS date format.