Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mozilla.cfg not working when a string is added

  • 3 replies
  • 1 has this problem
  • 6 views
  • Last reply by cor-el

more options

I am using a mozilla.cfg with the local-settings.js to edit about:config and the string lockPref("network.automatic-ntlm-auth.allow-non-fqdn",true); will not allow firefox to open. If I remove the string firefox works just fine. Any suggestions?

I am using a mozilla.cfg with the local-settings.js to edit about:config and the string lockPref("network.automatic-ntlm-auth.allow-non-fqdn",true); will not allow firefox to open. If I remove the string firefox works just fine. Any suggestions?

All Replies (3)

more options

Can you post the full content of the mozilla.cfg file in case there is another problem with the file?

mozilla.cfg is run as a JavaScript file, so any error in the file will throw an exception and abort the execution.

I'm not having a problem with that line in mozilla.cfg, so I assume that something else is wrong.

Modified by cor-el

more options

here is my cfg file but I can remove the non-fqdn and it works fine

// lockPref("browser.startup.homepage", "");

lockPref("dom.disable_open_during_load",false);

lockPref("app.update.enabled",false);


lockpref("network.automatic-ntlm-auth.trusted-uris",") (I removed the domain's from here)

lockpref("network.automatic-ntlm-auth.allow-proxies", false);


lockPref("network.automatic-ntlm-auth.allow-non-fqdn",true);

Modified by ryan.gernaat

more options

I see two lines with lockpref() instead of lockPref(). Those lines won't work and cause an error. I assume that the trusted-uris value is enclosed in quotes, I only see one quote but you edited this line

lockpref("network.automatic-ntlm-auth.trusted-uris",") (I removed the domain's from here)
lockpref("network.automatic-ntlm-auth.allow-proxies", false);