Resolver problemas con plugins como Flash o Java para solucionar incidencias comunes de Firefox

This page does not exist in Euskara. You have been redirected to the Español version instead. If you would like to localize it into Euskara, click here. You can also see the English version of this page.

En marzo de 2017, cuando se lance la versión 52 de Firefox, Mozilla dejará de ofrecer asistencia para todos los plugins NPAPI, excepto para Flash. Para obtener más detalles, consulta este artículo y este post.

Si tienes problemas con páginas que usan plugins (como Adobe Flash, Javay otros) para mostrar contenido, puede que necesites comprobar si un plugin es el causante del problema.

Nota: Ahora, la versión de 64-bit de Firefox solo reconoce y admite los plugins NPAPI de Adobe Flash y Microsoft Silverlight.

Entre los problemas más comunes que pueden ocasionar los plugins se incluyen:

Este artículo describe cómo solucionar problemas con los plugins. Si tienes un problema con una extensión o con un tema, puedes ver Resolución de incidencias relacionadas con extensiones, temas y aceleración de hardware para solucionar problemas comunes de Firefox. Para más información sobre los plugins, puedes ver Usar plugins para reproducir audio, video, juegos y mucho más.

Determinar si un plugin es la causa del problema

Puedes deshabilitar plugins de forma selectiva mientras Firefox se está ejecutando. Si sospechas de un determinado plugin, deshabilítalo primero, e intenta reproducir el problema. Si no sabes qué plugin deshabilitar:

  1. En la parte superior de la ventana de Firefox, haz clic en el botón FirefoxEn la barra de menú, haz clic en HerramientasEn la parte superior de la ventana de Firefox, haz clic en el Herramientas y selecciona Complementos. Se abrirá la pestaña del Administrador de Complementos.Haz clic en el botón Menú New Fx Menu y elige Complementos. Se abrirá la pestaña del Administrador de Complementos.

  2. En la pestaña del Administrador de Complementos, selecciona el panel Plugins.
  3. Selecciona el plugin de la lista y haz clic sobre su botón de No activar nunca. Repite este paso por cada uno de los plugins de la lista hasta que todos estén desactivados. No es necesario que reinicies Firefox para que los cambios tengan efecto.
  4. Haz pruebas para ver si el problema se repite. Si esto no ocurre, vuelve al administrador de complementos y vuelve a habilitar los plugins uno a uno con su botón de Activar siempre en el menú desplegable hasta que encuentres cuál es plugin causante del problema.

Si al deshabilitar un plugin se soluciona el problema, sigue los pasos que se indican en este artículo.

Actualizar o reinstalar tus plugins

Muchos de los problemas con los plugins pueden resolverse actualizando a la ultima versión del plugin. Para comprobar si tus plugins instalados están desactualizados, visita la página de comprobación y actualizaciones de plugins de Mozilla.

Si actualizar a la nueva versión del plugin o reinstalarlo por completo no soluciona el problema, puedes dejarlo deshabilitado.

Desinstalar manualmente un plugin

Si no puedes usar un programa de desinstalación para eliminar un plugin, puedes eliminarlo manualmente:

  1. Escribe about:plugins en la barra de direcciones y presiona la tecla EnterReturn para que aparezca la página "Acerca de los plugins".
  2. Cada una de las entradas que aparecen en la página "Acerca de los plugins" tendrá el Nombre del archivo: seguido del nombre del plugin.

Se eliminará el plugin.

Reinicializar la base de datos de plugins

En algunos casos, puede que no puedas instalar o reinstalar un plugin. Reinicializar la base de datos de plugins puede que solucione este problema:

  1. Abre tu carpeta de perfil de usuario:

    En la parte superior de la ventana de Firefox, haz clic en el botón Firefox, desplázate hasta el menú AyudaEn la barra de menús, haz clic en el menú AyudaEn la parte superior de la ventana de Firefox, haz clic en el menú Ayuda y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.Haz clic en el botón de menú New Fx Menu , en Ayuda Help-29 y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.

  2. Debajo de Configuración básica de la aplicación, haz clic en el botón Mostrar carpetaAbrir carpetaMostrar en FinderAbrir directorio. Se abrirá la ventana con los archivosla carpeta de tu perfil.
  3. Nota: Si te resulta imposible abrir o utilizar Firefox, sigue las instrucciones que se muestran en Buscar tu perfil sin necesidad de abrir Firefox.

  4. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona SalirEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona SalirEn la barra de menú, haz clic en el menú Firefox y selecciona Salir de FirefoxEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona Salir.

    Haz clic en el botón de menú New Fx Menu y selecciona SalirQuit Close 29 .

  5. Borrar el archivo pluginreg.dat.
  6. Abre Firefox.
  7. En la barra de dirección teclea about:plugins y presiona la tecla EnterReturn para que aparezca la lista de plugins instalados en Firefox.

Artikulua lagungarria izan da? Itxaron mesedez...

These fine people helped write this article: willyaranda, Breaking_Pitt, inma_610, avelper. You can help too - find out how.