Entire system is slow, egregious firefox memory use. Any known issues?

6-9GB consumption just seems like too much to me. Attached a couple screenshots and the FF troubleshooting information, any other data I can provide anyone that can help… (read more)

6-9GB consumption just seems like too much to me. Attached a couple screenshots and the FF troubleshooting information, any other data I can provide anyone that can help this? I'm sure restarting firefox will fix it for a while, but it seems like there is a resource leak somewhere.

Asked by tavise 1 minut tagasi

Firefox 92 under Window 7 will not load pages fully. Mobile pages work partially sometimes. How do I install Firefox 88.0.1?

I want my bank website to load pages like it used to under Firefox 88 and also Facebook behaves like I am in Facebook jail for over a month. Some mobile pages will work … (read more)

I want my bank website to load pages like it used to under Firefox 88 and also Facebook behaves like I am in Facebook jail for over a month. Some mobile pages will work partially sometimes. Can I replace Firefox 92 with Frefox 88 and how do I do that?

Asked by tgramful 50 minutit tagasi

Last reply by tgramful 49 minutit tagasi

Firefox Update

Tried to update Firefox as advised by browser, but download doesn't support OS 10.11.6. Don't want to update OS as system is old. What is the last version of Firefox th… (read more)

Tried to update Firefox as advised by browser, but download doesn't support OS 10.11.6. Don't want to update OS as system is old. What is the last version of Firefox that I should download?

Asked by roonem1 53 minutit tagasi

Google Maps

I've been unable to open Google Maps for the last couple of months, or so. It doesn't matter whether I try directly through a Google search, or from within another websit… (read more)

I've been unable to open Google Maps for the last couple of months, or so. It doesn't matter whether I try directly through a Google search, or from within another website.

Asked by fhberkin 1 tund tagasi

FireFox 92 slows down / freezes then resumes

Hello, Ever since the last upgrade was installed I have seen that the browser gets slower and slower but even on the first tab opened the performance is terrible. The sym… (read more)

Hello,

Ever since the last upgrade was installed I have seen that the browser gets slower and slower but even on the first tab opened the performance is terrible. The symptoms are that pages load slowly, typing doesn't get displayed in the order typed, using aps like Ancestry in the photo section; using the select a face from a picture is very slow and jerky.

I would gladly give up what 'improvements' 92 provided just to get back to a version that works better.

I have disabled unused features, defragged the HD, and followed what was provided about slow FF and nothing has helped.

As a test I tried another browser on the same site and it was lightening fast. I prefer FF so that is not an option.

Any ideas on what I can do to get FF to operate better????

Thanks on advance for your help!!

Asked by RHB10 2 nädalat tagasi

Last reply by RHB10 1 tund tagasi

Certain downloads repeatedly fail when in Incognito mode, and succeed in Regular mode, even when the requests sent by the browser are 100% word-for-word identical. Request logs provided.

SHORT SUMMARY: A few specific direct downloads from a third-party server successfully finish in Regular browsing mode but fail half-way in Incognito mode. This is reprodu… (read more)

SHORT SUMMARY:

A few specific direct downloads from a third-party server successfully finish in Regular browsing mode but fail half-way in Incognito mode. This is reproducable on numerous tries and persists between Firefox restarts, system reboots, and ISP changes. This difference between Regular and Incognito remains even when the requests that the browser sends are fully word-for-word identical, down to the DNT=1 in the request. There are no issues with downloads in Google Chrome on the same machine, and similarly no issues in Incognito mode in an old ESR Firefox (v52) on a really old laptop with WinXP. This problem ONLY appears in Firefox 92. ========================================

FULL DETAILS:

I'm using the latest public release of Firefox, 92.0.1, on Windows 8. I have a habit of using Incognito mode most of the time, and I found out that certain downloads fail in Incognito tabs - but succeed in Regular tabs. A few examples:

http://down.360safe.com/cse/360cse_official.exe http://down.360safe.com/cse/360cse_9.5.0.122.exe http://down.360safe.com/cse/360cse_9.5.0.114.exe http://down.360safe.com/cse/360cse_9.0.1.162.exe

They are direct links to the .exe setups of various versions of an obscure browser called 360 Extreme Browser, recommended for use with WinXP on obsolete hardware since it's supposedly very lightweight. You can run them through VirusTotal if you want. The first link always points to the latest release, the other links are specific releases.

When I open any of them, I am first presented with the regular download dialog box, while Firefox automatically starts downloading the file to %TEMP% in the background, without waiting for my decision (as it always does):

https://i.imgur.com/0D6pH4Z.png

... then, a couple seconds later, I'm presented with the "source file could not be read" error.

https://i.imgur.com/3f6StGQ.png

When I click OK, the first dialog box also disappears, and there is no trace of the (failed) download left in the download widget in the top right.

Alternatively, I can try to be very fast, and as soon as the first dialog box appears, I can quickly click "Save File" and press Enter in the folder selection window that appears. That way, I can confirm the download before it gets a chance to fail. But it fails anyway, except this time I can see the incomplete file in my destination folder, and the failed download in the list of downloads in the top right corner of Firefox. This download fails about 5-15 MBs into the file - it's different between different attempts.

It is my understanding that the "nature" or "mechanism" of the fail is the same, but if it happens while it's downloading to %TEMP% and I haven't selected the folder yet, then I'm presented with an explicit error message and there is no trace of it in the download history, and if it happens when I've already selected the folder, then there is no explicit error message and the failed download is displayed in the download history.

In the latter case, I can then press "Retry download" in the download history. Then, the download will successfully restart (not from zero, but from the percentage that it failed at) and will successfully complete. But the FIRST try, initiated by the tab ("by the page"?) and not by the "download history" widget in the corner, ALWAYS fails at some point between 5-15 MBs.

========================================

INVESTIGATION AND LOGS AND LOTS OF TECHNICAL DETAILS

So you might say, that third-party server is acting weird and is probably misconfigured. But:

  • This download ALWAYS SUCCEEDS without any problems in Regular (not Incognito) tabs. It ALWAYS FAILS in Incognito.
  • This download ALWAYS SUCCEEDS in Google Chrome that I have on this same machine, both in Regular and in Incognito.
  • This download ALWAYS SUCCEEDS in Firefox 52.9 ESR on a really obsolete laptop with WinXP that I have, connected to the same network(s), both in Regular and in Incognito.

To sum up, this fails VERY SPECIFICALLY in Incognito mode in Firefox 92 (current modern version) and NOWHERE ELSE.

All download attempts that are successful (non-Incognito FF 92, Google Chrome, FF 52.9 ESR...) result in a downloaded file with the same correct size and checksum. The download that is successfully RESTARTED after failing in Incognito (read details above) also results in a file with the same size and checksum.

I am not aware of any software on this machine that would be interrupting the download, such as antivirus. In any case, it's interrupted when it reaches a different random size on each different attempt, and it only affects Incognito Firefox and nothing else - not Regular tabs of FF and not Chrome. I have also tried two different ISPs - one that provides me with Ethernet at my place, and my mobile phone ISP. Same behavior between them. The only third-party plugin that I have in Firefox is uBlock. I disabled it completely and this didn't change anything.

I've inspected the requests and responses, using Firefox's own dev tools.

REGULAR TAB (not incognito) = SUCCESSFUL DOWNLOAD

https://pastebin.com/xzXXJDEt (so as not to clutter this message with long request listings)

INCOGNITO TAB: FAILED DOWNLOAD

https://pastebin.com/Nq0txZ9P (same reasoning)

The differences are: Incognito mode forces HTTPS, sends Sec-Fetch- entries in the GET request, and also sends DNT = 1. Everything else is the same.

I then went to Firefox settings and enabled sending DNT *all the time*, even in Regular (non-incognito) tabs. I also tried to download explicitly from the https:// URL in Regular (non-incognito) mode, just like Incognito mode forces https. This resulted in a request that is sent from a Regular tab but is 100% identical to the request sent from Incognito mode. Read below:

https://pastebin.com/0QCpKqBZ (same reasoning for hosting on Pastebin)

You can check that this request from a Regular (non-incognito) tab is now word-for-word identical to the request from an Incognito tab. Yet, the download from Incognito STILL fails at ~10 MBs into the file, and the download from Regular STILL succeeds. I fail to see any difference between the requests, whatsoever.

In the Cookies tab, there are "No cookies for this request" for both Regular and Incognito downloads. The Security tab looks 100% identical for Regular and Incognito downloads, and looks like this: https://i.imgur.com/SAhzquW.png (idk how to copy this in plaintext form).

In another online discussion elsewhere while I was troubleshooting this, I was advised to see if network.dns.echconfig.enabled was set to TRUE and to try setting it to FALSE. Not sure what this would change, but I went to check and found that it was already FALSE.

Also, in that discussion elsewhere, I had one more user running Firefox on Windows 10 (according to his publicly displayed user agent) confirm this. But I don't know how to reach him to ask for extensive troubleshooting like mine.

========================================

FINAL SUMMARY:

  • Some specific downloads fail halfway in Incognito Mode in latest Firefox
  • There are no issues in Regular (non-incognito) mode, or in Google Chrome on this same machine, or in obsolete Firefox 52 on another machine
  • This persists across Firefox restarts, reboots, ISP changes
  • This difference between Regular and Incognito modes persists even when you change settings so that the sent GET requests are 100% word-for-word identical

Help me troubleshoot this further? Even if this is caused by that third-party server acting up (for whatever reason), how does it tell between my Regular firefox tab and my Incognito firefox tab when the sent requests are the same? And even if this is caused by something else on my machine or in my network, then the same question applies, how can this "something" tell between my Regular and Incognito tabs?

Asked by jagev53494 8 tundi tagasi

firefox "screenshot" command line option

in previous versions of firefox, I was able to create screenshots with the following command line options: /firefox.exe" -P headless --purgecaches --screenshot raw_weathe… (read more)

in previous versions of firefox, I was able to create screenshots with the following command line options:

/firefox.exe" -P headless --purgecaches --screenshot raw_weather.png --window-size=1920,1080 -browser "https://www.google.com/search?&q=weather+in+Washington+DC"

however, with the latest version 92.0.1, the "--screenshot" option no longer works. what has changed? what am I doing wrong?

Asked by nealelliott1 23 tundi tagasi

Last reply by nealelliott1 1 tund tagasi

Facebook not loading some pictures, loading very slow, or not loading anything at all (blank screen).

Issue: Facebook not loading some pictures, loading very slow, or not loading anything at all (blank screen). Firefox 92.0.1 (64 bit). The only extension is AdGuard, deact… (read more)

Issue: Facebook not loading some pictures, loading very slow, or not loading anything at all (blank screen).

Firefox 92.0.1 (64 bit). The only extension is AdGuard, deactivated for Facebook OS: Windows 10 Pro 10.0.19044 Build 19044. Recently installed. It works perfectly with Microsoft Edge and with Chrome.

What I have already tried: - "Forget this site" option - Clear all cookies and cache - Start Facebook in safe mode - Deactivate "Enhanced Tracking Protection" for Facebook - Uninstall Firefox, delete related folders, run registry clean, reinstall Firefox

Asked by MG 1 tund tagasi

No option to open PDFs in Firefox 92.0.1 (64-bit)

According to this article I should be able to preview PDFs within Firefox. I am not able to, even in safe mode. See screenshot for my settings area. There is simply no op… (read more)

According to this article I should be able to preview PDFs within Firefox. I am not able to, even in safe mode. See screenshot for my settings area. There is simply no option to set Firefox to Open/view PDFs.

Asked by TheGuyInTheBack 1 tund tagasi

account and password from logins.json file

Hello, I have folder with old Firefox data, I need Google account name and password, mostly name. How can i decrypt the name from file logins.json or how can I import it … (read more)

Hello, I have folder with old Firefox data, I need Google account name and password, mostly name. How can i decrypt the name from file logins.json or how can I import it to my current Firefox profile? In properties of passwords in Firefox I don't have option to import from file, I don't know how to find option that will let me do it.

Asked by sawicka.katarzyna91 2 tundi tagasi

Not Able To Play YouTube On Latest Firefox

Hello Everyone. This is my first post to this Mozilla Community. From the last update of Firefox(92.0.1), I am not able to play YouTube on it. I don't use Google Chrome o… (read more)

Hello Everyone. This is my first post to this Mozilla Community. From the last update of Firefox(92.0.1), I am not able to play YouTube on it. I don't use Google Chrome on my PC, as it takes lots of RAM, so basically, I use Firefox as my primary Browser. Can anyone confirm, is YouTube playable on the latest version of Firefox or not? Currently, I am using Windows 7 Ultimate with 4Gigs of RAM.

Asked by travis.kirlin 3 tundi tagasi

Error trying to preview an attached file on Hotmail, using Firefox

Hello, Since yesterday (Sept, 28th 2021), I have the following message when trying to preview an attached document (PDF, in this case), accessing Hotmail using Firefox 92… (read more)

Hello, Since yesterday (Sept, 28th 2021), I have the following message when trying to preview an attached document (PDF, in this case), accessing Hotmail using Firefox 92.0 (64-bit) in UBUNTU Linux:

"Something went wrong while the document preview was being created. Please try again later"

The same error also occurs using Firefox 92.0 (64 bit) in Windows 10, but does not occur using Chrome in UBUNTU and Chrome in Windows, as well as using Microsoft Edge. Can you help me please?

Thanks in advance. Manoel.

Asked by manoel_cunha 3 tundi tagasi

Cursor disappears in maps

When i look at a map embedded in website the cursor disappears and only shows up randomnly or when you stop moving the mouse. This makes using maps in Firefox impossible.… (read more)

When i look at a map embedded in website the cursor disappears and only shows up randomnly or when you stop moving the mouse. This makes using maps in Firefox impossible. Must be related to Firefox - works in Google Chrome Please fix or advise or I have to change webbrowser

Asked by roger.pettersson 1 nädal tagasi

Last reply by roger.pettersson 5 tundi tagasi

Microsoft Edge stealing info from Firefox

Microsoft Edge browser seems to be stealing my Firefox search and data info. Items I have shopped for in Firefox are showing up in Edge advertisements. Any way to fix thi… (read more)

Microsoft Edge browser seems to be stealing my Firefox search and data info. Items I have shopped for in Firefox are showing up in Edge advertisements. Any way to fix this?

Asked by em2brcmdpc 5 tundi tagasi

I just figured out there is a wordpress management plugin as firefox addon! Can I use them?

I am a blogger and I want a management plugin for my Wordpress website https://myuniversalremotecodes.com like I can see its available as Wordpress Toolbar by Baris Derin… (read more)

I am a blogger and I want a management plugin for my Wordpress website https://myuniversalremotecodes.com like I can see its available as Wordpress Toolbar by Baris Derin (Firefox Addon) is it safe to use and manage it if I use this addon?

Asked by gbmasari 6 tundi tagasi