Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When changing and fixed the language settings for www.google.com to english, why still it is getting opened (google home page) in some south indian language?

  • 2 vastust
  • 4 on selline probleem
  • 22 views
  • Viimati vastas cor-el

more options

Title: When changing and fixed the language settings for www.google.com to english, why still it is getting opened (google home page) in some south Indian language? STEPS: 1. Launch Firefox from desktop >> in the address bar type www.google.com >> go to language settings and set to English as default. 2. Again launch www.google.com 3. Observe.

Actual Result: Again it is being launched in some south Indian language.

Expected Result: Again google home page should open with english options as set.

Reproducibility: 100%

Valitud lahendus

Google stores such settings in a cookie on your computer, so you have to make sure that you keep such a cookie.

  • Firefox/Tools > Options > Privacy > Cookies: Exceptions

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

Loe vastust kontekstis 👍 4

All Replies (2)

more options

Hello,

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

Thank you.

more options

Valitud lahendus

Google stores such settings in a cookie on your computer, so you have to make sure that you keep such a cookie.

  • Firefox/Tools > Options > Privacy > Cookies: Exceptions

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.