Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My university requires Foxfire 3+ & I'm not finding the download. If it's still available, please let me know where it's located.

more options

California State University campuses require Foxfire 3+, not the current version. This is the warning message that I'm getting when I do a browser check at the campus website using Blackboard: Web Browser Your web browser is: Firefox 5 Your web browser is not currently supported by Turnitin and full compatibility with Turnitin products cannot be guaranteed. Please let me know how to correct this problem...Thanks.

All Replies (1)

more options

BlackBoard has its' own update schedule, which differs from Mozilla's release schedule for Firefox. BlackBoard usually runs a few versions behind the latest version of Firefox.

http://www2.blackboard.com/tuneup/viewpage?name=tuneup_browser_tuneup_windows_firefox
Select the link for the version of WebCT Vista or Campus Edition (version info is usually at the bottom of each page, in the footer) that your school is using, then see which version of Firefox is compatible.

Depending upon which version of WebCT your school is using, you will have to use Firefox 3.6.x, Firefox 3.5.x, or Firefox 3.0.x when accessing the Blackboard site.

My advice is to install the Firefox Portable version that you need for Blackboard on your computer, and use that installation only for Blackboard. Continue to use 5.0 for all other web browsing.
http://portableapps.com/apps/internet/firefox_portable/localization#legacy