Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

unable to visit http site

  • 10 vastust
  • 1 on selline probleem
  • 197 views
  • Viimati vastas brynn2

more options

Hello, I'm not sure if I chose the right topic above.

I'm trying to visit a site which is still using http. But Firefox is automatically redirecting to https, where of course it cannot resolve the site.

In settings, I have it set for "Don’t enable HTTPS-Only Mode". But still, Ff is redirecting.

I don't know. Maybe I should set for https only, and then enter an exception??

I have searched for a solution, but for every solution I find, when I look up how to do it, it says, before you try this, try that first. After about 5 rounds of that, I got too confused and gave up.

Oh, I also cleared the cache, but no help.

I've enabled all the extra info below. But let me know if you need any other specific info. Do you need the address of the website?

Thank you very much.

Hello, I'm not sure if I chose the right topic above. I'm trying to visit a site which is still using http. But Firefox is automatically redirecting to https, where of course it cannot resolve the site. In settings, I have it set for "Don’t enable HTTPS-Only Mode". But still, Ff is redirecting. I don't know. Maybe I should set for https only, and then enter an exception?? I have searched for a solution, but for every solution I find, when I look up how to do it, it says, before you try this, try that first. After about 5 rounds of that, I got too confused and gave up. Oh, I also cleared the cache, but no help. I've enabled all the extra info below. But let me know if you need any other specific info. Do you need the address of the website? Thank you very much.

Valitud lahendus

Hey, good news!

I had switched the Enhanced Tracking setting a few times, but except for what I mentioned above, it didn't do anything.

What needed to happen was that I had to restart Firefox after changing one of those settings. It might be a good idea to mention that on Settings page, that you need to restart Firefox to make it take effect.

Anyway, it was set on Custom, which apparently was too high. I change to the default, restarted Firefox, and now I have the page!

Later, I will switch to Strict, to see how much I can get away with.

Anyway, thanks jscher2000 and cor-el, for you help. I appreciate it very much!

Loe vastust kontekstis 👍 0

All Replies (10)

more options

Are you using a private window when you visit the site?

If you are using private windows:

In private windows, Firefox 91+ generally applies "HTTPS-First Mode" (Firefox 91 introduces HTTPS by Default in Private Browsing). Unfortunately, unlike the "HTTPS Only" feature, which you can manage in detail, "HTTPS-First" does NOT allow user exceptions.

You might need to disable "HTTPS First" and enable "HTTPS Only" in private windows to find the best balance of convenience and protection.

Disabling HTTPS First in private windows

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste dom.security.https_first_pbm and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

You can close this tab now.

Enabling HTTPS Only in private windows

You can set this up on the Settings page. See: HTTPS-Only Mode in Firefox.

Any difference?

Helpful?

more options

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Note that you appear to be using an outdated Firefox 96.0 version according to the System Details. Any special reason for that version and not the current release (98.0.1) ?

Helpful?

more options

Thank you jscher2000

I am not using a private window that I know of. If it somehow happened accidentally, how can I find out?

Thank you cor-el

This is the page I'm trying to visit. http://www.innovativehousingconcepts.org/

I forgot to mention before, but I can access it with other browsers. It's just Firefox where I can't get it. Although I guess it's possible the page is broken?

I get tired of explaining why I don't use the most current version. And I'm sure you've heard it all before anyway. Let's just say that's my choice.

I will upgrade to the current version, if there's some reason to think that might solve the problem. For example, did Firefox change how it handles https in a more recent version? Anything like that?

Or as a last resort, I would try upgrading.

Helpful?

more options

No problem to access this website via a secure HTTPS connection, so no need to use HTTP or an HTTPS-Only exception.

Helpful?

more options

Are yo possibly using a proxy or VPN to connect ?

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Helpful?

more options

Site seems to work fine with either HTTP or HTTPS. What happens when you try to load the page?

Helpful?

more options

jscher2000 said

Site seems to work fine with either HTTP or HTTPS. What happens when you try to load the page?

First when I browse to the site, I see the http change to https. It happens instantaneously, if I blink, I miss it.

Than I just see the circle spinning in the middle of a blank white page. It looks like it's waiting for me to allow the scripts with NoScript. So I allow the scripts. But the circle just keeps spinning. Re UBlock, I've marked it as a safe site, so UBlock is not the c ulprit.

cor-el,

No proxy. No VPN.

Connection Settings already show No Proxy is ticked.

I clicked the lock icon in address field. It shows 'certificate issuer is not recognized by Mozilla'. Could that be the problem?

When I have seen this problem in the past, it gives me an option to proceed to view the page anyway. In this case, it does not give me any options.

Continuing with the articles you referenced, I've cleared the cookies and cache 3 times now.

I used about:config, to change IPv6 to true.

But I hesitate to continue with more and more serious changes, because as I read through the articles, I was reminded that I was able to visit the site once or twice, before it stopped working. I've been trying to figure out what I might have done recently.

I've only recently come back to Firefox, and I think I might have changed some settings in Privacy and Security. So I've been going through and swapping out settings.

Just now, I changed Enhance Tracking Protection from Strict to Custom (I know that seems backwards, but I'm also exploring these settings at the same time). Then suddenly, the site displayed, with one Asian character instead of a usual icon. It displayed for only a moment - 20 seconds maybe, and it went back to the white page with spinning circle in the middle.

So I'll post this, and continue to play with the settings. Maybe I'll hit on the solution....

If you all have any insight, please share.

Thank you very much

Helpful?

more options

Valitud lahendus

Hey, good news!

I had switched the Enhanced Tracking setting a few times, but except for what I mentioned above, it didn't do anything.

What needed to happen was that I had to restart Firefox after changing one of those settings. It might be a good idea to mention that on Settings page, that you need to restart Firefox to make it take effect.

Anyway, it was set on Custom, which apparently was too high. I change to the default, restarted Firefox, and now I have the page!

Later, I will switch to Strict, to see how much I can get away with.

Anyway, thanks jscher2000 and cor-el, for you help. I appreciate it very much!

Helpful?

more options

Hhmm.... I have that site, but now, some other sites will not load....

It doesn't make sense...

Muudetud brynn2 poolt

Helpful?

more options

Ok, restarting computer seems to have put things back in order.

Time for some rest!

Thanks again!

Helpful?

Küsimuse postitamine

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.