Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I change the default backround color from white to black? AKA Stop the white flash.

  • 3 vastust
  • 2 on selline probleem
  • 19 views
  • Viimati vastas jscher2000

more options

Whenever I open any webpage, the window turns solid white for a second before the page loads.

I am not talking about "new tab" I already have that set to use a dark theme. This is when you click on a favorite or a link on a page.

I can open a new tab with it's dark theme with no white flash but then I click on a saved favorite, and I get the white flash before any of the website loads.

PS I am using the userContent.css and userChrome.css from https://github.com/aris-t2/customcssforfx but have not found a setting for this.

Muudetud MadeUpName30 poolt

All Replies (3)

more options

Hi, I do not think you can stop that as the page needs to start loading before any settings can take effect. You may want to see Greasemonkey Extension :

sort off a companion to the above :

Google :

youtube :

and this one, does sites : https://addons.mozilla.org/en-US/firefox/addon/stylish/ there is more out there under themes

Please let us know if this solved your issue or if need further assistance.

Muudetud Shadow110 poolt

more options

None of those addons, all of which I am familiar with, can help. All of those apply CSS to specific websites.

I'm talking about the default color the browser uses for a backround "before" any part of a webpage is loaded.

Type anything, something, into the search/adress bar and hit enter.

The browser window will flash white for a second before doing anything else.

Muudetud MadeUpName30 poolt

more options

Since ancient days, I've had this in either a Stylish userstyle (pre-Quantum) or userChrome.css:

@-moz-document url(chrome://browser/content/browser.xul) {
  browser[type="content-primary"], 
  browser[type="content"] {
    background: #778899 !important;
  }
}

I do see that dark slate color from time to time, so I think it still works.

Or check the CSS for this theme which is still under active development: https://github.com/overdodactyl/ShadowFox