Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Facebook is not sending Push Notifications despite all settings turned on

  • 15 vastust
  • 7 on selline probleem
  • 10 views
  • Viimati vastas Tonnes

more options

I have tried everything to enable Facebook push notifications in my Firefox but all of the following have failed:

-I have set the "Receive Notifications" setting for Facebook to "Allow". -In about:config, dom.webnotifications.enabled is set to true. -I tried Safe Mode and also tried removing all Add-ons, didn't work. -I have tried uninstalling my entire Firefox with all data removed completely from my laptop and reinstalling it.

This Push notification feature is so important and would help me not miss any facebook notifications, but I have tried all solutions mentioned all over the internet and nothing has seemed to work and enable Facebook push notifications. Please help me fix this problem personally.

I have tried everything to enable Facebook push notifications in my Firefox but all of the following have failed: -I have set the "Receive Notifications" setting for Facebook to "Allow". -In about:config, dom.webnotifications.enabled is set to true. -I tried Safe Mode and also tried removing all Add-ons, didn't work. -I have tried uninstalling my entire Firefox with all data removed completely from my laptop and reinstalling it. This Push notification feature is so important and would help me not miss any facebook notifications, but I have tried all solutions mentioned all over the internet and nothing has seemed to work and enable Facebook push notifications. Please help me fix this problem personally.

All Replies (15)

more options

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer

Try

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem. Never work with original files.

Please let us know if this solved your issue or if need further assistance.

more options

I followed your steps EXACTLY and I am still not getting the facebook notifications. I deleted my Firefox profile entirely, no accounts synced, refreshed firefox as well.


Also, I noticed one anomaly in Firefox when I open my facebook account notification settings. On Chrome, it allows me to choose "Desktop and Mobile", while on Firefox, it only lets me choose settings for "Mobile" (Desktop notifications feature not identified by Firefox) Chrome consequently gives me all Facebook push notifications while Firefox fails to do so.

However, on my mom's laptop, the Firefox shows "Desktop and Mobile" on facebook just like Chrome. How do I fix this now? -+

more options

Maybe my last post has some error in the images. So I am re-posting them.

Muudetud justin_cartor poolt

more options

Think this is more of a Facebook Issue of it not seeing Firefox Properly. It maybe picking that up from Win10. Do not use Facebook myself so no idea if they respond to help.

more options

But on Windows 7, Facebook and other sites do pick up Firefox properly. So isn't this Firefox's fault for not being fully Notification compatible for Win 10?

more options

Did you try clearing cookies and cache as suggested here? Also remove any stored Cached Web Content as well as Site Data in Options > Privacy & Security.

more options

There are two types of notifications. There is the desktop notification that a website can use when you are connected to the website.

The other type of notification that works via a service worker uses a special Push API and a website can use this API at any time whether you are connected to the website or not as it uses a special Push server that manages these notifications.

There is a checkbox in Page Info for the current website:

  • Tools -> Page Info -> Permissions : Receive Notifications

You can check what websites you have allowed to send you messages via the Push API.

  • Options/Preferences -> Content: Notification -> Choose

Push notifications are opt-in, and you can revoke permission from any website at any time,

These notifications require that you give permission to receive the notification when the website prompt you. These types of notifications are controlled globally via prefs that you can inspect and modify via the about:config page.

Global setting Push notifications:

  • dom.push.enabled

Desktop Notification:

  • notification.feature.enabled

Web Notification:

  • dom.webnotifications.enabled
  • dom.webnotifications.serviceworker.enabled

You can see all registered service workers on this page: about:serviceworkers You can check the WebSockets stats via this page: about:networking#websockets

See also this demo page for PUSH:

Muudetud cor-el poolt

more options
more options

Tonnes said

Did you try clearing cookies and cache as suggested here? Also remove any stored Cached Web Content as well as Site Data in Options > Privacy & Security.

I cleared cookies and cache right after reading that page last week but that didn't help. I removed stored Cached Web Content as well as Site Data from Options>Privacy & Security just now, and that didn't help either.


cor-el said
There are two types of notifications. There is the desktop notification that a website can use when you are connected to the website. The other type of notification that works via a service worker uses a special Push API and a website can use this API at any time whether you are connected to the website or not as it uses a special Push server that manages these notifications. There is a checkbox in Page Info for the current website:
  • Tools -> Page Info -> Permissions : Receive Notifications
You can check what websites you have allowed to send you messages via the Push API.
  • Options/Preferences -> Content: Notification -> Choose
Push notifications are opt-in, and you can revoke permission from any website at any time, These notifications require that you give permission to receive the notification when the website prompt you. These types of notifications are controlled globally via prefs that you can inspect and modify via the about:config page. Global setting Push notifications:
  • dom.push.enabled
Desktop Notification:
  • notification.feature.enabled
Web Notification:
  • dom.webnotifications.enabled
  • dom.webnotifications.serviceworker.enabled
You can see all registered service workers on this page: about:serviceworkers You can check the WebSockets stats via this page: about:networking#websockets See also this demo page for PUSH:

I read your post and applied all solutions line by and I have also added screenshots to show that Notification settings for Facebook are turned on still notifications are not showing up because FB wouldn't recognise firefox as a Desktop Notification enabled browser and as far as I have observed, this is happening only on Windows 10. On the contrary, Chrome has no issues with Notifications, and I am highly reluctant to switch my browser and suggest others to do so too. Because Firefox has been my default browser since 10+ years.

more options

Did you also refresh the page overriding the cache using Ctrl+F5, and perhaps more important, did you clear everything when not logged in to FB?

I don’t think any of the settings described above should be modified - I see the "Desktop and Mobile" option for every Firefox setup so assume it should just work by default. Now I’m not very familiar with FB, but it may detect Firefox in a wrong way all right, also based on more reports about improper client detection (unrelated to Firefox though). What I would do:

- Create a test profile, either using about:profiles or by changing the startup shortcut to add -P (more info), and then launch Firefox with that profile. - Optional: run another Firefox instance such as Nightly by extracting it from a .zip file (from here) and running the .exe to see what FB reports. - Make sure any FB setting related to all allowed devices are set up correctly, i.e. remove any instance of Firefox in there (e.g. in the Security and Logins settings, but there may be more) and try to log in on Windows as if it was the first time. - Make sure there is no software on your system able to change the browser user agent string, other than add-ons of course - security software can be one of them. You could also launch Windows in Safe Mode with networking enabled to temporarily bypass any installed security software and see what FB reports. - In order to rule this out: you appear to use a localized version of Firefox. That should not affect the client detection, but you could try an en-US build (as above from a .zip file located here) to see what happens.

more options

Make sure you clear the Facebook cookies to reset all data stored in cookies. I don't know if Facebook uses permanent local storage to store persistent data locally. You can check that in the Storage Inspector.

Note that there is a difference between Push notification and Web notification. The former uses a web server that allows to push notifications to Firefox at any time in the background. Web notifications can only be shown when you have a tab open to a web page that sends them.

I don't know what type Facebook uses. This thread title mentions push notifications.

Did you try the demo Push site I posted above?

more options

Tonnes said

Did you also refresh the page overriding the cache using Ctrl+F5, and perhaps more important, did you clear everything when not logged in to FB? I don’t think any of the settings described above should be modified - I see the "Desktop and Mobile" option for every Firefox setup so assume it should just work by default. Now I’m not very familiar with FB, but it may detect Firefox in a wrong way all right, also based on more reports about improper client detection (unrelated to Firefox though). What I would do: - Create a test profile, either using about:profiles or by changing the startup shortcut to add -P (more info), and then launch Firefox with that profile. - Optional: run another Firefox instance such as Nightly by extracting it from a .zip file (from here) and running the .exe to see what FB reports. - Make sure any FB setting related to all allowed devices are set up correctly, i.e. remove any instance of Firefox in there (e.g. in the Security and Logins settings, but there may be more) and try to log in on Windows as if it was the first time. - Make sure there is no software on your system able to change the browser user agent string, other than add-ons of course - security software can be one of them. You could also launch Windows in Safe Mode with networking enabled to temporarily bypass any installed security software and see what FB reports. - In order to rule this out: you appear to use a localized version of Firefox. That should not affect the client detection, but you could try an en-US build (as above from a .zip file located here) to see what happens.


  • Ctrl+F5 on the page overriding the cache - What page is this? How do I open this?
  • Clearing when logged out - I logged out of my fb time and again, and even deleted my entire profile and all firefox folders and refreshed firefox, that is not helping
  • Created a test profile, and opened firefox in that profile, didn't work. I even cleared all cookies and cache and tried the new profile and failed.
  • I ran the Nightly version from the extracted 31st Dec, 2017 zip file and nope, that didn't help me either. FB still showing only "Mobile".
  • I logged out of all FB sessions and cleared cache again and no success.
  • I launched Windows in Safe Mode with networking enabled and even in that mode, Firefox failed to show me Desktop and Mobile for facebook. In fact no notifications are working at all.
  • I am not using a localized version of firefox. I was told to download a "Full" version from "All Firefox Versions" Page and I downloaded the latest en-US one, 32-Bit. I was using the 64-bit initially corresponding to my 64-bit Win10 System, but I changed it to 32-bit to rule out any possibilities of untried versions.


cor-el said

Make sure you clear the Facebook cookies to reset all data stored in cookies. I don't know if Facebook uses permanent local storage to store persistent data locally. You can check that in the Storage Inspector. Note that there is a difference between Push notification and Web notification. The former uses a web server that allows to push notifications to Firefox at any time in the background. Web notifications can only be shown when you have a tab open to a web page that sends them. I don't know what type Facebook uses. This thread title mentions push notifications. Did you try the demo Push site I posted above?

The Notification that I am talking about is the PUSH Notification, the one that appears on the bottom right corner of the screen (I attached a screenshot from Firefox's website).

I tried your website goroost.com and that is for Developer's Edition of Firefox only, and Google Chrome and Safari. Should I download the Developer's Edition now?

I did clear the entire collection of cookies of my browser and still stand at no success.

more options

Since my problem was not solved, and since Google Chrome is providing the glitch-free service of Push Notifications that FIrefox is failing to provide, I'm sad to say that I am switching my browser today after using it for 12 years.


Hope you guys fix this someday.

Highly disappointed.

more options

Another website to test PUSH: https://gauntface.github.io/simple-push-demo/

See also: about:serviceworkers

more options

Have you ever tried using another (or new / temporary) Facebook account to rule out the issue is account related?

I did note your account does not suffer the issue with Chrome as per the "Desktop and Mobile" string, but it might be account and client related nevertheless, in which case you may need to clear the known Firefox client info at FB in some way - frankly I don’t know how.

Also, please have a look at this bug which may deal with the issue. Because of that bug I hoped the answer to your question about the requirement to use Dev Edition for now would be yes, also because I cannot reproduce this in Nightly. However, I see no issue in Firefox 56 release either (that I never tried FB in until today) but your mileage may vary, hence the account related question. As you already tried Nightly which is basically similar to Dev Edition, it probably won’t help. Do note the comments about "coordinated decision" and "roll out for all users" in that bug, so all this may be expected behavior based on your region.

In short: I would try Developer Edition / Nightly (from zip), create a new FB account to check for the Desktop and Mobile setting being available, then log out and log in again in using FF release 57 or 58 (or even 56 when still available on any system in order to rule out a possible regression after 56) to do the same. If that does not help, I’m afraid you need to wait for the bug to be fixed.