Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After updating Firefox and Flash player, I can't play flash videos.

more options

I'm running Firefox on 32-bit XP (I know, in know... ) and I just updated both Firefox and Flash player. Since then I've been unable to play videos on most streaming sites. Youtube still works, but only at 360p, which I'm told is because it is using HTML5 player. Looking at https://www.youtube.com/html5, the page indicates I can play 'HTMLVideoElement' 'WebM VP8' and 'Media Source Extensions' but not 'H.264' 'MSE & H.264' or 'MSE & WebM VP9'.

All Replies (2)

more options

Yes, unfortunately, Firefox does not include its own MP4 decoder and has to rely on what Microsoft has supplied. Microsoft never provided it on XP.

Firefox might be able to decode VP9. Some capability is built in but it's not enabled by default, perhaps because it's not fully baked yet. If you want to try it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webm and pause while the list is filtered

(3) Double-click the media.mediasource.webm.enabled preference to switch it from false to true

This should light up that "MSE & WebM VP9" button on https://www.youtube.com/html5 but I don't know whether you'll get more format selections.


The following is a re-post based on research done about 6 weeks ago. I have not double-checked that this still works because it's hard to get my hands on an XP device.

Until Firefox 39, YouTube served Windows XP users the Flash-based player. Starting in Firefox 40, YouTube now serves Windows XP users the HTML5-based player, which is very unfortunate because on Windows XP, Firefox can't decode MP4, so you get WebM 360p as your only format choice.

Assuming this is the problem -- you can right-click the player and look at the last line of the short context menu to confirm the player being used -- here are two possible workarounds:

(1) Use an add-on to force YouTube to serve you the Flash player

There are at least two extensions for this, you only need one:

A limitation is that this doesn't help with YouTube videos embedded into other sites.

(2) Use an add-on to tell YouTube you're still running Firefox 39

(A) Install the extension https://addons.mozilla.org/firefox/addon/ua-site-switch/ which admittedly has a confusing interface.

(B) Select and copy the old user agent identification for Firefox 39:

Mozilla/5.0 (Windows NT 5.1; rv:39.0) Gecko/20100101 Firefox/39.0

(C) While on a youtube.com page, click the little drop-down triangle for ua-site-switch and paste the old user agent string and then press Enter to save it

(D) Then reload YouTube bypassing cached files (Ctrl+Shift+r)

(E) Repeat B & C on https://www.youtube-nocookie.com/ to apply the hack to embedded videos

more options

Thanks very much jscher. I switched 'media.mediasource.webm.enabled' to 'true'. Youtube still plays with the HTML5 player (confirmed via the right click context menu, thanks), but I can now choose video resolutions. The Youtube html5 page now shows I'm okay on VP9, but not H264. On another video streaming site, I'm now able to choose Flash player again so that is solved too. Thank you for the Firefox addons also. I'll keep those in mind if there are further issues. This computer is pretty old anyway, so I'll be upgrading to a new machine with a more current Windows install pretty soon in any case.

Muudetud manacatsirman poolt